summaryrefslogtreecommitdiff
path: root/system/nvi/build-fix.patch
diff options
context:
space:
mode:
Diffstat (limited to 'system/nvi/build-fix.patch')
-rw-r--r--system/nvi/build-fix.patch19
1 files changed, 19 insertions, 0 deletions
diff --git a/system/nvi/build-fix.patch b/system/nvi/build-fix.patch
new file mode 100644
index 000000000..3839b7461
--- /dev/null
+++ b/system/nvi/build-fix.patch
@@ -0,0 +1,19 @@
+--- nvi-1.79/build/Makefile.in.old 1996-10-23 13:43:38.000000000 +0000
++++ nvi-1.79/build/Makefile.in 2018-08-08 00:47:23.110000000 +0000
+@@ -137,16 +137,6 @@
+ $(chmod) $(dmode) $(datadir)/vi/catalog
+ (cd $(srcdir)/catalog && $(cp) $(cat) $(datadir)/vi/catalog && \
+ cd $(datadir)/vi/catalog && $(chmod) $(fmode) *)
+- @echo "Installing Perl scripts: $(datadir)/vi/perl ..."
+- $(mkdir) $(datadir)/vi/perl && $(chmod) $(dmode) $(datadir)/vi/perl
+- [ -f VI.pm ] && $(cp) VI.pm $(datadir)/vi/perl && \
+- cd $(datadir)/vi/perl && $(chmod) $(fmode) VI.pm)
+- (cd $(srcdir)/perl_scripts && $(cp) *.pl $(datadir)/vi/perl && \
+- cd $(datadir)/vi/perl && $(chmod) $(fmode) *.pl)
+- @echo "Installing Tcl scripts: $(datadir)/vi/tcl ..."
+- $(mkdir) $(datadir)/vi/tcl && $(chmod) $(dmode) $(datadir)/vi/tcl
+- (cd $(srcdir)/tcl_scripts && $(cp) *.tcl $(datadir)/vi/tcl && \
+- cd $(datadir)/vi/tcl && $(chmod) $(fmode) *.tcl)
+ @echo "Installing recover script: $(datadir)/vi/recover ..."
+ ($(cp) recover $(datadir)/vi/recover && \
+ $(chmod) $(emode) $(datadir)/vi/recover)