summaryrefslogtreecommitdiff
path: root/system/openssh/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'system/openssh/APKBUILD')
-rw-r--r--system/openssh/APKBUILD18
1 files changed, 14 insertions, 4 deletions
diff --git a/system/openssh/APKBUILD b/system/openssh/APKBUILD
index 05c36455b..a393066ef 100644
--- a/system/openssh/APKBUILD
+++ b/system/openssh/APKBUILD
@@ -4,14 +4,14 @@
pkgname=openssh
pkgver=9.4_p1
_myver=${pkgver%_*}${pkgver#*_}
-pkgrel=0
+pkgrel=1
pkgdesc="Remote login tool using encrypted SSH protocol"
url="https://www.openssh.com/portable.html"
arch="all"
options="suid !check"
license="BSD-1-Clause AND BSD-2-Clause AND BSD-3-Clause"
depends="openssh-client openssh-sftp-server openssh-server"
-makedepends_build="linux-pam-dev gettext-tiny"
+makedepends_build="autoconf automake libtool linux-pam-dev gettext-tiny"
makedepends_host="openssl-dev zlib-dev linux-headers linux-pam-dev
gettext-tiny-dev utmps-dev"
makedepends="$makedepends_build $makedepends_host"
@@ -29,6 +29,7 @@ source="https://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/$pkgname-$_myver.ta
fix-utmpx.patch
sftp-interactive.patch
time64-seccomp.patch
+ utmp-header-check.patch
sshd.initd
sshd.confd
@@ -52,6 +53,11 @@ source="https://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/$pkgname-$_myver.ta
builddir="$srcdir"/$pkgname-$_myver
+prepare() {
+ default_prepare
+ autoreconf -vif
+}
+
build() {
export LD="$CC"
LIBS="-lutmps -lskarnet" ./configure --build=$CBUILD \
@@ -63,9 +69,12 @@ build() {
--with-pid-dir=/run \
--with-mantype=man \
--with-ldflags="${LDFLAGS}" \
+ --disable-utmp \
+ --disable-wtmp \
--enable-lastlog \
+ --enable-utmpx \
+ --enable-wtmpx \
--disable-strip \
- --enable-wtmp \
--with-privsep-path=/var/empty \
--with-xauth=/usr/bin/xauth \
--with-privsep-user=sshd \
@@ -150,8 +159,9 @@ openrc() {
sha512sums="0aaedeced7dbc70419c7245eb0e9db4ef570e0e7739b890ebae04d56da5fe8d147e8e150f3c943f60730976569e3ac6cc8da62ec7e2a78e2ef47d295ca0b1d25 openssh-9.4p1.tar.gz
f3d5960572ddf49635d4edbdff45835df1b538a81840db169c36b39862e6fa8b0393ca90626000b758f59567ff6810b2537304098652483b3b31fb438a061de6 disable-forwarding-by-default.patch
-70bffa6c061a02dd790dbaa68cd0b488395aa2312039b037e1a707e8cf7465754bf376d943d351914b64044c074af7504e845de865dec45ea00d992c2bbb8925 fix-utmpx.patch
+81993408a6d48797e59229c282409506d09baf8c7b97fceafc32d9d9cfc2a3d92b25d685c1021a9e647e62d6335c579b2efed089212a806eaeb20ce9cfd8918e fix-utmpx.patch
34c0673f550e7afcd47eda4fe1da48fb42e5344c95ba8064c9c3c137fda9c43635b0f7b8145d0300f59c79f75a396ebd467afb54cdaa42aa251d624d0752dc84 sftp-interactive.patch
ad5b209f7f3fff69c10bae34da143e071e107a2141eee94f393532d6bb04a36bfe6d9b5d2c08b713f67118503c38d11b4aad689df1df7c8a918d52db8326821d time64-seccomp.patch
+76dcb3c46a2ce1c92c48058b7fdcb8d3230afefc16b80ab6b816bf21bd250ef67488e648fbe65b5d13ccf07bb748409751f1a54c0df9655a70d355648bf612bb utmp-header-check.patch
964c0f8538ba25bdc9cdbd1467bbdfb2090e38492ff0ef7c64473785713fe26d752ea6a7b0ee7a0b34e08f4d3b4bccf6a69e6c456f0c57d0d0c581aa8a046936 sshd.initd
ce0abddbd2004891f88efd8522c4b37a4989290269fab339c0fa9aacc051f7fd3b20813e192e92e0e64315750041cb74012d4321260f4865ff69d7a935b259d4 sshd.confd"