summaryrefslogtreecommitdiff
path: root/system/paxmark/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'system/paxmark/APKBUILD')
-rw-r--r--system/paxmark/APKBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/system/paxmark/APKBUILD b/system/paxmark/APKBUILD
new file mode 100644
index 000000000..767803915
--- /dev/null
+++ b/system/paxmark/APKBUILD
@@ -0,0 +1,23 @@
+# Contributor: Timo Teräs <timo.teras@iki.fi>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=paxmark
+pkgver=0.11
+pkgrel=0
+pkgdesc="Manage PaX marking of executables"
+url="https://alpinelinux.org"
+arch="noarch"
+options="!check"
+license="GPL-2.0-only"
+depends="attr"
+makedepends=""
+install=""
+subpackages=""
+source="paxmark"
+
+package() {
+ mkdir -p "$pkgdir"/usr/sbin
+ install -m755 "$srcdir"/paxmark "$pkgdir"/usr/sbin
+ ln -s paxmark "$pkgdir"/usr/sbin/paxmark.sh
+}
+
+sha512sums="c43b5a48a8ac14b027114f712820b1fb8b0e209fcfe1a69eb64b4c68289a3bb3f26c3ea40350cbfdaa97329b4a8e1de2582025e5221c3016aff85bb75118e665 paxmark"