summaryrefslogtreecommitdiff
path: root/system/perl-authen-sasl/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'system/perl-authen-sasl/APKBUILD')
-rw-r--r--system/perl-authen-sasl/APKBUILD17
1 files changed, 7 insertions, 10 deletions
diff --git a/system/perl-authen-sasl/APKBUILD b/system/perl-authen-sasl/APKBUILD
index b894d9dee..74afc7ab0 100644
--- a/system/perl-authen-sasl/APKBUILD
+++ b/system/perl-authen-sasl/APKBUILD
@@ -1,6 +1,9 @@
# Maintainer: Adélie Perl Team <adelie-perl@lists.adelielinux.org>
pkgname=perl-authen-sasl
-_realname=Authen-SASL
+_pkgreal=Authen-SASL
+_author=GBARR
+_au=${_author%%"${_author#??}"}
+_a=${_author%%"${_author#?}"}
pkgver=2.16
pkgrel=2
pkgdesc="SASL authentication framework for Perl"
@@ -8,28 +11,22 @@ url="https://metacpan.org/release/Authen-SASL"
arch="noarch"
license="GPL-2.0-only OR Artistic-1.0-Perl"
depends="perl perl-digest-hmac"
-makedepends="perl-dev perl-module-install"
-install=
+makedepends="perl-module-install"
subpackages="$pkgname-doc"
-source="https://search.cpan.org/CPAN/authors/id/G/GB/GBARR/Authen-SASL-$pkgver.tar.gz"
-builddir="$srcdir/$_realname-$pkgver"
+source="https://cpan.metacpan.org/authors/id/$_a/$_au/$_author/Authen-SASL-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgreal-$pkgver"
build() {
- cd "$builddir"
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
make
}
check() {
- cd "$builddir"
make test
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
-
- # creates file collision among perl modules
find "$pkgdir" -name perllocal.pod -delete
}