summaryrefslogtreecommitdiff
path: root/system/perl-cpanel-json-xs/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'system/perl-cpanel-json-xs/APKBUILD')
-rw-r--r--system/perl-cpanel-json-xs/APKBUILD21
1 files changed, 7 insertions, 14 deletions
diff --git a/system/perl-cpanel-json-xs/APKBUILD b/system/perl-cpanel-json-xs/APKBUILD
index ef5094438..8e8ac6a9f 100644
--- a/system/perl-cpanel-json-xs/APKBUILD
+++ b/system/perl-cpanel-json-xs/APKBUILD
@@ -3,39 +3,32 @@
# Maintainer: Adélie Perl Team <adelie-perl@lists.adelielinux.org>
pkgname=perl-cpanel-json-xs
_pkgreal=Cpanel-JSON-XS
+_author=RURBAN
+_au=${_author%%"${_author#??}"}
+_a=${_author%%"${_author#?}"}
pkgver=4.12
pkgrel=0
pkgdesc="cPanel's fork of JSON::XS, fast and correct serialising"
url="https://metacpan.org/release/Cpanel-JSON-XS"
arch="all"
license="GPL-2.0-only OR Artistic-1.0-Perl"
-cpandepends=""
-cpanmakedepends="perl-json perl-test-leaktrace"
-depends="$cpandepends"
-makedepends="perl-dev $cpanmakedepends"
+depends="perl"
+makedepends="perl-dev perl-json perl-test-leaktrace"
subpackages="$pkgname-doc"
-source="https://search.cpan.org/CPAN/authors/id/R/RU/RURBAN/$_pkgreal-$pkgver.tar.gz"
+source="https://cpan.metacpan.org/authors/id/$_a/$_au/$_author/$_pkgreal-$pkgver.tar.gz"
builddir="$srcdir/$_pkgreal-$pkgver"
-prepare() {
- cd "$builddir"
- export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
-}
-
build() {
- cd "$builddir"
export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
make
}
check() {
- cd "$builddir"
make test
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}