summaryrefslogtreecommitdiff
path: root/system/perl-cpanel-json-xs
diff options
context:
space:
mode:
Diffstat (limited to 'system/perl-cpanel-json-xs')
-rw-r--r--system/perl-cpanel-json-xs/APKBUILD43
1 files changed, 43 insertions, 0 deletions
diff --git a/system/perl-cpanel-json-xs/APKBUILD b/system/perl-cpanel-json-xs/APKBUILD
new file mode 100644
index 000000000..801c2e226
--- /dev/null
+++ b/system/perl-cpanel-json-xs/APKBUILD
@@ -0,0 +1,43 @@
+# Automatically generated by apkbuild-cpan, template 1
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Adélie Perl Team <adelie-perl@lists.adelielinux.org>
+pkgname=perl-cpanel-json-xs
+_pkgreal=Cpanel-JSON-XS
+pkgver=4.04
+pkgrel=0
+pkgdesc="cPanel's fork of JSON::XS, fast and correct serialising"
+url="http://search.cpan.org/dist/Cpanel-JSON-XS/"
+arch="all"
+license="GPL-2.0-only OR Artistic-1.0-Perl"
+cpandepends=""
+cpanmakedepends="perl-json perl-test-leaktrace"
+depends="$cpandepends"
+makedepends="perl-dev $cpanmakedepends"
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/R/RU/RURBAN/$_pkgreal-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgreal-$pkgver"
+
+prepare() {
+ cd "$builddir"
+ export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+}
+
+build() {
+ cd "$builddir"
+ export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ make
+}
+
+check() {
+ cd "$builddir"
+ make test
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+sha512sums="6b2479ee89f2b8c79ef979cecbdb6f29c28ee37ab530eabc9070728ba37063be3c5836571bea84d537dc93f8586cca71fd3bdca5e420c1d6a2eabf2547ca1db7 Cpanel-JSON-XS-4.04.tar.gz"