summaryrefslogtreecommitdiff
path: root/system/perl-digest-sha1/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'system/perl-digest-sha1/APKBUILD')
-rw-r--r--system/perl-digest-sha1/APKBUILD20
1 files changed, 7 insertions, 13 deletions
diff --git a/system/perl-digest-sha1/APKBUILD b/system/perl-digest-sha1/APKBUILD
index 9d4155ce1..99c8f59a7 100644
--- a/system/perl-digest-sha1/APKBUILD
+++ b/system/perl-digest-sha1/APKBUILD
@@ -1,7 +1,10 @@
# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
# Maintainer: Adélie Perl Team <adelie-perl@lists.adelielinux.org>
pkgname=perl-digest-sha1
-_realname=Digest-SHA1
+_pkgreal=Digest-SHA1
+_author=GAAS
+_au=${_author%%"${_author#??}"}
+_a=${_author%%"${_author#?}"}
pkgver=2.13
pkgrel=11
pkgdesc="Perl interface to the SHA-1 algorithm"
@@ -10,32 +13,23 @@ arch="all"
license="GPL-2.0-only OR Artistic-1.0-Perl"
depends="perl"
makedepends="perl-dev"
-install=
subpackages="$pkgname-doc"
-source="https://search.cpan.org/CPAN/authors/id/G/GA/GAAS/$_realname-$pkgver.tar.gz
+source="https://cpan.metacpan.org/authors/id/$_a/$_au/$_author/$_pkgreal-$pkgver.tar.gz
perl-digest-sha1-check-object.patch
"
-builddir="$srcdir/$_realname-$pkgver"
+builddir="$srcdir/$_pkgreal-$pkgver"
-prepare() {
- cd "$builddir"
- default_prepare
+build() {
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor \
OPTIMIZE="$CFLAGS"
-}
-
-build() {
- cd "$builddir"
make
}
check() {
- cd "$builddir"
make test
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
# creates file collision among perl modules
find "$pkgdir" -name perllocal.pod -delete