summaryrefslogtreecommitdiff
path: root/system/perl-file-listing/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'system/perl-file-listing/APKBUILD')
-rw-r--r--system/perl-file-listing/APKBUILD20
1 files changed, 9 insertions, 11 deletions
diff --git a/system/perl-file-listing/APKBUILD b/system/perl-file-listing/APKBUILD
index db9ea786a..2f90ff91f 100644
--- a/system/perl-file-listing/APKBUILD
+++ b/system/perl-file-listing/APKBUILD
@@ -1,34 +1,32 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Adélie Perl Team <adelie-perl@lists.adelielinux.org>
pkgname=perl-file-listing
+_pkgreal=File-Listing
+_author=GAAS
+_au=${_author%%"${_author#??}"}
+_a=${_author%%"${_author#?}"}
pkgver=6.04
pkgrel=2
-pkgdesc="File::Listing perl module"
+pkgdesc="Perl module for parsing directory lists in various formats"
url="https://metacpan.org/release/File-Listing"
arch="noarch"
license="GPL-2.0-only OR Artistic-1.0-Perl"
-depends="perl perl-http-date"
-makedepends="perl-dev"
-install=""
-replaces="perl-libwww"
+depends="perl-http-date"
+makedepends=""
subpackages="$pkgname-doc"
-source="https://search.cpan.org/CPAN/authors/id/G/GA/GAAS/File-Listing-$pkgver.tar.gz"
-
-builddir="$srcdir"/File-Listing-$pkgver
+source="https://cpan.metacpan.org/authors/id/$_a/$_au/$_author/$_pkgreal-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgreal-$pkgver"
build() {
- cd "$builddir"
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
make
}
check() {
- cd "$builddir"
make test
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}