summaryrefslogtreecommitdiff
path: root/system/perl-http-daemon/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'system/perl-http-daemon/APKBUILD')
-rw-r--r--system/perl-http-daemon/APKBUILD17
1 files changed, 8 insertions, 9 deletions
diff --git a/system/perl-http-daemon/APKBUILD b/system/perl-http-daemon/APKBUILD
index a0fc81ce5..aed0d4aae 100644
--- a/system/perl-http-daemon/APKBUILD
+++ b/system/perl-http-daemon/APKBUILD
@@ -1,25 +1,24 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Adélie Perl Team <adelie-perl@lists.adelielinux.org>
pkgname=perl-http-daemon
+_pkgreal=HTTP-Daemon
pkgver=6.06
-_author=O
-_author2=${_author}A
-_author3=${_author2}LDERS
+_author=OALDERS
+_au=${_author%%"${_author#??}"}
+_a=${_author%%"${_author#?}"}
pkgrel=0
pkgdesc="HTTP::Daemon perl module"
url="https://metacpan.org/release/HTTP-Daemon"
arch="noarch"
license="GPL-2.0-only or Artistic-1.0-Perl"
-depends="perl perl-http-date perl-http-message"
+depends="perl-http-date perl-http-message"
checkdepends="perl-test-needs"
-makedepends="perl-dev perl-module-build"
-replaces="perl-libwww"
+makedepends="perl-module-build"
subpackages="$pkgname-doc"
-source="https://search.cpan.org/CPAN/authors/id/$_author/$_author2/$_author3/HTTP-Daemon-$pkgver.tar.gz"
-builddir="$srcdir"/HTTP-Daemon-$pkgver
+source="https://cpan.metacpan.org/authors/id/$_a/$_au/$_author/$_pkgreal-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgreal-$pkgver"
build() {
- # use Module::Build for non-/usr/local, not Module::Build::Tiny.
PERL_MB_FALLBACK_SILENCE_WARNING=1 perl Build.PL installdirs=vendor
./Build
}