summaryrefslogtreecommitdiff
path: root/system/perl-http-daemon
diff options
context:
space:
mode:
Diffstat (limited to 'system/perl-http-daemon')
-rw-r--r--system/perl-http-daemon/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/system/perl-http-daemon/APKBUILD b/system/perl-http-daemon/APKBUILD
new file mode 100644
index 000000000..f8f330398
--- /dev/null
+++ b/system/perl-http-daemon/APKBUILD
@@ -0,0 +1,35 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Adélie Perl Team <adelie-perl@lists.adelielinux.org>
+pkgname=perl-http-daemon
+pkgver=6.01
+pkgrel=2
+pkgdesc="HTTP::Daemon perl module"
+url="http://search.cpan.org/dist/HTTP-Daemon/"
+arch="noarch"
+license="GPL-2.0-only or Artistic-1.0-Perl"
+depends="perl perl-http-date perl-http-message"
+makedepends="perl-dev"
+install=""
+replaces="perl-libwww"
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/G/GA/GAAS/HTTP-Daemon-$pkgver.tar.gz"
+builddir="$srcdir"/HTTP-Daemon-$pkgver
+
+build() {
+ cd "$builddir"
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ cd "$builddir"
+ make test
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+sha512sums="8d2b8cd9c9386defb256457e160492d78cd6a7d962514522c62d6f8d3dd1cb6f7019b7a1a70b13f340ef54538eef02629a13861864f2f79306f1da7255fa887b HTTP-Daemon-6.01.tar.gz"