summaryrefslogtreecommitdiff
path: root/system/perl-http-date/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'system/perl-http-date/APKBUILD')
-rw-r--r--system/perl-http-date/APKBUILD18
1 files changed, 7 insertions, 11 deletions
diff --git a/system/perl-http-date/APKBUILD b/system/perl-http-date/APKBUILD
index 4cfb54549..5bf34a0f0 100644
--- a/system/perl-http-date/APKBUILD
+++ b/system/perl-http-date/APKBUILD
@@ -1,7 +1,10 @@
# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
# Maintainer: Adélie Perl Team <adelie-perl@lists.adelielinux.org>
pkgname=perl-http-date
-_realname=HTTP-Date
+_pkgreal=HTTP-Date
+_author=GAAS
+_au=${_author%%"${_author#??}"}
+_a=${_author%%"${_author#?}"}
pkgver=6.02
pkgrel=2
pkgdesc="Perl module date conversion routines"
@@ -9,29 +12,22 @@ url="https://metacpan.org/release/HTTP-Date"
arch="noarch"
license="GPL-2.0-only OR Artistic-1.0-Perl"
depends="perl"
-makedepends="perl-dev"
-replaces="perl-libwww"
-install=
+makedepends=""
subpackages="$pkgname-doc"
-source="https://search.cpan.org/CPAN/authors/id/G/GA/GAAS/$_realname-$pkgver.tar.gz"
-
-builddir="$srcdir/$_realname-$pkgver"
+source="https://cpan.metacpan.org/authors/id/$_a/$_au/$_author/$_pkgreal-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgreal-$pkgver"
build() {
- cd "$builddir"
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
make
}
check() {
- cd "$builddir"
make test
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
- # creates file collision among perl modules
find "$pkgdir" -name perllocal.pod -delete
}