summaryrefslogtreecommitdiff
path: root/system/perl-io-html/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'system/perl-io-html/APKBUILD')
-rw-r--r--system/perl-io-html/APKBUILD22
1 files changed, 7 insertions, 15 deletions
diff --git a/system/perl-io-html/APKBUILD b/system/perl-io-html/APKBUILD
index 7d32a8dbd..9d563e046 100644
--- a/system/perl-io-html/APKBUILD
+++ b/system/perl-io-html/APKBUILD
@@ -2,39 +2,31 @@
# Maintainer: Adélie Perl Team <adelie-perl@lists.adelielinux.org>
pkgname=perl-io-html
_pkgreal=IO-HTML
+_author=CJM
+_au=${_author%%"${_author#??}"}
+_a=${_author%%"${_author#?}"}
pkgver=1.001
pkgrel=2
pkgdesc="Open an HTML file with automatic charset detection"
url="https://metacpan.org/release/IO-HTML"
arch="noarch"
license="GPL-2.0-only OR Artistic-1.0-Perl"
-cpandepends=""
-cpanmakedepends=""
-depends="$cpandepends"
-makedepends="perl-dev $cpanmakedepends"
+depends="perl"
+makedepends=""
subpackages="$pkgname-doc"
-source="https://search.cpan.org/CPAN/authors/id/C/CJ/CJM/$_pkgreal-$pkgver.tar.gz"
+source="https://cpan.metacpan.org/authors/id/$_a/$_au/$_author/$_pkgreal-$pkgver.tar.gz"
builddir="$srcdir/$_pkgreal-$pkgver"
-prepare() {
- cd "$builddir"
- export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
-}
-
build() {
- cd "$builddir"
- export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
make
}
check() {
- cd "$builddir"
make test
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}