summaryrefslogtreecommitdiff
path: root/system/perl-ipc-run3/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'system/perl-ipc-run3/APKBUILD')
-rw-r--r--system/perl-ipc-run3/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/system/perl-ipc-run3/APKBUILD b/system/perl-ipc-run3/APKBUILD
new file mode 100644
index 000000000..51a428e6d
--- /dev/null
+++ b/system/perl-ipc-run3/APKBUILD
@@ -0,0 +1,34 @@
+# Contributor: A. Wilcox <awilfox@adelielinux.org>
+# Maintainer: Síle Ekaterin Liszka <sheila@vulpine.house>
+pkgname=perl-ipc-run3
+_pkgreal=IPC-Run3
+_author=RJBS
+_au=${_author%%"${_author#??}"}
+_a=${_author%%"${_author#?}"}
+pkgver=0.048
+pkgrel=0
+pkgdesc="Run a subprocess from Perl with I/O redirection"
+url="https://metacpan.org/release/IPC-Run3"
+arch="noarch"
+license="GPL-1.0+ OR BSD-2-Clause OR Artistic-1.0-Perl OR Artistic-2.0"
+depends="perl"
+makedepends="perl-dev"
+subpackages="$pkgname-doc"
+source="https://cpan.metacpan.org/authors/id/$_a/$_au/$_author/$_pkgreal-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgreal-$pkgver"
+
+build() {
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ make test
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+sha512sums="50432850d8dccd2e59aa6684d34f3e3242fd7df3eb4d9a5eb02dae389aa46b5fd68cc54114a157c3fe99956e68e74d575ab3db5009b7bf7d5c325f1f109b1262 IPC-Run3-0.048.tar.gz"