summaryrefslogtreecommitdiff
path: root/system/perl-json/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'system/perl-json/APKBUILD')
-rw-r--r--system/perl-json/APKBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/system/perl-json/APKBUILD b/system/perl-json/APKBUILD
index ee036d859..ee0c36dc8 100644
--- a/system/perl-json/APKBUILD
+++ b/system/perl-json/APKBUILD
@@ -2,31 +2,31 @@
# Maintainer: Adélie Perl Team <adelie-perl@lists.adelielinux.org>
pkgname=perl-json
_pkgreal=JSON
+_author=ISHIGAKI
+_au=${_author%%"${_author#??}"}
+_a=${_author%%"${_author#?}"}
pkgver=4.02
pkgrel=0
pkgdesc="Perl module implementing a JSON encoder/decoder"
url="https://metacpan.org/release/JSON"
arch="noarch"
license="GPL-2.0-only OR Artistic-1.0-Perl"
-makedepends="perl-dev"
+depends="perl"
+makedepends=""
subpackages="$pkgname-doc"
-source="https://search.cpan.org/CPAN/authors/id/I/IS/ISHIGAKI/$_pkgreal-$pkgver.tar.gz"
-
+source="https://cpan.metacpan.org/authors/id/$_a/$_au/$_author/$_pkgreal-$pkgver.tar.gz"
builddir="$srcdir/$_pkgreal-$pkgver"
build() {
- cd "$builddir"
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
make
}
check() {
- cd "$builddir"
make test
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
find "$pkgdir" -name perllocal.pod -delete
find "$pkgdir" -name .packlist -delete