summaryrefslogtreecommitdiff
path: root/system/perl-libwww/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'system/perl-libwww/APKBUILD')
-rw-r--r--system/perl-libwww/APKBUILD15
1 files changed, 8 insertions, 7 deletions
diff --git a/system/perl-libwww/APKBUILD b/system/perl-libwww/APKBUILD
index 6b62d0b33..61644804c 100644
--- a/system/perl-libwww/APKBUILD
+++ b/system/perl-libwww/APKBUILD
@@ -1,10 +1,10 @@
# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
# Maintainer: Adélie Perl Team <adelie-perl@lists.adelielinux.org>
pkgname=perl-libwww
-_realname=libwww-perl
-_author1=O
-_author2=${_author1}A
-_author=${_author2}LDERS
+_pkgreal=libwww-perl
+_author=OALDERS
+_au=${_author%%"${_author#??}"}
+_a=${_author%%"${_author#?}"}
pkgver=6.39
pkgrel=0
pkgdesc="Perl module - World Wide Web library"
@@ -15,10 +15,11 @@ depends="perl-http-date perl-http-cookies perl-net-http perl-http-daemon
perl-html-parser perl-file-listing perl-www-robotrules
perl-http-negotiate perl-uri perl-http-message perl-test-needs
perl-lwp-mediatypes perl-encode-locale perl-try-tiny"
-makedepends="perl-dev perl-test-fatal perl-test-requiresinternet"
+makedepends=""
+checkdepends="perl-test-fatal perl-test-requiresinternet"
subpackages="$pkgname-doc"
-source="$pkgname-$pkgver.tar.gz::https://cpan.metacpan.org/authors/id/$_author1/$_author2/$_author/libwww-perl-$pkgver.tar.gz"
-builddir="$srcdir/$_realname-$pkgver"
+source="$pkgname-$pkgver.tar.gz::https://cpan.metacpan.org/authors/id/$_a/$_au/$_author/libwww-perl-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgreal-$pkgver"
build() {
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor