summaryrefslogtreecommitdiff
path: root/system/perl-module-build/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'system/perl-module-build/APKBUILD')
-rw-r--r--system/perl-module-build/APKBUILD25
1 files changed, 8 insertions, 17 deletions
diff --git a/system/perl-module-build/APKBUILD b/system/perl-module-build/APKBUILD
index 72b5d4bb7..84554d859 100644
--- a/system/perl-module-build/APKBUILD
+++ b/system/perl-module-build/APKBUILD
@@ -3,41 +3,32 @@
# Maintainer: Adélie Perl Team <adelie-perl@lists.adelielinux.org>
pkgname=perl-module-build
_pkgreal=Module-Build
+_author=LEONT
+_au=${_author%%"${_author#??}"}
+_a=${_author%%"${_author#?}"}
pkgver=0.4229
pkgrel=0
pkgdesc="Build and install Perl modules"
url="https://metacpan.org/release/Module-Build"
arch="noarch"
license="GPL-2.0-only AND Artistic-1.0-Perl"
-cpandepends=""
-cpanmakedepends=""
-depends="$cpandepends"
-makedepends="perl-dev $cpanmakedepends"
+depends="perl"
+makedepends=""
subpackages="$pkgname-doc"
-source="https://search.cpan.org/CPAN/authors/id/L/LE/LEONT/$_pkgreal-$pkgver.tar.gz"
-
+source="https://cpan.metacpan.org/authors/id/$_a/$_au/$_author/$_pkgreal-$pkgver.tar.gz"
builddir="$srcdir/$_pkgreal-$pkgver"
-prepare() {
- cd "$builddir"
- export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
- perl Build.PL installdirs=vendor
-}
-
build() {
- cd "$builddir"
- export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ perl Build.PL --installdirs=vendor
./Build
}
check() {
- cd "$builddir"
./Build test
}
package() {
- cd "$builddir"
- ./Build install destdir="$pkgdir"
+ ./Build install --destdir="$pkgdir"
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}