summaryrefslogtreecommitdiff
path: root/system/perl-test-fatal/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'system/perl-test-fatal/APKBUILD')
-rw-r--r--system/perl-test-fatal/APKBUILD22
1 files changed, 8 insertions, 14 deletions
diff --git a/system/perl-test-fatal/APKBUILD b/system/perl-test-fatal/APKBUILD
index f767bfb56..f6336e2af 100644
--- a/system/perl-test-fatal/APKBUILD
+++ b/system/perl-test-fatal/APKBUILD
@@ -3,37 +3,31 @@
# Maintainer: Adélie Perl Team <adelie-perl@lists.adelielinux.org>
pkgname=perl-test-fatal
_pkgreal=Test-Fatal
+_author=RJBS
+_au=${_author%%"${_author#??}"}
+_a=${_author%%"${_author#?}"}
pkgver=0.014
pkgrel=1
-pkgdesc="incredibly simple helpers for testing code with exceptions"
+pkgdesc="Simple helpers for testing code with exceptions"
url="https://metacpan.org/release/Test-Fatal"
arch="noarch"
license="GPL-2.0-only OR Artistic-1.0-Perl"
-cpandepends="perl-try-tiny"
-cpanmakedepends=""
-depends="$cpandepends"
-makedepends="perl-dev $cpanmakedepends"
+depends="perl-try-tiny"
+makedepends=""
subpackages="$pkgname-doc"
-source="https://search.cpan.org/CPAN/authors/id/R/RJ/RJBS/$_pkgreal-$pkgver.tar.gz"
+source="https://cpan.metacpan.org/authors/id/$_a/$_au/$_author/$_pkgreal-$pkgver.tar.gz"
builddir="$srcdir/$_pkgreal-$pkgver"
-prepare() {
- cd "$builddir"
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
-}
-
build() {
- cd "$builddir"
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
make
}
check() {
- cd "$builddir"
make test
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}