summaryrefslogtreecommitdiff
path: root/system/perl-test-pod/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'system/perl-test-pod/APKBUILD')
-rw-r--r--system/perl-test-pod/APKBUILD23
1 files changed, 7 insertions, 16 deletions
diff --git a/system/perl-test-pod/APKBUILD b/system/perl-test-pod/APKBUILD
index 9385c2c1c..8f5bbc7ee 100644
--- a/system/perl-test-pod/APKBUILD
+++ b/system/perl-test-pod/APKBUILD
@@ -3,40 +3,31 @@
# Maintainer: Adélie Perl Team <adelie-perl@lists.adelielinux.org>
pkgname=perl-test-pod
_pkgreal=Test-Pod
+_author=ETHER
+_au=${_author%%"${_author#??}"}
+_a=${_author%%"${_author#?}"}
pkgver=1.52
pkgrel=0
pkgdesc="Check for POD errors in files"
url="https://metacpan.org/release/Test-Pod"
arch="noarch"
license="GPL-2.0-only AND Artistic-1.0-Perl"
-cpandepends=""
-cpanmakedepends=""
-depends="$cpandepends"
-makedepends="perl-dev $cpanmakedepends"
+depends="perl"
+makedepends=""
subpackages="$pkgname-doc"
-source="https://search.cpan.org/CPAN/authors/id/E/ET/ETHER/$_pkgreal-$pkgver.tar.gz"
-
+source="https://cpan.metacpan.org/authors/id/$_a/$_au/$_author/$_pkgreal-$pkgver.tar.gz"
builddir="$srcdir/$_pkgreal-$pkgver"
-prepare() {
- cd "$builddir"
- export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
-}
-
build() {
- cd "$builddir"
- export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
make
}
check() {
- cd "$builddir"
make test
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}