summaryrefslogtreecommitdiff
path: root/system/perl-test-warnings/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'system/perl-test-warnings/APKBUILD')
-rw-r--r--system/perl-test-warnings/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/system/perl-test-warnings/APKBUILD b/system/perl-test-warnings/APKBUILD
new file mode 100644
index 000000000..8dace4f45
--- /dev/null
+++ b/system/perl-test-warnings/APKBUILD
@@ -0,0 +1,34 @@
+# Contributor: Dan Theisen <djt@hxx.in>
+# Maintainer: Síle Ekaterin Liszka <sheila@vulpine.house>
+pkgname=perl-test-warnings
+_pkgreal=Test-Warnings
+_author=ETHER
+_au=${_author%%"${_author#??}"}
+_a=${_author%%"${_author#?}"}
+pkgver=0.031
+pkgrel=0
+pkgdesc="Test for warnings and the lack of them"
+url="https://metacpan.org/pod/Test::Warnings"
+arch="noarch"
+license="Artistic-1.0-Perl OR GPL-1.0+"
+depends="perl"
+makedepends="perl-dev"
+subpackages="$pkgname-doc"
+source="https://cpan.metacpan.org/authors/id/$_a/$_au/$_author/$_pkgreal-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgreal-$pkgver"
+
+build() {
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ make test
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+sha512sums="02ddd342b6aa8771dd6ea3b7385c5eb970173633d49a3535bc46c3f98a66cd6e81895fc5f38cbe23366c8fa0f96121b51a8180b0d4ef0f2d8c658bb559c72c58 Test-Warnings-0.031.tar.gz"