summaryrefslogtreecommitdiff
path: root/system/perl-try-tiny/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'system/perl-try-tiny/APKBUILD')
-rw-r--r--system/perl-try-tiny/APKBUILD21
1 files changed, 7 insertions, 14 deletions
diff --git a/system/perl-try-tiny/APKBUILD b/system/perl-try-tiny/APKBUILD
index 0ce6d0cfb..36129e2a3 100644
--- a/system/perl-try-tiny/APKBUILD
+++ b/system/perl-try-tiny/APKBUILD
@@ -3,38 +3,31 @@
# Maintainer: Adélie Perl Team <adelie-perl@lists.adelielinux.org>
pkgname=perl-try-tiny
_pkgreal=Try-Tiny
+_author=ETHER
+_au=${_author%%"${_author#??}"}
+_a=${_author%%"${_author#?}"}
pkgver=0.30
pkgrel=0
pkgdesc="Minimal Perl try/catch with proper environment preservation"
url="https://metacpan.org/release/Try-Tiny"
arch="noarch"
license="GPL-2.0-only OR Artistic-1.0-Perl"
-cpandepends=""
-cpanmakedepends=""
-depends="$cpandepends"
-makedepends="perl-dev $cpanmakedepends"
+depends="perl"
+makedepends=""
subpackages="$pkgname-doc"
-source="https://search.cpan.org/CPAN/authors/id/E/ET/ETHER/$_pkgreal-$pkgver.tar.gz"
-
+source="https://cpan.metacpan.org/authors/id/$_a/$_au/$_author/$_pkgreal-$pkgver.tar.gz"
builddir="$srcdir/$_pkgreal-$pkgver"
-prepare() {
- cd "$builddir"
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
-}
-
build() {
- cd "$builddir"
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
make
}
check() {
- cd "$builddir"
make test
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}