summaryrefslogtreecommitdiff
path: root/system/perl-www-robotrules/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'system/perl-www-robotrules/APKBUILD')
-rw-r--r--system/perl-www-robotrules/APKBUILD16
1 files changed, 8 insertions, 8 deletions
diff --git a/system/perl-www-robotrules/APKBUILD b/system/perl-www-robotrules/APKBUILD
index 9911f3670..1bd5c777f 100644
--- a/system/perl-www-robotrules/APKBUILD
+++ b/system/perl-www-robotrules/APKBUILD
@@ -1,32 +1,32 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Adélie Perl Team <adelie-perl@lists.adelielinux.org>
pkgname=perl-www-robotrules
+_pkgreal=WWW-RobotRules
+_author=GAAS
+_au=${_author%%"${_author#??}"}
+_a=${_author%%"${_author#?}"}
pkgver=6.02
pkgrel=2
pkgdesc="Perl module for parsing /robots.txt files on HTTP servers"
url="https://metacpan.org/release/WWW-RobotRules"
arch="noarch"
license="GPL-2.0-only OR Artistic-1.0-Perl"
-depends="perl perl-uri"
-makedepends="perl-dev"
-replaces="perl-libwww"
+depends="perl-uri"
+makedepends=""
subpackages="$pkgname-doc"
-source="https://search.cpan.org/CPAN/authors/id/G/GA/GAAS/WWW-RobotRules-$pkgver.tar.gz"
-builddir="$srcdir"/WWW-RobotRules-$pkgver
+source="https://cpan.metacpan.org/authors/id/$_a/$_au/$_author/$_pkgreal-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgreal-$pkgver"
build() {
- cd "$builddir"
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
make
}
check() {
- cd "$builddir"
make test
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}