summaryrefslogtreecommitdiff
path: root/system/perl-yaml-tiny/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'system/perl-yaml-tiny/APKBUILD')
-rw-r--r--system/perl-yaml-tiny/APKBUILD21
1 files changed, 7 insertions, 14 deletions
diff --git a/system/perl-yaml-tiny/APKBUILD b/system/perl-yaml-tiny/APKBUILD
index 4570c5fb0..2419fdfb6 100644
--- a/system/perl-yaml-tiny/APKBUILD
+++ b/system/perl-yaml-tiny/APKBUILD
@@ -3,39 +3,32 @@
# Maintainer: Adélie Perl Team <adelie-perl@lists.adelielinux.org>
pkgname=perl-yaml-tiny
_pkgreal=YAML-Tiny
+_author=ETHER
+_au=${_author%%"${_author#??}"}
+_a=${_author%%"${_author#?}"}
pkgver=1.73
pkgrel=1
pkgdesc="YAML manipulation library for Perl"
url="https://metacpan.org/release/YAML-Tiny"
arch="noarch"
license="GPL-2.0-only OR Artistic-1.0-Perl"
-cpandepends=""
-cpanmakedepends="perl-json-maybexs"
-depends="$cpandepends"
-makedepends="perl-dev $cpanmakedepends"
+depends="perl"
+makedepends="perl-json-maybexs"
subpackages="$pkgname-doc"
-source="https://search.cpan.org/CPAN/authors/id/E/ET/ETHER/$_pkgreal-$pkgver.tar.gz"
+source="https://cpan.metacpan.org/authors/id/$_a/$_au/$_author/$_pkgreal-$pkgver.tar.gz"
builddir="$srcdir/$_pkgreal-$pkgver"
-prepare() {
- cd "$builddir"
- export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
-}
-
build() {
- cd "$builddir"
export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
make
}
check() {
- cd "$builddir"
make test
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install || return 1
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}