summaryrefslogtreecommitdiff
path: root/system/perl/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'system/perl/APKBUILD')
-rw-r--r--system/perl/APKBUILD6
1 files changed, 1 insertions, 5 deletions
diff --git a/system/perl/APKBUILD b/system/perl/APKBUILD
index 4df8d9e58..f65edd034 100644
--- a/system/perl/APKBUILD
+++ b/system/perl/APKBUILD
@@ -1,6 +1,6 @@
# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
# Contributor: Valery Kartel <valery.kartel@gmail.com>
-# Contributor: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
+# Contributor: Kiyoshi Aman <adelie@aerdan.vulpine.house>
# Maintainer: Adélie Perl Team <adelie-perl@lists.adelielinux.org>
# Proxy-For: solar
pkgname=perl
@@ -37,7 +37,6 @@ _archlib=/usr/lib/perl5/core_perl
prepare() {
chmod +w "$builddir"/*.c
default_prepare
- cd "$builddir"
sed -e 's/less -R/less/g' \
-e 's/libswanted="\(.*\) nsl\(.*\)"/libswanted="\1\2"/g' \
-i ./Configure ||
@@ -50,7 +49,6 @@ prepare() {
}
build() {
- cd "$builddir"
BUILD_ZLIB=0
BUILD_BZIP2=0
BZIP2_LIB=/usr/lib
@@ -89,12 +87,10 @@ build() {
}
check() {
- cd "$builddir"
make test
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
if [ -n "$(find $pkgdir/usr/local -type f)" ]; then
error "files found under /usr/local"