summaryrefslogtreecommitdiff
path: root/system/perl/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'system/perl/APKBUILD')
-rw-r--r--system/perl/APKBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/system/perl/APKBUILD b/system/perl/APKBUILD
index cc8a2c781..c63f7c2e2 100644
--- a/system/perl/APKBUILD
+++ b/system/perl/APKBUILD
@@ -4,7 +4,7 @@
# Maintainer: Adélie Perl Team <adelie-perl@lists.adelielinux.org>
pkgname=perl
pkgver=5.34.1
-pkgrel=0
+pkgrel=1
pkgdesc="Larry Wall's Practical Extraction and Report Language"
url="https://www.perl.org/"
arch="all"
@@ -89,7 +89,11 @@ build() {
}
check() {
- TEST_JOBS=$JOBS make test_harness
+ # https://perldoc.perl.org/perlhack.txt
+ export LC_ALL=C
+ export TEST_JOBS=${JOBS}
+ export PERL_TEST_HARNESS_ASAP=1
+ make -j${JOBS} test_harness_notty
}
package() {