summaryrefslogtreecommitdiff
path: root/system/python3/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'system/python3/APKBUILD')
-rw-r--r--system/python3/APKBUILD12
1 files changed, 3 insertions, 9 deletions
diff --git a/system/python3/APKBUILD b/system/python3/APKBUILD
index db6326d40..abfc78b55 100644
--- a/system/python3/APKBUILD
+++ b/system/python3/APKBUILD
@@ -5,7 +5,7 @@ pkgver=3.6.5
_basever="${pkgver%.*}"
pkgrel=0
pkgdesc="A high-level scripting language"
-url="http://www.python.org"
+url="https://www.python.org"
arch="all"
license="Python-2.0"
provides="py3-pip"
@@ -37,7 +37,7 @@ subpackages="$pkgname-dbg $pkgname-dev $pkgname-doc $pkgname-tests::noarch
# Packages Are Actually Buildable.
makedepends="expat-dev openssl-dev zlib-dev ncurses-dev bzip2-dev xz-dev
sqlite-dev libffi-dev tcl-dev linux-headers !python3"
-source="http://www.python.org/ftp/python/$pkgver/Python-$pkgver.tar.xz
+source="https://www.python.org/ftp/python/$pkgver/Python-$pkgver.tar.xz
musl-find_library.patch
fix-xattrs-glibc.patch
"
@@ -46,7 +46,6 @@ builddir="$srcdir/Python-$pkgver"
prepare() {
default_prepare
- cd "$builddir"
# force system libs
rm -r Modules/expat \
Modules/zlib \
@@ -55,8 +54,6 @@ prepare() {
}
build() {
- cd "$builddir"
-
# --enable-optimizations is not enabled because it
# is very, very slow as many tests are ran sequentially
# for profile guided optimizations. additionally it
@@ -83,8 +80,6 @@ build() {
}
check() {
- cd "$builddir"
-
# test that we reach recursionlimit before we segfault
cat > test-stacksize.py <<-EOF
import threading
@@ -130,7 +125,6 @@ EOF
}
package() {
- cd "$builddir"
make -j1 DESTDIR="$pkgdir" EXTRA_CFLAGS="$CFLAGS" install maninstall
install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
# those are provided by python3-tkinter
@@ -148,7 +142,7 @@ dev() {
}
tests() {
- pkgdesc="The test modules from the main python package"
+ pkgdesc="Test modules from the main Python package"
cd "$pkgdir"/usr/lib/python$_basever
local i; for i in */test */tests; do