summaryrefslogtreecommitdiff
path: root/system/rsync/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'system/rsync/APKBUILD')
-rw-r--r--system/rsync/APKBUILD6
1 files changed, 0 insertions, 6 deletions
diff --git a/system/rsync/APKBUILD b/system/rsync/APKBUILD
index c4d57a19c..7131a95b0 100644
--- a/system/rsync/APKBUILD
+++ b/system/rsync/APKBUILD
@@ -7,7 +7,6 @@ pkgdesc="A file transfer program to keep remote files in sync"
url="https://rsync.samba.org/"
arch="all"
license="GPL-3.0+"
-options="!checkroot"
makedepends="perl acl-dev attr-dev popt-dev"
subpackages="$pkgname-doc $pkgname-openrc rrsync::noarch"
source="https://download.samba.org/pub/$pkgname/$pkgname-$pkgver.tar.gz
@@ -16,10 +15,8 @@ source="https://download.samba.org/pub/$pkgname/$pkgname-$pkgver.tar.gz
rsyncd.conf
rsyncd.logrotate
"
-builddir="$srcdir/$pkgname-$pkgver"
build() {
- cd "$builddir"
# Force IPv6 enabled, upstream bug https://bugzilla.samba.org/show_bug.cgi?id=10715
CFLAGS="$CFLAGS -DINET6" \
./configure \
@@ -35,12 +32,10 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
install -D -m 755 "$srcdir"/rsyncd.initd "$pkgdir"/etc/init.d/rsyncd
@@ -54,7 +49,6 @@ rrsync() {
pkgdesc="Restricted rsync, restricts rsync to a subdir declared in .ssh/authorized_keys"
depends="rsync perl"
- cd "$builddir"
install -D -m 755 ./support/rrsync "$subpkgdir"/usr/bin/rrsync
}