summaryrefslogtreecommitdiff
path: root/system/s6
diff options
context:
space:
mode:
Diffstat (limited to 'system/s6')
-rw-r--r--system/s6/APKBUILD7
-rw-r--r--system/s6/s6.post-upgrade8
2 files changed, 10 insertions, 5 deletions
diff --git a/system/s6/APKBUILD b/system/s6/APKBUILD
index 4909c3daf..4529f6126 100644
--- a/system/s6/APKBUILD
+++ b/system/s6/APKBUILD
@@ -1,14 +1,14 @@
# Contributor: Laurent Bercot <ska-adelie@skarnet.org>
# Maintainer: Laurent Bercot <ska-adelie@skarnet.org>
pkgname=s6
-pkgver=2.9.2.0
+pkgver=2.10.0.0
pkgrel=0
pkgdesc="skarnet.org's small & secure supervision software suite"
url="https://skarnet.org/software/$pkgname/"
arch="all"
options="!check" # No test suite.
license="ISC"
-_skalibs_version=2.9.2.1
+_skalibs_version=2.10.0.0
depends="execline"
makedepends="skalibs-dev>=$_skalibs_version execline-dev"
install="$pkgname.post-upgrade"
@@ -66,4 +66,5 @@ doc() {
mkdir -p "$subpkgdir/usr/share/doc"
cp -a "$builddir/doc" "$subpkgdir/usr/share/doc/$pkgname"
}
-sha512sums="ef814c0426d00112c793d4f8bb99319cde8e4ab91c24e98401559bbd28eafdb11a66d446a31816a50f67d607ed1e8c55383362e9761abca21ca24b3598929eee s6-2.9.2.0.tar.gz"
+
+sha512sums="a3b6603ff7144a41d15e85bbfabc78656a52c0fad18e4195619a9a2c1a84adb84d736bcaa3f082d98dd11d3ac4d4d40988d1206ebaa33a0f9125b29fe380b6f7 s6-2.10.0.0.tar.gz"
diff --git a/system/s6/s6.post-upgrade b/system/s6/s6.post-upgrade
index 26d289c27..3188f031d 100644
--- a/system/s6/s6.post-upgrade
+++ b/system/s6/s6.post-upgrade
@@ -5,13 +5,14 @@ oldv="$2"
rm -f /etc/runlevels/default/s6
-if test `apk version -t "$oldv" 2.8` = "<" ; then
+if test `apk version -t "$oldv" 2.9` = "<" ; then
cat <<EOF
*
* The s6 package has been upgraded. To complete the upgrade, you need to
-* restart the supervision tree - with the following command, run as root:
+* restart the supervision tree. If you are using sysvinit, please use the
+* following command, run as root:
*
* s6-svscanctl -t /run/service
*
@@ -19,6 +20,9 @@ if test `apk version -t "$oldv" 2.8` = "<" ; then
* terminals that are listed in the GETTYS variable in /etc/conf.d/gettys
* - so please save your work first.
*
+* If you are using s6-linux-init, which is the default, please just
+* reboot your machine as soon as is convenient for you.
+*
EOF
fi