summaryrefslogtreecommitdiff
path: root/system/sed/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'system/sed/APKBUILD')
-rw-r--r--system/sed/APKBUILD10
1 files changed, 2 insertions, 8 deletions
diff --git a/system/sed/APKBUILD b/system/sed/APKBUILD
index bd20a4f6b..61d644e32 100644
--- a/system/sed/APKBUILD
+++ b/system/sed/APKBUILD
@@ -4,22 +4,18 @@ pkgname=sed
pkgver=4.7
pkgrel=0
pkgdesc="GNU stream editor"
-url="http://www.gnu.org/software/sed"
+url="https://www.gnu.org/software/sed"
arch="all"
-options="!checkroot"
license="GPL-3.0+"
makedepends="perl"
subpackages="$pkgname-doc $pkgname-lang"
install="$pkgname.post-deinstall"
-source="http://ftp.gnu.org/pub/gnu/$pkgname/$pkgname-$pkgver.tar.xz
+source="https://ftp.gnu.org/pub/gnu/$pkgname/$pkgname-$pkgver.tar.xz
disable-mbrtowc-test.patch
gnulib-tests-dont-require-gpg-passphrase.patch
"
-builddir="$srcdir/$pkgname-$pkgver"
-
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -32,12 +28,10 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
rm -rf "$pkgdir"/usr/lib/charset.alias || true