summaryrefslogtreecommitdiff
path: root/system/shadow/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'system/shadow/APKBUILD')
-rw-r--r--system/shadow/APKBUILD64
1 files changed, 34 insertions, 30 deletions
diff --git a/system/shadow/APKBUILD b/system/shadow/APKBUILD
index 13dc98d7a..6b8723bf6 100644
--- a/system/shadow/APKBUILD
+++ b/system/shadow/APKBUILD
@@ -1,21 +1,24 @@
# Contributor: William Pitcock <nenolod@dereferenced.org>
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
-# Maintainer: Stuart Cardall <developer@it-offshore.co.uk>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=shadow
-pkgver=4.5
+pkgver=4.6
pkgrel=0
-pkgdesc="PAM-using login and passwd utilities (usermod, useradd, ...)"
-url="http://pkg-shadow.alioth.debian.org/"
+pkgdesc="Login and password management utilities"
+url="https://github.com/shadow-maint/shadow"
arch="all"
-license="GPL"
+options="suid"
+license="BSD-3-Clause OR Artistic-1.0-Perl"
depends=""
-makedepends="linux-pam-dev"
-subpackages="$pkgname-doc $pkgname-dbg $pkgname-uidmap"
+makedepends="linux-pam-dev autoconf automake"
+subpackages="$pkgname-doc $pkgname-dbg $pkgname-lang $pkgname-uidmap"
source="https://github.com/shadow-maint/shadow/releases/download/$pkgver/shadow-$pkgver.tar.xz
login.pamd
dots-in-usernames.patch
useradd-usergroups.patch
pam-useradd.patch
+ utmpx.patch
+ support-m4-dirs.patch
"
# secfixes:
# 4.5-r0:
@@ -25,13 +28,16 @@ source="https://github.com/shadow-maint/shadow/releases/download/$pkgver/shadow-
# 4.2.1-r7:
# - CVE-2016-6252
-options="suid"
-builddir="$srcdir/shadow-$pkgver"
+prepare() {
+ cd "$builddir"
+ default_prepare
+ autoreconf -v -f --install
+}
build() {
cd "$builddir"
- ./configure \
+ LIBS="-lutmps -lskarnet" ./configure \
--build=$CBUILD \
--host=$CHOST \
--target=$CTARGET \
@@ -40,7 +46,7 @@ build() {
--mandir=/usr/share/man \
--infodir=/usr/share/info \
--localstatedir=/var \
- --disable-nls \
+ --enable-utmpx \
--with-libpam \
--without-audit \
--without-selinux \
@@ -48,9 +54,8 @@ build() {
--without-attr \
--without-tcb \
--without-nscd \
- --without-group-name-max-length \
- || return 1
- make || return 1
+ --without-group-name-max-length
+ make
}
check() {
@@ -61,23 +66,23 @@ check() {
package() {
cd "$builddir"
- make DESTDIR="$pkgdir" install || return 1
+ make DESTDIR="$pkgdir" install
# Do not install these pam.d files they are broken and outdated.
- rm "$pkgdir"/etc/pam.d/* || return 1
+ rm "$pkgdir"/etc/pam.d/*
# install some pam.d files based on a patched useradd
for pamf in groupadd groupdel groupmems groupmod \
useradd userdel usermod
do
install -m0644 etc/pam.d/useradd \
- "$pkgdir/etc/pam.d/$pamf" || return 1
+ "$pkgdir/etc/pam.d/$pamf"
done
# nologin is provided by util-linux.
- rm "$pkgdir"/sbin/nologin || return 1
+ rm "$pkgdir"/sbin/nologin
# However, install our own for login.
- cp "$srcdir"/login.pamd "$pkgdir"/etc/pam.d/login || return 1
+ cp "$srcdir"/login.pamd "$pkgdir"/etc/pam.d/login
# /etc/login.defs is not very useful - replace it with an *almost* blank file.
rm "$pkgdir"/etc/login.defs
@@ -85,26 +90,25 @@ package() {
# Avoid conflict with man-pages.
rm "$pkgdir"/usr/share/man/man3/getspnam.3* \
- "$pkgdir"/usr/share/man/man5/passwd.5* || return 1
+ "$pkgdir"/usr/share/man/man5/passwd.5*
}
uidmap() {
pkgdesc="Utilities for using subordinate UIDs and GIDs"
- mkdir -p "$subpkgdir"
- cd "$subpkgdir"
-
- mkdir -p usr/bin
- mv "$pkgdir"/usr/bin/new*idmap usr/bin/ || return 1
- chmod 4711 usr/bin/new*idmap || return 1
+ mkdir -p "$subpkgdir"/usr/bin
+ mv "$pkgdir"/usr/bin/new*idmap "$subpkgdir"/usr/bin/
+ chmod 4711 "$subpkgdir"/usr/bin/new*idmap
# Used e.g. for unprivileged LXC containers.
- mkdir etc
- touch etc/subuid etc/subgid
+ mkdir "$subpkgdir"/etc
+ touch "$subpkgdir"/etc/subuid "$subpkgdir"/etc/subgid
}
-sha512sums="e57f8db54df23301c229d4be30d4cbb67efa1d1809cffcff79adc480b6019fb2b5fd09e112e82a3f00ad5a6b2994592adac93f70a631cf666b6f4723b61c87b5 shadow-4.5.tar.xz
+sha512sums="e8eee52c649d9973f724bc2d5aeee71fa2e6a2e41ec3487cd6cf6d47af70c32e0cdf304df29b32eae2b6eb6f9066866b5f2c891add0ec87ba583bea3207b3631 shadow-4.6.tar.xz
46a6f83f3698e101b58b8682852da749619412f75dfa85cecad03d0847f6c3dc452d984510db7094220e4570a0565b83b0556e16198ad894a3ec84b3e513d58d login.pamd
745eea04c054226feba165b635dbb8570b8a04537d41e914400a4c54633c3a9cf350da0aabfec754fb8cf3e58fc1c8cf597b895506312f19469071760c11f31d dots-in-usernames.patch
49f1d5ded82d2d479805c77d7cc6274c30233596e375b28306b31a33f8fbfc3611dbc77d606081b8300247908c267297dbb6c5d1a30d56095dda53c6a636fb56 useradd-usergroups.patch
-0b4587e263cb6be12fa5ae6bc3b3fc4d3696dae355bc67d085dc58c52ff96edb4d163b95db2092b8c2f3310839430cac03c7af356641b42e24ee4aa6410f5cf1 pam-useradd.patch"
+0b4587e263cb6be12fa5ae6bc3b3fc4d3696dae355bc67d085dc58c52ff96edb4d163b95db2092b8c2f3310839430cac03c7af356641b42e24ee4aa6410f5cf1 pam-useradd.patch
+0ae5df1a287b8fa07fa9b9061dd3d5e6198527a6d9e9d4a9e2885f7a3884d1935e56856e25f1c092475aa31cee31b11d3bc7f9efe0347b0811ae53a805b2f26e utmpx.patch
+ec0ef7038b385954b7e47b0414839d30c99edcc96863a06a8e90f04bcc943c6c30274fc382f15ca74ceca57bef36c90feae6e7d363ed8c6408ae4f2bf938dacb support-m4-dirs.patch"