summaryrefslogtreecommitdiff
path: root/system/userspace-rcu
diff options
context:
space:
mode:
Diffstat (limited to 'system/userspace-rcu')
-rw-r--r--system/userspace-rcu/APKBUILD36
-rw-r--r--system/userspace-rcu/endian.patch11
2 files changed, 0 insertions, 47 deletions
diff --git a/system/userspace-rcu/APKBUILD b/system/userspace-rcu/APKBUILD
deleted file mode 100644
index e36f0f6bf..000000000
--- a/system/userspace-rcu/APKBUILD
+++ /dev/null
@@ -1,36 +0,0 @@
-# Maintainer: A. Wilcox <awilfox@adelielinux.org>
-pkgname=userspace-rcu
-pkgver=0.14.0
-pkgrel=0
-pkgdesc="Userspace RCU (read-copy-update) library"
-url="https://liburcu.org"
-arch="all"
-license="LGPL-2.1-only"
-depends=""
-makedepends=""
-subpackages="$pkgname-doc $pkgname-dev"
-source="https://lttng.org/files/urcu/userspace-rcu-$pkgver.tar.bz2
- endian.patch
- "
-
-build() {
- ./configure \
- --build=$CBUILD \
- --host=$CHOST \
- --prefix=/usr \
- --sysconfdir=/etc \
- --mandir=/usr/share/man \
- --localstatedir=/var
- make
-}
-
-check() {
- make check
-}
-
-package() {
- make DESTDIR="$pkgdir" install
-}
-
-sha512sums="7297e51012f4c44ee27c0e18ed9d87bf24be34db68a5398394c1e683a045bb561cf74aa913398404c0ed5cb8011af728ea12947717fa5f27627e5ca78e63a40f userspace-rcu-0.14.0.tar.bz2
-07935ed9741554b2cbc343fdd6218172deca4d4167b31b92f2be82623c5d83191472da2b4bee5adcd59e3d4bec3751d3e793cc720b822b6060dc588b8ee58f16 endian.patch"
diff --git a/system/userspace-rcu/endian.patch b/system/userspace-rcu/endian.patch
deleted file mode 100644
index d80495c8a..000000000
--- a/system/userspace-rcu/endian.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- userspace-rcu-0.14.0/doc/examples/rculfhash/jhash.h.old 2023-02-13 11:51:12.000000000 -0600
-+++ userspace-rcu-0.14.0/doc/examples/rculfhash/jhash.h 2024-08-10 18:35:07.651374111 -0500
-@@ -51,7 +51,7 @@
- c ^= b; c -= rot(b, 24); \
- }
-
--#if (BYTE_ORDER == LITTLE_ENDIAN)
-+#if (__BYTE_ORDER__ == __ORDER_LITTLE_ENDIAN__)
- #define HASH_LITTLE_ENDIAN 1
- #else
- #define HASH_LITTLE_ENDIAN 0