summaryrefslogtreecommitdiff
path: root/system/util-linux/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'system/util-linux/APKBUILD')
-rw-r--r--system/util-linux/APKBUILD17
1 files changed, 6 insertions, 11 deletions
diff --git a/system/util-linux/APKBUILD b/system/util-linux/APKBUILD
index 138d6f402..182e27176 100644
--- a/system/util-linux/APKBUILD
+++ b/system/util-linux/APKBUILD
@@ -2,16 +2,16 @@
# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=util-linux
-pkgver=2.32.1
+pkgver=2.33.1
case $pkgver in
*.*.*) _v=${pkgver%.*};;
*.*) _v=$pkgver;;
esac
-pkgrel=1
+pkgrel=0
pkgdesc="Official Linux system management utilities"
-url="http://git.kernel.org/cgit/utils/util-linux/util-linux.git"
+url="https://git.kernel.org/pub/scm/utils/util-linux/util-linux.git"
arch="all"
options="!check suid" # multibyte input fails because of musl locale stuff
license="GPL-2.0-only AND GPL-2.0+ AND LGPL-2.1+ AND Public-Domain"
@@ -26,23 +26,19 @@ replaces="e2fsprogs util-linux-ng sfdisk cfdisk findmnt mcookie blkid setpriv
provides="sfdisk=$pkgver-$pkgrel cfdisk=$pkgver-$pkgrel findmnt=$pkgver-$pkgrel
mcookie=$pkgver-$pkgrel blkid=$pkgver-$pkgrel libblkid=$pkgver-$pkgrel
libmount=$pkgver-$pkgrel libsmartcols=$pkgver-$pkgrel"
-source="http://www.kernel.org/pub/linux/utils/$pkgname/v${_v}/$pkgname-$pkgver.tar.xz
+source="https://www.kernel.org/pub/linux/utils/$pkgname/v${_v}/$pkgname-$pkgver.tar.xz
ttydefaults.h
"
-builddir="$srcdir/$pkgname-$pkgver"
prepare() {
default_prepare
- cd "$builddir"
cp "$srcdir"/ttydefaults.h include/
libtoolize --force && aclocal -I m4 && autoconf \
&& automake --add-missing
}
build() {
- cd "$builddir"
-
# login utils are provided by shadow
LIBS="-lutmps -lskarnet" ./configure \
--build=$CBUILD \
@@ -56,14 +52,13 @@ build() {
--disable-login \
--disable-sulogin \
--disable-su \
+ --disable-chfn-chsh \
--without-python
make
}
package() {
- cd "$builddir"
make -j1 DESTDIR="$pkgdir" install
- # use pkg-config
}
dev() {
@@ -105,5 +100,5 @@ libfdisk() {
mv "$pkgdir"/lib/libfdisk.so.* "$subpkgdir"/lib/
}
-sha512sums="267fedae24a874ee4dc558081f6b8d07b33b955b0635f3348f021c111c17f2e95c01b2cbf909fe13c6ca448cbcf23c658c75f72f25749aa65e99f68fabb94698 util-linux-2.32.1.tar.xz
+sha512sums="94ada47e472b62a612c26fd5a5b7423e09366690a8a96f777191a5d920981eb0f224474bc2f128e827299bf60062770011332757e1551a8cd3764b5c70ae4ba2 util-linux-2.33.1.tar.xz
876bb9041eca1b2cca1e9aac898f282db576f7860aba690a95c0ac629d7c5b2cdeccba504dda87ff55c2a10b67165985ce16ca41a0694a267507e1e0cafd46d9 ttydefaults.h"