summaryrefslogtreecommitdiff
path: root/system/vim/vimrc
diff options
context:
space:
mode:
Diffstat (limited to 'system/vim/vimrc')
-rw-r--r--system/vim/vimrc18
1 files changed, 18 insertions, 0 deletions
diff --git a/system/vim/vimrc b/system/vim/vimrc
new file mode 100644
index 000000000..4849a16d1
--- /dev/null
+++ b/system/vim/vimrc
@@ -0,0 +1,18 @@
+set nocompatible " Use Vim defaults (much better!)
+set bs=2 " Allow backspacing over everything in insert mode
+set ai " Always set auto-indenting on
+set history=50 " keep 50 lines of command history
+set ruler " Show the cursor position all the time
+
+set mouse= " Use Vim 7 default of no mouse movements by default
+
+" Don't use Ex mode, use Q for formatting
+map Q gq
+
+" When doing tab completion, give the following files lower priority.
+set suffixes+=.info,.aux,.log,.dvi,.bbl,.out,.o,.lo
+
+set nomodeline
+syntax on
+color desert
+autocmd BufRead APKBUILD set filetype=sh