summaryrefslogtreecommitdiff
path: root/system/xf86-video-ati/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'system/xf86-video-ati/APKBUILD')
-rw-r--r--system/xf86-video-ati/APKBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/system/xf86-video-ati/APKBUILD b/system/xf86-video-ati/APKBUILD
new file mode 100644
index 000000000..b5d128d60
--- /dev/null
+++ b/system/xf86-video-ati/APKBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=xf86-video-ati
+pkgver=18.0.1
+pkgrel=0
+pkgdesc="ATI video driver"
+url="http://xorg.freedesktop.org/"
+arch="all"
+license="MIT"
+subpackages="$pkgname-doc"
+depends="mesa-dri-ati"
+makedepends="xorg-server-dev libxi-dev fontsproto randrproto util-macros
+ videoproto renderproto libdrm-dev xf86driproto glproto mesa-dev
+ xineramaproto eudev-dev pixman-dev"
+options="!check"
+source="http://www.x.org/releases/individual/driver/$pkgname-$pkgver.tar.bz2"
+builddir="$srcdir"/$pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ export LDFLAGS="$LDFLAGS -Wl,-z,lazy"
+
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --enable-glamor
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+ install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
+}
+
+sha512sums="b468a78503a596bbf71a1b91b231ce1fa32908f619ff2dfe249352d046696a3641f2a9ff065e32545fff77100134b4b237591215e78ef885b6509d6b16112d14 xf86-video-ati-18.0.1.tar.bz2"