summaryrefslogtreecommitdiff
path: root/system/zip/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'system/zip/APKBUILD')
-rw-r--r--system/zip/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/system/zip/APKBUILD b/system/zip/APKBUILD
new file mode 100644
index 000000000..401ce74e3
--- /dev/null
+++ b/system/zip/APKBUILD
@@ -0,0 +1,35 @@
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer: Dan Theisen <djt@hxx.in>
+pkgname=zip
+pkgver=3.0
+pkgrel=5
+pkgdesc="Creates PKZIP-compatible .zip files"
+url="http://www.info-zip.org/pub/infozip/Zip.html"
+arch="all"
+options="!check" # No test suite.
+license="Info-ZIP"
+depends=""
+makedepends=""
+subpackages="$pkgname-doc"
+source="ftp://ftp.info-${pkgname}.org/pub/info${pkgname}/src/${pkgname}30.zip
+ 10-zip-3.0-build.patch
+ 20-zip-3.0-exec-stack.patch
+ 30-zip-3.0-pic.patch"
+
+builddir="$srcdir"/${pkgname}30
+
+build() {
+ cd "$builddir"
+ make -f unix/Makefile LOCAL_ZIP="${CFLAGS} ${CPPFLAGS}" prefix=/usr generic
+}
+
+package() {
+ cd "$builddir"
+ make -f unix/Makefile prefix=${pkgdir}/usr MANDIR=${pkgdir}/usr/share/man install
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}
+
+sha512sums="642ea6768d79adc1499251a3fb7bfc7ddc8d708699cbf9e0cfe849deda94165cb93e21dc2606bea1166ae5d8531e1e2cb056a7246bf2ab86ea7587bd4712d8d8 zip30.zip
+e71f7c6f6dd6f8f576018581b155f324eaf6810a2f7c5c402843bdfc3ce6772f09be166b33ff34dcb703774694b18584c8de1763f29895c1d563661679f43d71 10-zip-3.0-build.patch
+2a6824066543684e02731bd36930e0ffa6ab48162c61d5e7af08e8ea0795401271ef28bdd0f6ace865d91fdb1a05b643813cdd458a9fdf554f1ca298ea7f50e3 20-zip-3.0-exec-stack.patch
+fcb2d728d79160128064af90eb17a9c03e980d9619c4d930c4dbf79cb13842c7bb694036dcbf5cd9b412efc6fc0b86bb94a88b3f110b6b63bf6bda2b97fe0568 30-zip-3.0-pic.patch"