summaryrefslogtreecommitdiff
path: root/system/zsh/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'system/zsh/APKBUILD')
-rw-r--r--system/zsh/APKBUILD24
1 files changed, 11 insertions, 13 deletions
diff --git a/system/zsh/APKBUILD b/system/zsh/APKBUILD
index 32c86b7df..5c80e950b 100644
--- a/system/zsh/APKBUILD
+++ b/system/zsh/APKBUILD
@@ -3,16 +3,17 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Dan Theisen <djt@hxx.in>
pkgname=zsh
-pkgver=5.6.2
-pkgrel=1
+pkgver=5.7.1
+pkgrel=0
pkgdesc="A very advanced and programmable command interpreter (shell)"
-url="http://www.zsh.org/"
+url="https://www.zsh.org/"
arch="all"
license="Zsh AND BSD-3-Clause AND GPL-2.0+ AND GPL-2.0-only AND Artistic-1.0-Perl AND MIT AND GPL-1.0+"
depends="debianutils" # add-shell
makedepends_host="ncurses-dev pcre-dev utmps-dev"
install="zsh.post-install zsh.post-upgrade zsh.pre-deinstall"
-source="http://www.zsh.org/pub/$pkgname-$pkgver.tar.xz
+# Note the custom fetch() function
+source="https://www.zsh.org/pub/$pkgname-$pkgver.tar.xz
zprofile
zshrc
"
@@ -21,7 +22,6 @@ subpackages="$pkgname-doc
$pkgname-vcs::noarch
$pkgname-tcp::noarch"
[ "$CBUILD" != "$CHOST" ] || subpackages="$subpackages $pkgname-zftp"
-builddir="$srcdir/$pkgname-$pkgver"
# secfixes:
# 5.6.2-r0:
@@ -52,9 +52,12 @@ for _i in $_comps; do
subpackages="$subpackages ${_i%%:*}-zsh-completion:_completion:noarch"
done
-prepare() {
- cd "$builddir"
+fetch() {
+ uri_fetch_mirror "https://www.zsh.org/pub/old/$pkgname-$pkgver.tar.xz" || true
+ default_fetch
+}
+prepare() {
default_prepare
# Remove completions for other systems.
@@ -81,8 +84,6 @@ prepare() {
}
build() {
- cd "$builddir"
-
LIBS="-lutmps -lskarnet" ./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -102,7 +103,6 @@ build() {
}
check() {
- cd "$builddir"
# Does not work with musl due to UTF-8
rm "$builddir"/Test/A03quoting.ztst
# Does not work with musl due to locale
@@ -115,8 +115,6 @@ check() {
}
package() {
- cd "$builddir"
-
make DESTDIR="$pkgdir" install
install -Dm644 "$srcdir"/zprofile "$pkgdir"/etc/zsh/zprofile
install -Dm644 "$srcdir"/zshrc "$pkgdir"/etc/zsh/zshrc
@@ -177,6 +175,6 @@ _submv() {
mv "$pkgdir"/$path "$subpkgdir"/${path%/*}/
}
-sha512sums="f0a49e41b55eb478692ab5471d7c9828956b7e96bc82944202b0ef1c49a889b21a0e7682aa5f59fd0054ebfd866c2244c8a622e7aa46c13038af5c226c48a3a2 zsh-5.6.2.tar.xz
+sha512sums="a6aa88e1955a80229a4784a128866e325f79a8b5f73c922ab480048411036f1835cbb31daa30ab38bd16ab2a50040eda8f4f1f64704b21b6acc3051b1dbf18d0 zsh-5.7.1.tar.xz
e90723eb790581419498f3ab86fb5d6cab4aaede8c87eb79ead7047d259b643cfb47f4d1beb06d03e038cfda3a20ef9dd4c1b417270ab55c688e166fe30ef4f6 zprofile
1675e016f97333cad89b587f4292d81b6bc10e27b75482e3e0c3808539c95bd49b907b6579fb98d817f77f2f2384c0df5afa3e2b6f43b6ae9b466925cd9ccffc zshrc"