summaryrefslogtreecommitdiff
path: root/system/zsh/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'system/zsh/APKBUILD')
-rw-r--r--system/zsh/APKBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/system/zsh/APKBUILD b/system/zsh/APKBUILD
index 32c86b7df..e1e54c0f5 100644
--- a/system/zsh/APKBUILD
+++ b/system/zsh/APKBUILD
@@ -6,13 +6,14 @@ pkgname=zsh
pkgver=5.6.2
pkgrel=1
pkgdesc="A very advanced and programmable command interpreter (shell)"
-url="http://www.zsh.org/"
+url="https://www.zsh.org/"
arch="all"
license="Zsh AND BSD-3-Clause AND GPL-2.0+ AND GPL-2.0-only AND Artistic-1.0-Perl AND MIT AND GPL-1.0+"
depends="debianutils" # add-shell
makedepends_host="ncurses-dev pcre-dev utmps-dev"
install="zsh.post-install zsh.post-upgrade zsh.pre-deinstall"
-source="http://www.zsh.org/pub/$pkgname-$pkgver.tar.xz
+# Note the custom fetch() function
+source="https://www.zsh.org/pub/$pkgname-$pkgver.tar.xz
zprofile
zshrc
"
@@ -21,7 +22,6 @@ subpackages="$pkgname-doc
$pkgname-vcs::noarch
$pkgname-tcp::noarch"
[ "$CBUILD" != "$CHOST" ] || subpackages="$subpackages $pkgname-zftp"
-builddir="$srcdir/$pkgname-$pkgver"
# secfixes:
# 5.6.2-r0:
@@ -52,6 +52,11 @@ for _i in $_comps; do
subpackages="$subpackages ${_i%%:*}-zsh-completion:_completion:noarch"
done
+fetch() {
+ uri_fetch_mirror "https://www.zsh.org/pub/old/$pkgname-$pkgver.tar.xz" || true
+ default_fetch
+}
+
prepare() {
cd "$builddir"