summaryrefslogtreecommitdiff
path: root/system
diff options
context:
space:
mode:
Diffstat (limited to 'system')
-rw-r--r--system/gdb/APKBUILD6
-rw-r--r--system/gdb/stopcode-lock.patch75
-rw-r--r--system/musl/APKBUILD4
-rw-r--r--system/musl/ppc64-regs.patch45
-rw-r--r--system/nspr/APKBUILD6
-rw-r--r--system/nspr/stacksize.patch22
-rw-r--r--system/perl-cpanel-json-xs/APKBUILD4
-rw-r--r--system/vim/APKBUILD4
8 files changed, 110 insertions, 56 deletions
diff --git a/system/gdb/APKBUILD b/system/gdb/APKBUILD
index b038ca23f..021848629 100644
--- a/system/gdb/APKBUILD
+++ b/system/gdb/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=gdb
pkgver=8.2
-pkgrel=0
+pkgrel=1
pkgdesc="The GNU Debugger"
url="https://www.sourceware.org/gdb/"
arch="all"
@@ -17,6 +17,7 @@ source="https://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.xz
ppc-musl.patch
ppc-ptregs.patch
remove-extraneous-include.patch
+ stopcode-lock.patch
"
build() {
@@ -60,4 +61,5 @@ sha512sums="11cc481bebc51eb6db73249ecb62b8c07455cf3db169f4860b3a83114849fbd2b586
986e68275f7692f39b5d8aedeb9f9e88f0e5bebb3f8c7f104933c525d35ca54fc90e18698c1e3e1009e8a188e5e70d6f252cb39e4c75e37db7bf479017e0da32 s390x-use-elf-gdb_fpregset_t.patch
04911f87904b62dd7662435f9182b20485afb29ddb3d6398a9d31fef13495f7b70639c77fdae3a40e2775e270d7cd40d0cfd7ddf832372b506808d33c8301e01 ppc-musl.patch
b75e1c1ee503a1948a7d5b8d90427b5c7d38ded69978056cee0adca222771a5c95ed1ac73127fcae7b795ea94296344eee5fca47e4cd04b418c164a756fb0933 ppc-ptregs.patch
-3ff31774ba78c1208415289566b901debd815da8b53acefe4a0785e7b2bbcff39585a556d44ff2f7d8d639ebc047620b96e72573acae376d8f23aa98dd1fe286 remove-extraneous-include.patch"
+3ff31774ba78c1208415289566b901debd815da8b53acefe4a0785e7b2bbcff39585a556d44ff2f7d8d639ebc047620b96e72573acae376d8f23aa98dd1fe286 remove-extraneous-include.patch
+720d6cbc71d5d4f5cc8955b18a76661688534d409e2beb53e9e2d2322a303fa622e622b583e1f6c50cf3f32b8abe4f5320a6885e7680769c92ef5bb09ef59d1d stopcode-lock.patch"
diff --git a/system/gdb/stopcode-lock.patch b/system/gdb/stopcode-lock.patch
new file mode 100644
index 000000000..6a4e3d855
--- /dev/null
+++ b/system/gdb/stopcode-lock.patch
@@ -0,0 +1,75 @@
+From: Andrew Burgess <andrew.burgess@embecosm.com>
+Date: Tue, 3 Jul 2018 18:02:48 +0000 (+0100)
+Subject: gdb: Avoid using W_STOPCODE(0) as this is ambiguous on MIPS
+X-Git-Tag: users/ARM/embedded-binutils-master-2018q4~1172
+X-Git-Url: https://sourceware.org/git/gitweb.cgi?p=binutils-gdb.git;a=commitdiff_plain;h=953473375500a809fbb3eca3efa4dbb670c3a32f
+
+gdb: Avoid using W_STOPCODE(0) as this is ambiguous on MIPS
+
+The MIPS target supports 127 signals, and this can create an ambiguity
+in process wait statuses. A status value of 0x007f could potentially
+indicate a process that has exited with signal 127, or a process that
+has stopped with signal 0.
+
+In uClibc-ng the interpretation of 0x007f is that the process has
+exited with signal 127 rather than stopped with signal 0, and so,
+WIFSTOPPED (W_STOPCODE (0)) will be false rather than true as it would
+be on most other platforms.
+
+Given that it's pretty easy to avoid using W_STOPCODE (0), lets do that.
+
+gdb/ChangeLog:
+
+ * linux-nat.c (linux_nat_target::follow_fork): Avoid using
+ 'W_STOPCODE (0)' as this could be ambiguous.
+---
+
+diff --git a/gdb/linux-nat.c b/gdb/linux-nat.c
+index 86d3dfd..d2c88ad 100644
+--- a/gdb/linux-nat.c
++++ b/gdb/linux-nat.c
+@@ -445,7 +445,6 @@ linux_nat_target::follow_fork (int follow_child, int detach_fork)
+ if (!follow_child)
+ {
+ struct lwp_info *child_lp = NULL;
+- int status = W_STOPCODE (0);
+ int has_vforked;
+ ptid_t parent_ptid, child_ptid;
+ int parent_pid, child_pid;
+@@ -465,6 +464,8 @@ linux_nat_target::follow_fork (int follow_child, int detach_fork)
+ /* Detach new forked process? */
+ if (detach_fork)
+ {
++ int child_stop_signal = 0;
++ bool detach_child = true;
+ struct cleanup *old_chain = make_cleanup (delete_lwp_cleanup,
+ child_lp);
+
+@@ -484,18 +485,24 @@ linux_nat_target::follow_fork (int follow_child, int detach_fork)
+ if (!gdbarch_software_single_step_p (target_thread_architecture
+ (parent_ptid)))
+ {
++ int status;
++
+ linux_disable_event_reporting (child_pid);
+ if (ptrace (PTRACE_SINGLESTEP, child_pid, 0, 0) < 0)
+ perror_with_name (_("Couldn't do single step"));
+ if (my_waitpid (child_pid, &status, 0) < 0)
+ perror_with_name (_("Couldn't wait vfork process"));
++ else
++ {
++ detach_child = WIFSTOPPED (status);
++ child_stop_signal = WSTOPSIG (status);
++ }
+ }
+
+- if (WIFSTOPPED (status))
++ if (detach_child)
+ {
+- int signo;
++ int signo = child_stop_signal;
+
+- signo = WSTOPSIG (status);
+ if (signo != 0
+ && !signal_pass_state (gdb_signal_from_host (signo)))
+ signo = 0;
diff --git a/system/musl/APKBUILD b/system/musl/APKBUILD
index d35060fb4..bffa25154 100644
--- a/system/musl/APKBUILD
+++ b/system/musl/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=musl
pkgver=1.1.21
-pkgrel=2
+pkgrel=3
pkgdesc="System library (libc) implementation"
url="http://www.musl-libc.org/"
arch="all"
@@ -27,7 +27,6 @@ source="http://www.musl-libc.org/releases/musl-$pkgver.tar.gz
handle-aux-at_base.patch
fgetspent_r.patch
gettext-preserve-errno.patch
- ppc64-regs.patch
ldconfig
getent.c
@@ -126,7 +125,6 @@ sha512sums="fa6c4cc012626c5e517e0e10926fc845e3aa5f863ffaceeb38ac5b9ce0af631a37f6
6a7ff16d95b5d1be77e0a0fbb245491817db192176496a57b22ab037637d97a185ea0b0d19da687da66c2a2f5578e4343d230f399d49fe377d8f008410974238 handle-aux-at_base.patch
ded41235148930f8cf781538f7d63ecb0c65ea4e8ce792565f3649ee2523592a76b2a166785f0b145fc79f5852fd1fb1729a7a09110b3b8f85cba3912e790807 fgetspent_r.patch
db180e437b8b7582e4d2baf06b592b88a9f6e5a8f18b7afa81d7a707240a774273778f8fec1c5cbea2a137e00cca49ff08fe762c871be20c70b50104b7e8e1e1 gettext-preserve-errno.patch
-8d90a4bbec151f696bee30ed7275d8eb88b5c5ae7027d1dac963a950b0717b1e5149d6718c441bc9ee103b57899a9835a93f8373448b5887b52a24937bfd0af9 ppc64-regs.patch
cce2f1eeb61e55674469c26871a573cce61d739c3defe9c8f56f2b774f6ba5435849ad542a6714120efddc98c297098e9c98a1a424ac593df2243d4aa479f9a9 ldconfig
378d70e65bcc65bb4e1415354cecfa54b0c1146dfb24474b69e418cdbf7ad730472cd09f6f103e1c99ba6c324c9560bccdf287f5889bbc3ef0bdf0e08da47413 getent.c
9d42d66fb1facce2b85dad919be5be819ee290bd26ca2db00982b2f8e055a0196290a008711cbe2b18ec9eee8d2270e3b3a4692c5a1b807013baa5c2b70a2bbf iconv.c"
diff --git a/system/musl/ppc64-regs.patch b/system/musl/ppc64-regs.patch
deleted file mode 100644
index 4deb979ba..000000000
--- a/system/musl/ppc64-regs.patch
+++ /dev/null
@@ -1,45 +0,0 @@
-From ea183d9b727ac7e3ccfdcb89242566857d7182c8 Mon Sep 17 00:00:00 2001
-From: "A. Wilcox" <AWilcox@Wilcox-Tech.com>
-Date: Tue, 12 Feb 2019 09:31:34 -0600
-Subject: [PATCH] powerpc64: use a type for mcontext_t regs field
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-GCC Go dereferences `regs` for `nip`. Without this change, compilation
-fails with the following message:
-
-../../../libgo/runtime/go-signal.c: In function ‘getSiginfo’:
-../../../libgo/runtime/go-signal.c:225:56: warning: dereferencing ‘void *’ pointer
- ret.sigpc = ((ucontext_t*)(context))->uc_mcontext.regs->nip;
- ^~
-../../../libgo/runtime/go-signal.c:225:56: error: request for member ‘nip’ in something not a structure or union
----
- arch/powerpc64/bits/signal.h | 4 +++-
- 1 file changed, 3 insertions(+), 1 deletion(-)
-
-diff --git a/arch/powerpc64/bits/signal.h b/arch/powerpc64/bits/signal.h
-index 34693a68..6736c69a 100644
---- a/arch/powerpc64/bits/signal.h
-+++ b/arch/powerpc64/bits/signal.h
-@@ -8,6 +8,8 @@
-
- #if defined(_GNU_SOURCE) || defined(_BSD_SOURCE)
-
-+#include <bits/user.h>
-+
- typedef unsigned long greg_t, gregset_t[48];
-
- typedef struct {
-@@ -29,7 +31,7 @@ typedef struct sigcontext {
- int _pad0;
- unsigned long handler;
- unsigned long oldmask;
-- void *regs;
-+ struct pt_regs *regs;
- gregset_t gp_regs;
- fpregset_t fp_regs;
- vrregset_t *v_regs;
---
-2.19.2
-
diff --git a/system/nspr/APKBUILD b/system/nspr/APKBUILD
index a6da52de1..bf0c907e8 100644
--- a/system/nspr/APKBUILD
+++ b/system/nspr/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=nspr
pkgver=4.20
-pkgrel=0
+pkgrel=1
pkgdesc="Netscape Portable Runtime"
url="https://developer.mozilla.org/en-US/docs/Mozilla/Projects/NSPR"
arch="all"
@@ -14,6 +14,7 @@ makedepends="autoconf automake"
subpackages="$pkgname-dev"
source="http://ftp.mozilla.org/pub/mozilla.org/nspr/releases/v$pkgver/src/nspr-$pkgver.tar.gz
fix-getproto.patch
+ stacksize.patch
"
prepare() {
@@ -61,4 +62,5 @@ package() {
}
sha512sums="22fdf7627f450b0594ebccaee170098e1a8cd0f429fd44816f1322756002ced3d69cf686c3f69f7cb30b8132d3605a9fce5457ab99d0002e6af11a3408a5c949 nspr-4.20.tar.gz
-ee654f609a90b9a95c1901ad1d56cdef7cce8bca9efc092198607944f142f8fec924b13219ca6663facd0f0d59b671b8b3de58ab3449c4c863d42e2937f02184 fix-getproto.patch"
+ee654f609a90b9a95c1901ad1d56cdef7cce8bca9efc092198607944f142f8fec924b13219ca6663facd0f0d59b671b8b3de58ab3449c4c863d42e2937f02184 fix-getproto.patch
+1f694fc151f6578080449e3aa999c520486bbe117b8237150966ec43092db4156e81412ac889045e0c0c3bf65d459af5bdc1cf19c9fa3dab120405a60732f15a stacksize.patch"
diff --git a/system/nspr/stacksize.patch b/system/nspr/stacksize.patch
new file mode 100644
index 000000000..c2fcecd68
--- /dev/null
+++ b/system/nspr/stacksize.patch
@@ -0,0 +1,22 @@
+set a minimum stack size on ppc64 to prevent crashes
+
+Firefox, a user of nspr, attempts to set a stack size of 32k in its
+JS watchdog, which the pthreads impl doesn't like and fails.
+
+Coincidentally, nspr here is compiled with debug on, which means it has
+assertions turned on; under normal circumstances, those would be disabled,
+the stack size set call would fail and everything would fall back on the
+default 2M stacksize, but it would still be wrong - therefore, establish
+a minimum, just like for aarch64.
+
+--- nspr-4.20/nspr/pr/include/md/_linux.h.old 2018-08-28 12:42:28.000000000 +0000
++++ nspr-4.20/nspr/pr/include/md/_linux.h 2019-02-18 17:35:30.380000000 +0000
+@@ -71,7 +71,7 @@
+ #define _MD_DEFAULT_STACK_SIZE 65536L
+ #define _MD_MMAP_FLAGS MAP_PRIVATE
+
+-#if defined(__aarch64__) || defined(__mips__)
++#if defined(__aarch64__) || defined(__mips__) || defined(__powerpc64__)
+ #define _MD_MINIMUM_STACK_SIZE 0x20000
+ #endif
+
diff --git a/system/perl-cpanel-json-xs/APKBUILD b/system/perl-cpanel-json-xs/APKBUILD
index 76e9a74a9..3792720b6 100644
--- a/system/perl-cpanel-json-xs/APKBUILD
+++ b/system/perl-cpanel-json-xs/APKBUILD
@@ -3,7 +3,7 @@
# Maintainer: Adélie Perl Team <adelie-perl@lists.adelielinux.org>
pkgname=perl-cpanel-json-xs
_pkgreal=Cpanel-JSON-XS
-pkgver=4.08
+pkgver=4.09
pkgrel=0
pkgdesc="cPanel's fork of JSON::XS, fast and correct serialising"
url="https://metacpan.org/release/Cpanel-JSON-XS"
@@ -40,4 +40,4 @@ package() {
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
-sha512sums="7236923791b244e022cea00f3c8697905a8187edddaf0b197ee6f8a4afe958c42ea37f655e0db8e4c66a07427b7888e68ae1dc08849ef7cbb518155b2d9c65f5 Cpanel-JSON-XS-4.08.tar.gz"
+sha512sums="9d0771129a473b696bcfd502303a88e8e97f0dc2cf2b97003328edf72182400b8c07a2f5cf120f102c32a04118d4530f3d7da369c9b063554d2cfc0feddbb6aa Cpanel-JSON-XS-4.09.tar.gz"
diff --git a/system/vim/APKBUILD b/system/vim/APKBUILD
index ef3026655..9c75b2621 100644
--- a/system/vim/APKBUILD
+++ b/system/vim/APKBUILD
@@ -4,7 +4,7 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
pkgname=vim
-pkgver=8.1.0885
+pkgver=8.1.0952
pkgrel=0
pkgdesc="advanced text editor"
url="http://www.vim.org"
@@ -81,6 +81,6 @@ vimdiff() {
mv "$pkgdir"/usr/bin/vimdiff "$subpkgdir"/usr/bin
}
-sha512sums="c36737899eaf3e369a60d41cf909d421a3fc3cc13a77e63a5a5e12fae65652cd94d2b12368f2d1bbf785d3249ffb78107a8d09d77153632c77a276e3ee056339 vim-8.1.0885.tar.gz
+sha512sums="485d839901b3d1fc8efcc035991d5f34849f6d05d9c556dcf5b2918cd01e7f7b490cd0a7eb976c7577adb41962dceea4552474103f0b3c7807311d07f8158bd1 vim-8.1.0952.tar.gz
12ee3f96c94d74215159fba379ed61907ec5982a9f1643575dcb7c3d5e30824665d683de95f97b5067718b3f2a1238fb7534a70803bc170614498ad026f352d8 vimrc
16026a3ed3e080b3f8281948579ab678e9acd724ad594463279712fbf1024bcd923155a133bd08118848d2c6cdf11c69489d85b1c7438f60b4c279094714d181 no-default-mouse.patch"