summaryrefslogtreecommitdiff
path: root/system
diff options
context:
space:
mode:
Diffstat (limited to 'system')
-rw-r--r--system/musl-locales/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/system/musl-locales/APKBUILD b/system/musl-locales/APKBUILD
new file mode 100644
index 000000000..f537430d0
--- /dev/null
+++ b/system/musl-locales/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor: Alyx <alyx@leuhta.com>
+# Maintainer: Alyx <alyx@leuhta.com>
+pkgname=musl-locales
+pkgver=0.20200319
+pkgrel=0
+pkgdesc="Locale program for musl"
+url="https://gitlab.com/rilian-la-te/musl-locales"
+arch="all"
+options="!check" # No test suite.
+license="LGPL-3.0-only"
+depends=""
+makedepends="cmake make gettext-tiny-dev"
+subpackages="$pkgname-lang"
+source="https://distfiles.adelielinux.org/source/$pkgname-$pkgver.tar.xz"
+
+build() {
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ .
+ make
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+lang() {
+ license="MIT"
+ default_lang
+}
+
+sha512sums="921c5a4dfb45ac12b1eaf284986237bd95420a58705702d0541a46fa2480ff97cd3ac929661108c67304e4e1bfe1efed7bf8edd535b7260d7eb69d72aa294e45 musl-locales-0.20200319.tar.xz"