summaryrefslogtreecommitdiff
path: root/system
diff options
context:
space:
mode:
Diffstat (limited to 'system')
-rw-r--r--system/python3/APKBUILD8
1 files changed, 7 insertions, 1 deletions
diff --git a/system/python3/APKBUILD b/system/python3/APKBUILD
index f14f72b1c..250f259b6 100644
--- a/system/python3/APKBUILD
+++ b/system/python3/APKBUILD
@@ -136,7 +136,13 @@ EOF
# dumb
fail="$fail test_ssl" # tries to do SSLv2 which we have disabled in OpenSSL
- make quicktest TESTOPTS="--exclude $fail"
+ # needs network but doesn't declare it
+ fail="$fail test_normalization"
+
+ # defaults from Tools/scripts/run_tests.py, with -network added
+ use="all,-largefile,-audio,-gui,-network"
+
+ make quicktest TESTOPTS="--use '$use' --exclude $fail"
}
package() {