summaryrefslogtreecommitdiff
path: root/system
diff options
context:
space:
mode:
Diffstat (limited to 'system')
-rw-r--r--system/build-tools/APKBUILD4
-rw-r--r--system/fortify-headers/APKBUILD18
-rw-r--r--system/fortify-headers/extension-cpp-fix.patch175
-rw-r--r--system/perl-test-simple/APKBUILD4
-rw-r--r--system/vim/APKBUILD4
5 files changed, 6 insertions, 199 deletions
diff --git a/system/build-tools/APKBUILD b/system/build-tools/APKBUILD
index 39495ec5b..e5ff48c72 100644
--- a/system/build-tools/APKBUILD
+++ b/system/build-tools/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=build-tools
pkgver=1.0
-pkgrel=7
+pkgrel=8
pkgdesc="Meta-package for user development utilities"
url="https://adelielinux.org/"
arch="noarch"
@@ -11,7 +11,7 @@ depends="bash gettext-tiny gettext-tiny-dev
binutils gcc g++
make
diffutils patch
- fortify-headers linux-headers
+ linux-headers
mawk sed
bzip2 gzip unzip xz
abuild"
diff --git a/system/fortify-headers/APKBUILD b/system/fortify-headers/APKBUILD
deleted file mode 100644
index 33ee4e317..000000000
--- a/system/fortify-headers/APKBUILD
+++ /dev/null
@@ -1,18 +0,0 @@
-# Contributor: Timo Teräs <timo.teras@iki.fi>
-# Maintainer: Adelie Platform Group <adelie-devel@lists.adelielinux.org>
-pkgname=fortify-headers
-pkgver=1.0
-pkgrel=0
-pkgdesc="libc-agnostic implementation of FORTIFY_SOURCE"
-url="https://git.2f30.org/fortify-headers/"
-arch="noarch"
-options="!check" # No test suite.
-license="0BSD"
-source="https://dl.2f30.org/releases/$pkgname-$pkgver.tar.gz"
-
-package() {
- cd "$builddir"
- make DESTDIR="$pkgdir" PREFIX=/usr install
-}
-
-sha512sums="085a725da9a6da0eea732ee77e3a3dc7d3c96bc3344172523db5f1e35391492910a050c15c560912115b2db916c2d6fa37e409e997c53399ee4fee912c5513e8 fortify-headers-1.0.tar.gz"
diff --git a/system/fortify-headers/extension-cpp-fix.patch b/system/fortify-headers/extension-cpp-fix.patch
deleted file mode 100644
index fc7bbb5f8..000000000
--- a/system/fortify-headers/extension-cpp-fix.patch
+++ /dev/null
@@ -1,175 +0,0 @@
-From a29bd89353a05454e2545d52124f9a1a61b4e3e3 Mon Sep 17 00:00:00 2001
-From: "A. Wilcox" <AWilcox@Wilcox-Tech.com>
-Date: Sat, 23 Jun 2018 17:57:48 -0500
-Subject: [PATCH] Don't use __extension__ in C++ code
-
-A few important notes:
-
-* __extension__ is a GNU C "alternate" keyword, not a C++ keyword.[1]
-
-* __extension__ is designed to work on "expressions"; it does work on
- #include_next in C mode, but it has no effect in C++ mode; the
- warning will still appear, if enabled, even with __extension__
- preceding #include_next. This is because #include_next is not
- considered an expression in C++, so the compiler attaches
- __extension__ to the first expression of the header.
-
-All of this leads us to a build failure while building at least all
-Mozilla software. Moz has an alternate -isystem dir searched before
-/usr/include that overrides some headers, including <features.h>. The
-first statement in each of these headers is a #pragma, and since
-__extension__ is looking for an expression, and #pragma is a "null"
-expression, we end up with the following error:
-
-dist/system_wrappers/features.h:1:9: error: '#pragma' is not allowed here
-
-Since __extension__ has no effect on #include_next in C++ mode anyway,
-and since it can cause breakage, this commit omits __extension__ in C++
-mode.
-
-[1]: https://gcc.gnu.org/onlinedocs/gcc-6.4.0/gcc/Alternate-Keywords.html
----
- include/poll.h | 2 ++
- include/stdio.h | 2 ++
- include/stdlib.h | 4 ++++
- include/string.h | 2 ++
- include/sys/select.h | 2 ++
- include/sys/socket.h | 2 ++
- include/unistd.h | 2 ++
- include/wchar.h | 8 ++++++++
- 8 files changed, 24 insertions(+)
-
-diff --git a/include/poll.h b/include/poll.h
-index 7b42866..24691f1 100644
---- a/include/poll.h
-+++ b/include/poll.h
-@@ -16,7 +16,9 @@
- #ifndef _FORTIFY_POLL_H
- #define _FORTIFY_POLL_H
-
-+#ifndef __cplusplus
- __extension__
-+#endif
- #include_next <poll.h>
-
- #if defined(_FORTIFY_SOURCE) && _FORTIFY_SOURCE > 0 && defined(__OPTIMIZE__) && __OPTIMIZE__ > 0
-diff --git a/include/stdio.h b/include/stdio.h
-index b67f9ce..a965184 100644
---- a/include/stdio.h
-+++ b/include/stdio.h
-@@ -16,7 +16,9 @@
- #ifndef _FORTIFY_STDIO_H
- #define _FORTIFY_STDIO_H
-
-+#ifndef __cplusplus
- __extension__
-+#endif
- #include_next <stdio.h>
-
- #if defined(_FORTIFY_SOURCE) && _FORTIFY_SOURCE > 0 && defined(__OPTIMIZE__) && __OPTIMIZE__ > 0
-diff --git a/include/stdlib.h b/include/stdlib.h
-index 7ff5746..ef70995 100644
---- a/include/stdlib.h
-+++ b/include/stdlib.h
-@@ -16,12 +16,16 @@
- #ifndef _FORTIFY_STDLIB_H
- #define _FORTIFY_STDLIB_H
-
-+#ifndef __cplusplus
- __extension__
-+#endif
- #include_next <stdlib.h>
-
- #if defined(_FORTIFY_SOURCE) && _FORTIFY_SOURCE > 0 && defined(__OPTIMIZE__) && __OPTIMIZE__ > 0
- #if defined(_XOPEN_SOURCE) || defined(_GNU_SOURCE) || defined(_BSD_SOURCE)
-+#ifndef __cplusplus
- __extension__
-+#endif
- #include_next <limits.h>
- #endif
-
-diff --git a/include/string.h b/include/string.h
-index ff237b0..43c7485 100644
---- a/include/string.h
-+++ b/include/string.h
-@@ -16,7 +16,9 @@
- #ifndef _FORTIFY_STRING_H
- #define _FORTIFY_STRING_H
-
-+#ifndef __cplusplus
- __extension__
-+#endif
- #include_next <string.h>
-
- #if defined(_FORTIFY_SOURCE) && _FORTIFY_SOURCE > 0 && defined(__OPTIMIZE__) && __OPTIMIZE__ > 0
-diff --git a/include/sys/select.h b/include/sys/select.h
-index e4e398f..bcee8be 100644
---- a/include/sys/select.h
-+++ b/include/sys/select.h
-@@ -16,7 +16,9 @@
- #ifndef _FORTIFY_SYS_SELECT_H
- #define _FORTIFY_SYS_SELECT_H
-
-+#ifndef __cplusplus
- __extension__
-+#endif
- #include_next <sys/select.h>
-
- #if defined(_FORTIFY_SOURCE) && _FORTIFY_SOURCE > 0 && defined(__OPTIMIZE__) && __OPTIMIZE__ > 0
-diff --git a/include/sys/socket.h b/include/sys/socket.h
-index 7d3f023..ad6ab2d 100644
---- a/include/sys/socket.h
-+++ b/include/sys/socket.h
-@@ -16,7 +16,9 @@
- #ifndef _FORTIFY_SYS_SOCKET_H
- #define _FORTIFY_SYS_SOCKET_H
-
-+#ifndef __cplusplus
- __extension__
-+#endif
- #include_next <sys/socket.h>
-
- #if defined(_FORTIFY_SOURCE) && _FORTIFY_SOURCE > 0 && defined(__OPTIMIZE__) && __OPTIMIZE__ > 0
-diff --git a/include/unistd.h b/include/unistd.h
-index d3ab246..71dda84 100644
---- a/include/unistd.h
-+++ b/include/unistd.h
-@@ -16,7 +16,9 @@
- #ifndef _FORTIFY_UNISTD_H
- #define _FORTIFY_UNISTD_H
-
-+#ifndef __cplusplus
- __extension__
-+#endif
- #include_next <unistd.h>
-
- #if defined(_FORTIFY_SOURCE) && _FORTIFY_SOURCE > 0 && defined(__OPTIMIZE__) && __OPTIMIZE__ > 0
-diff --git a/include/wchar.h b/include/wchar.h
-index 7394598..3cb6f92 100644
---- a/include/wchar.h
-+++ b/include/wchar.h
-@@ -16,13 +16,21 @@
- #ifndef _FORTIFY_WCHAR_H
- #define _FORTIFY_WCHAR_H
-
-+#ifndef __cplusplus
- __extension__
-+#endif
- #include_next <limits.h>
-+#ifndef __cplusplus
- __extension__
-+#endif
- #include_next <stdlib.h>
-+#ifndef __cplusplus
- __extension__
-+#endif
- #include_next <string.h>
-+#ifndef __cplusplus
- __extension__
-+#endif
- #include_next <wchar.h>
-
- #if defined(_FORTIFY_SOURCE) && _FORTIFY_SOURCE > 0 && defined(__OPTIMIZE__) && __OPTIMIZE__ > 0
---
-2.15.0
-
diff --git a/system/perl-test-simple/APKBUILD b/system/perl-test-simple/APKBUILD
index 1462197f8..ac80247c5 100644
--- a/system/perl-test-simple/APKBUILD
+++ b/system/perl-test-simple/APKBUILD
@@ -3,7 +3,7 @@
# Maintainer: Adélie Perl Team <adelie-perl@lists.adelielinux.org>
pkgname=perl-test-simple
_pkgreal=Test-Simple
-pkgver=1.302160
+pkgver=1.302162
pkgrel=0
pkgdesc="Basic utilities for writing Perl tests"
url="https://metacpan.org/release/Test-Simple"
@@ -47,4 +47,4 @@ doc() {
replaces="perl-doc"
}
-sha512sums="3df744efbf5e2bf1b03849f35bec32f0b0546efbe968e38ed55a472d92f2b2f5a7cf63e82d6fda7ec2406c403c053a32285d29dcf21d28030a924bc751e16548 Test-Simple-1.302160.tar.gz"
+sha512sums="1e8ac18986f4e8ae44f385a4db025adc714dd355b8590472392468a8865a2a21d0a30484c196f4cb31fcb1fcff85e7e06f8402931d8f9b04fea4139399aad116 Test-Simple-1.302162.tar.gz"
diff --git a/system/vim/APKBUILD b/system/vim/APKBUILD
index 13dff8ef9..ef3026655 100644
--- a/system/vim/APKBUILD
+++ b/system/vim/APKBUILD
@@ -4,7 +4,7 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
pkgname=vim
-pkgver=8.1.0829
+pkgver=8.1.0885
pkgrel=0
pkgdesc="advanced text editor"
url="http://www.vim.org"
@@ -81,6 +81,6 @@ vimdiff() {
mv "$pkgdir"/usr/bin/vimdiff "$subpkgdir"/usr/bin
}
-sha512sums="c5ae44a6ad45092abc1079b0543af3c34d49823a95f96bbb8dbe3f5426556ee9dbf78d2bda747286527977dafef7e6051a670d0095456263e853d424ddb2466c vim-8.1.0829.tar.gz
+sha512sums="c36737899eaf3e369a60d41cf909d421a3fc3cc13a77e63a5a5e12fae65652cd94d2b12368f2d1bbf785d3249ffb78107a8d09d77153632c77a276e3ee056339 vim-8.1.0885.tar.gz
12ee3f96c94d74215159fba379ed61907ec5982a9f1643575dcb7c3d5e30824665d683de95f97b5067718b3f2a1238fb7534a70803bc170614498ad026f352d8 vimrc
16026a3ed3e080b3f8281948579ab678e9acd724ad594463279712fbf1024bcd923155a133bd08118848d2c6cdf11c69489d85b1c7438f60b4c279094714d181 no-default-mouse.patch"