summaryrefslogtreecommitdiff
path: root/system
diff options
context:
space:
mode:
Diffstat (limited to 'system')
-rw-r--r--system/zstd/APKBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/system/zstd/APKBUILD b/system/zstd/APKBUILD
new file mode 100644
index 000000000..de125ca8d
--- /dev/null
+++ b/system/zstd/APKBUILD
@@ -0,0 +1,27 @@
+# Contributor: A. Wilcox <awilfox@adelielinux.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=zstd
+pkgver=1.4.2
+pkgrel=0
+pkgdesc="Fast real-time compression algorithm"
+url="https://facebook.github.io/zstd/"
+arch="all"
+license="BSD-3-Clause AND GPL-2.0-only"
+depends=""
+makedepends="lz4-dev xz-dev zlib-dev"
+subpackages="$pkgname-dev $pkgname-doc"
+source="https://github.com/facebook/zstd/releases/download/v$pkgver/zstd-$pkgver.tar.gz"
+
+build() {
+ make PREFIX="/usr"
+}
+
+check() {
+ make PREFIX="/usr" check
+}
+
+package() {
+ make PREFIX="/usr" DESTDIR="$pkgdir" install
+}
+
+sha512sums="b760f201ff8d018c422b030d3f59245b5f1cfd157ba8d6eb9fe9240e23d5739ca7b5a705b2d5e8ace703d041ab77bea66d735b283e51facfb18923794fabe213 zstd-1.4.2.tar.gz"