summaryrefslogtreecommitdiff
path: root/system
diff options
context:
space:
mode:
Diffstat (limited to 'system')
-rw-r--r--system/adelie-base/APKBUILD6
-rw-r--r--system/openssl/APKBUILD7
-rw-r--r--system/zsh/APKBUILD5
-rw-r--r--system/zsh/zprofile2
4 files changed, 13 insertions, 7 deletions
diff --git a/system/adelie-base/APKBUILD b/system/adelie-base/APKBUILD
index 7ab59cbb5..04b100e69 100644
--- a/system/adelie-base/APKBUILD
+++ b/system/adelie-base/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: A. Wilcox <awilfox@adelielinux.org>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=adelie-base
-pkgver=0.9.3
-pkgrel=1
+pkgver=0.9.4
+pkgrel=0
pkgdesc="The Adélie Linux Base System"
url="https://www.adelielinux.org/"
arch="noarch"
@@ -115,7 +115,7 @@ symbols() {
return 0
}
-sha512sums="a9690b20f90b94bda458e0570db55ce835e3d34ef04a3ea3f3d77e2d97483cecb940dbc3a1f2def72ff2589cc5b9cbe42ae38dc25d9b9ca25960a4832c87c7b4 adelie-base-0.9.3.tar.xz
+sha512sums="37b8ee0d8f005077c69da72c9f4ca8afe4eacc25aed365992218f1b06b7946666e4060c958eb94bdebdba4b9fc2b4d165bf098ceb4f9f4cf544fb2935e1dd1a7 adelie-base-0.9.4.tar.xz
37260d9315fd8d8b0df3dfb5bd3e1035a47ba1e43f33aa195e3feca6d169da282c1b067ef4603e7e9acaedbfef8b58cf490c00bdca444d43c9d570355ad29eac group
3ee7ebe2ca762029fa1795471735922416a2ec7683774d107b38bcd7aeb8277046edeff0c26b1f1195739478e1e11fb7a51c55149cf79adab44ed217334b7013 passwd
f2437ebfbc83aa6eaeec3a111aae98751215cebfaec3991ccc511be8c8938778ae46f15e07c7306bd431d036bc4ba49b33b724b839c125bd882d2e93c0314ae8 addgroup
diff --git a/system/openssl/APKBUILD b/system/openssl/APKBUILD
index dc4c4aab4..070d3d0e2 100644
--- a/system/openssl/APKBUILD
+++ b/system/openssl/APKBUILD
@@ -97,6 +97,13 @@ check() {
package() {
make DESTDIR="$pkgdir" install
rm "$pkgdir"/usr/bin/c_rehash
+
+ for _manfile in "$pkgdir"/usr/share/man/man1/*; do
+ case _manfile in
+ openssl*) ;;
+ *) mv $_manfile "$pkgdir"/usr/share/man/man1/openssl-$(basename $_manfile)
+ esac
+ done
}
libcrypto() {
diff --git a/system/zsh/APKBUILD b/system/zsh/APKBUILD
index a85083fc4..3bc96b226 100644
--- a/system/zsh/APKBUILD
+++ b/system/zsh/APKBUILD
@@ -4,7 +4,7 @@
# Maintainer: Dan Theisen <djt@hxx.in>
pkgname=zsh
pkgver=5.7.1
-pkgrel=2
+pkgrel=3
pkgdesc="A very advanced and programmable command interpreter (shell)"
url="https://www.zsh.org/"
arch="all"
@@ -98,6 +98,7 @@ build() {
--enable-unicode9 \
--enable-multibyte \
--enable-function-subdirs \
+ --enable-zprofile=/etc/zsh/zprofile \
--enable-zsh-secure-free \
--with-tcsetpgrp
make
@@ -179,5 +180,5 @@ _submv() {
sha512sums="a6aa88e1955a80229a4784a128866e325f79a8b5f73c922ab480048411036f1835cbb31daa30ab38bd16ab2a50040eda8f4f1f64704b21b6acc3051b1dbf18d0 zsh-5.7.1.tar.xz
d820fcf65bb3c52f23e968110b5df1188fc0b64079312f64d22ffe35de3b4f3055d4d629b3b0f97a1bfaddf62dbc80676af31c3a1a79645632082abfc854cf97 skel
-e90723eb790581419498f3ab86fb5d6cab4aaede8c87eb79ead7047d259b643cfb47f4d1beb06d03e038cfda3a20ef9dd4c1b417270ab55c688e166fe30ef4f6 zprofile
+63167188e22bf8933eb420a5ba068ab897531b90c8d8b8ec892f26a9180267a971013046a72b810d5b9d3add427cf650df608b0e008cd0789681ed1371b172c3 zprofile
1675e016f97333cad89b587f4292d81b6bc10e27b75482e3e0c3808539c95bd49b907b6579fb98d817f77f2f2384c0df5afa3e2b6f43b6ae9b466925cd9ccffc zshrc"
diff --git a/system/zsh/zprofile b/system/zsh/zprofile
index 50cbdaaaa..df7a3f76e 100644
--- a/system/zsh/zprofile
+++ b/system/zsh/zprofile
@@ -2,8 +2,6 @@
# /etc/zprofile and ~/.zprofile are run for login shells
#
-export PATH="$PATH:$HOME/bin"
-
_src_etc_profile()
{
# Make /etc/profile happier, and have possible ~/.zshenv options like