summaryrefslogtreecommitdiff
path: root/system
diff options
context:
space:
mode:
Diffstat (limited to 'system')
-rw-r--r--system/ruby/APKBUILD6
-rw-r--r--system/ruby/libedit-compat.patch22
2 files changed, 26 insertions, 2 deletions
diff --git a/system/ruby/APKBUILD b/system/ruby/APKBUILD
index 1a26b65b3..e608e4637 100644
--- a/system/ruby/APKBUILD
+++ b/system/ruby/APKBUILD
@@ -35,7 +35,7 @@
pkgname=ruby
pkgver=2.5.5
_abiver="${pkgver%.*}.0"
-pkgrel=1
+pkgrel=2
pkgdesc="An object-oriented language for quick and easy programming"
url="https://www.ruby-lang.org/"
arch="all"
@@ -68,6 +68,7 @@ source="https://cache.ruby-lang.org/pub/ruby/${pkgver%.*}/$pkgname-$pkgver.tar.x
rubygems-avoid-platform-specific-gems.patch
test_insns-lower-recursion-depth.patch
fix-get_main_stack.patch
+ libedit-compat.patch
"
replaces="ruby-etc ruby-gems"
@@ -309,4 +310,5 @@ _mvgem() {
sha512sums="06b1d58536ebfacb7b56c1e6ed4b8ab816fadc4f48c845a452554cd262e7908199a30e5793f3cbaec2db56a8803aa5c6089abf7bf06c8fc47867e97870b7dfec ruby-2.5.5.tar.xz
20e7e5ee9936a93872fe1ad836dd1fde001fe4a0e7ed54c26727ad83da3ceb0e6247681d9dd4f98a69e1b0250703ed8fc682d44075780d5f47faa1d5f58d2bdb rubygems-avoid-platform-specific-gems.patch
814fe6359505b70d8ff680adf22f20a74b4dbd3fecc9a63a6c2456ee9824257815929917b6df5394ed069a6869511b8c6dce5b95b4acbbb7867c1f3a975a0150 test_insns-lower-recursion-depth.patch
-e99b36940fa8fdd445d82738c70b8fc042cab042a4662cab156578aad2dac9673a96da22b6676aa36beac08070e92a7798c60d6f36eeb169216c4c51864ce2fe fix-get_main_stack.patch"
+e99b36940fa8fdd445d82738c70b8fc042cab042a4662cab156578aad2dac9673a96da22b6676aa36beac08070e92a7798c60d6f36eeb169216c4c51864ce2fe fix-get_main_stack.patch
+6b88fccce164db1d8beb16adeffdd7effd077e9842b7f61deddebeb39afcf9b839192b68a43ce66a1ff0c9aeaacc4f13a0ee56184c22e822cd8b10a07a1c87b2 libedit-compat.patch"
diff --git a/system/ruby/libedit-compat.patch b/system/ruby/libedit-compat.patch
new file mode 100644
index 000000000..601a9feea
--- /dev/null
+++ b/system/ruby/libedit-compat.patch
@@ -0,0 +1,22 @@
+--- ruby-2.5.5/ext/readline/readline.c.old 2017-09-30 08:35:23.000000000 +0000
++++ ruby-2.5.5/ext/readline/readline.c 2019-09-09 06:12:00.300098741 +0000
+@@ -571,6 +571,9 @@
+ rb_syserr_fail(save_errno, "fdopen");
+ }
+ rl_instream = readline_rl_instream = f;
++#ifdef HAVE_EDITLINE_READLINE_H
++ rl_initialize();
++#endif
+ readline_instream = input;
+ }
+ return input;
+@@ -607,6 +610,9 @@
+ rb_syserr_fail(save_errno, "fdopen");
+ }
+ rl_outstream = readline_rl_outstream = f;
++#ifdef HAVE_EDITLINE_READLINE_H
++ rl_initialize();
++#endif
+ readline_outstream = output;
+ }
+ return output;