summaryrefslogtreecommitdiff
path: root/system
diff options
context:
space:
mode:
Diffstat (limited to 'system')
-rw-r--r--system/apk-tools/APKBUILD6
-rw-r--r--system/apk-tools/pmmx.patch11
-rw-r--r--system/ca-certificates/APKBUILD5
-rw-r--r--system/perl-dbd-sqlite/APKBUILD4
-rw-r--r--system/perl-encode-eucjpascii/APKBUILD2
-rw-r--r--system/perl-encode-hanextra/APKBUILD2
-rw-r--r--system/perl-encode-iso2022/APKBUILD2
-rw-r--r--system/perl-encode-jisx0213/APKBUILD2
-rw-r--r--system/perl-json/APKBUILD3
-rw-r--r--system/perl-mime-charset/APKBUILD2
-rw-r--r--system/perl-module-build/APKBUILD2
-rw-r--r--system/perl-pod2-base/APKBUILD2
-rw-r--r--system/perl-sgmls/APKBUILD2
-rw-r--r--system/perl-test-needs/APKBUILD2
-rw-r--r--system/perl-test-pod/APKBUILD4
-rw-r--r--system/perl-unicode-linebreak/APKBUILD6
-rw-r--r--system/perl-uri/APKBUILD2
-rw-r--r--system/perl/APKBUILD3
-rw-r--r--system/util-linux/APKBUILD7
-rw-r--r--system/utmps/APKBUILD4
-rw-r--r--system/vim/APKBUILD4
21 files changed, 46 insertions, 31 deletions
diff --git a/system/apk-tools/APKBUILD b/system/apk-tools/APKBUILD
index 746468fab..40dfcb272 100644
--- a/system/apk-tools/APKBUILD
+++ b/system/apk-tools/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Adelie Platform Group <adelie-devel@lists.adelielinux.org>
pkgname=apk-tools
-pkgver=2.10.1
+pkgver=2.10.3
pkgrel=0
pkgdesc="Alpine Package Keeper - package manager"
url="https://git.alpinelinux.org/cgit/apk-tools/"
@@ -13,6 +13,7 @@ makedepends_host="zlib-dev openssl openssl-dev linux-headers"
makedepends="$makedepends_build $makedepends_host"
subpackages="$pkgname-static"
source="http://dev.alpinelinux.org/archive/$pkgname/$pkgname-$pkgver.tar.xz
+ pmmx.patch
"
prepare() {
@@ -66,4 +67,5 @@ static() {
"$subpkgdir"/sbin/apk.static
}
-sha512sums="f994dba20b9ba7ee0ad4cbd9d137f65b814851f348f0d5eb75eb60c7d6a21f88648b472239e14298eaf1348c517de00652432e7f8c8abd54565914c7d49e3cd3 apk-tools-2.10.1.tar.xz"
+sha512sums="1b190cfd04c69369bd4f2b708d4df0f8cf2937e1580c95138fd2c2257e7604d015deaca10a9fe0da6742981caadb6b067c15e417a1951866f781b8a5c71c98ee apk-tools-2.10.3.tar.xz
+746d00ce2af554a25db7ecea2b0a4d8f7399d2560efb6bf59ea144012d0163d3e0bad84c799bd706e8be6c0a543d4e35728d6beb269fddbbea626384009129cb pmmx.patch"
diff --git a/system/apk-tools/pmmx.patch b/system/apk-tools/pmmx.patch
new file mode 100644
index 000000000..1b19edc94
--- /dev/null
+++ b/system/apk-tools/pmmx.patch
@@ -0,0 +1,11 @@
+--- apk-tools-2.10.1/src/apk_defines.h.old 2018-09-10 08:04:03.000000000 +0000
++++ apk-tools-2.10.1/src/apk_defines.h 2019-01-04 03:31:41.900000000 +0000
+@@ -88,7 +88,7 @@
+ #if defined(__x86_64__)
+ #define APK_DEFAULT_ARCH "x86_64"
+ #elif defined(__i386__)
+-#define APK_DEFAULT_ARCH "x86"
++#define APK_DEFAULT_ARCH "pmmx"
+ #elif defined(__powerpc__) && !defined(__powerpc64__)
+ #define APK_DEFAULT_ARCH "ppc"
+ #elif defined(__powerpc64__) && __BYTE_ORDER__ == __ORDER_BIG_ENDIAN__
diff --git a/system/ca-certificates/APKBUILD b/system/ca-certificates/APKBUILD
index 1d7bfbd6f..3dab0f01b 100644
--- a/system/ca-certificates/APKBUILD
+++ b/system/ca-certificates/APKBUILD
@@ -3,13 +3,13 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=ca-certificates
pkgver=20180411
-pkgrel=0
+pkgrel=1
pkgdesc="CA root certificates"
url="https://www.mozilla.org/en-US/about/governance/policies/security-group/certs/"
arch="all"
options="!fhs !check"
license="MPL-2.0 GPL-2.0+"
-depends=""
+depends="debianutils"
makedepends_build="python3"
makedepends_host="openssl-dev"
subpackages="$pkgname-doc"
@@ -21,6 +21,7 @@ source="https://distfiles.adelielinux.org/source/$pkgname-$pkgver.tar.xz"
build() {
cd "$builddir"
+ export CFLAGS="$CFLAGS -DSYMLINK_MAX=PATH_MAX"
make
}
diff --git a/system/perl-dbd-sqlite/APKBUILD b/system/perl-dbd-sqlite/APKBUILD
index de26fcf57..066b7b4b8 100644
--- a/system/perl-dbd-sqlite/APKBUILD
+++ b/system/perl-dbd-sqlite/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Adélie Perl Team <adelie-perl@lists.adelielinux.org>
pkgname=perl-dbd-sqlite
_pkgname=DBD-SQLite
-pkgver=1.60
+pkgver=1.62
pkgrel=0
pkgdesc="Perl DBI SQLite module"
url="https://metacpan.org/release/DBD-SQLite"
@@ -40,5 +40,5 @@ package() {
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
-sha512sums="b5fd203898815ada13ec04477fa0ad90ec2f53761d9b1ed7cce7d06a674e31d3810e745658aea150a3a58fc18adb889e5e50e795e8575318ab4cc757c1ff1c9e DBD-SQLite-1.60.tar.gz
+sha512sums="b452a6245deb0dcc5906167f6ff14d55d70b4f05a1e8113c41810a34f9b75263c2d43f88bb909d872004795ec7d9f4ed93b68ffb5639be7dad9e44e0c8e8439f DBD-SQLite-1.62.tar.gz
00961932f9f89d9b46e6134150c2628aadd4cfa7159cb1604de023fedc919087fbf982b72fd51610e1ca390234cd939e74430b270131d0b30cedb97ba6203b49 perl-DBD-SQLite-bz543982.patch"
diff --git a/system/perl-encode-eucjpascii/APKBUILD b/system/perl-encode-eucjpascii/APKBUILD
index a1febaadb..9e174dc10 100644
--- a/system/perl-encode-eucjpascii/APKBUILD
+++ b/system/perl-encode-eucjpascii/APKBUILD
@@ -1,5 +1,5 @@
# Contributor: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
-# Maintainer: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
+# Maintainer: Adélie Perl Team <adelie-perl@lists.adelielinux.org>
pkgname=perl-encode-eucjpascii
pkgver=0.03
pkgrel=0
diff --git a/system/perl-encode-hanextra/APKBUILD b/system/perl-encode-hanextra/APKBUILD
index e82241be9..dce57db59 100644
--- a/system/perl-encode-hanextra/APKBUILD
+++ b/system/perl-encode-hanextra/APKBUILD
@@ -1,5 +1,5 @@
# Contributor: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
-# Maintainer: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
+# Maintainer: Adélie Perl Team <adelie-perl@lists.adelielinux.org>
pkgname=perl-encode-hanextra
pkgver=0.23
pkgrel=0
diff --git a/system/perl-encode-iso2022/APKBUILD b/system/perl-encode-iso2022/APKBUILD
index 0c10974b1..2c0321813 100644
--- a/system/perl-encode-iso2022/APKBUILD
+++ b/system/perl-encode-iso2022/APKBUILD
@@ -1,5 +1,5 @@
# Contributor: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
-# Maintainer: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
+# Maintainer: Adélie Perl Team <adelie-perl@lists.adelielinux.org>
pkgname=perl-encode-iso2022
pkgver=0.04
pkgrel=0
diff --git a/system/perl-encode-jisx0213/APKBUILD b/system/perl-encode-jisx0213/APKBUILD
index 64dbf52f3..b5fe8f8f3 100644
--- a/system/perl-encode-jisx0213/APKBUILD
+++ b/system/perl-encode-jisx0213/APKBUILD
@@ -1,5 +1,5 @@
# Contributor: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
-# Maintainer: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
+# Maintainer: Adélie Perl Team <adelie-perl@lists.adelielinux.org>
pkgname=perl-encode-jisx0213
pkgver=0.04
pkgrel=0
diff --git a/system/perl-json/APKBUILD b/system/perl-json/APKBUILD
index 1c6b4fdea..d2d7c2789 100644
--- a/system/perl-json/APKBUILD
+++ b/system/perl-json/APKBUILD
@@ -1,4 +1,5 @@
-# Maintainer: Kiyoshi Aman <kiyoshi.aman@gmail.com>
+# Contributor: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
+# Maintainer: Adélie Perl Team <adelie-perl@lists.adelielinux.org>
pkgname=perl-json
_pkgreal=JSON
pkgver=2.97001
diff --git a/system/perl-mime-charset/APKBUILD b/system/perl-mime-charset/APKBUILD
index 7adb38810..0d4541a3f 100644
--- a/system/perl-mime-charset/APKBUILD
+++ b/system/perl-mime-charset/APKBUILD
@@ -1,5 +1,5 @@
# Contributor: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
-# Maintainer: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
+# Maintainer: Adélie Perl Team <adelie-perl@lists.adelielinux.org>
pkgname=perl-mime-charset
pkgver=1.012.2
pkgrel=0
diff --git a/system/perl-module-build/APKBUILD b/system/perl-module-build/APKBUILD
index dffb1853d..ddc802076 100644
--- a/system/perl-module-build/APKBUILD
+++ b/system/perl-module-build/APKBUILD
@@ -1,6 +1,6 @@
# Automatically generated by apkbuild-cpan, template 1
# Contributor: Francesco Colista <fcolista@alpinelinux.org>
-# Maintainer:
+# Maintainer: Adélie Perl Team <adelie-perl@lists.adelielinux.org>
pkgname=perl-module-build
_pkgreal=Module-Build
pkgver=0.4224
diff --git a/system/perl-pod2-base/APKBUILD b/system/perl-pod2-base/APKBUILD
index 9d19f9e5c..28d409678 100644
--- a/system/perl-pod2-base/APKBUILD
+++ b/system/perl-pod2-base/APKBUILD
@@ -1,5 +1,5 @@
# Contributor: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
-# Maintainer: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
+# Maintainer: Adélie Perl Team <adelie-perl@lists.adelielinux.org>
pkgname=perl-pod2-base
pkgver=0.043
pkgrel=0
diff --git a/system/perl-sgmls/APKBUILD b/system/perl-sgmls/APKBUILD
index 111830823..110fdbd99 100644
--- a/system/perl-sgmls/APKBUILD
+++ b/system/perl-sgmls/APKBUILD
@@ -1,5 +1,5 @@
# Contributor: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
-# Maintainer: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
+# Maintainer: Adélie Perl Team <adelie-perl@lists.adelielinux.org>
pkgname=perl-sgmls
pkgver=1.1
pkgrel=0
diff --git a/system/perl-test-needs/APKBUILD b/system/perl-test-needs/APKBUILD
index 1c2e096c3..ef283c065 100644
--- a/system/perl-test-needs/APKBUILD
+++ b/system/perl-test-needs/APKBUILD
@@ -1,5 +1,5 @@
# Contributor: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
-# Maintainer: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
+# Maintainer: Adélie Perl Team <adelie-perl@lists.adelielinux.org>
pkgname=perl-test-needs
pkgver=0.002005
pkgrel=0
diff --git a/system/perl-test-pod/APKBUILD b/system/perl-test-pod/APKBUILD
index 639ccdbd3..e2c3ae3c3 100644
--- a/system/perl-test-pod/APKBUILD
+++ b/system/perl-test-pod/APKBUILD
@@ -1,6 +1,6 @@
-# Automatically generated by apkbuild-cpan, template 1
# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
-# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+# Contributor: A. Wilcox <awilfox@adelielinux.org>
+# Maintainer: Adélie Perl Team <adelie-perl@lists.adelielinux.org>
pkgname=perl-test-pod
_pkgreal=Test-Pod
pkgver=1.52
diff --git a/system/perl-unicode-linebreak/APKBUILD b/system/perl-unicode-linebreak/APKBUILD
index c981c7e78..cea969562 100644
--- a/system/perl-unicode-linebreak/APKBUILD
+++ b/system/perl-unicode-linebreak/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
-# Maintainer: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
+# Maintainer: Adélie Perl Team <adelie-perl@lists.adelielinux.org>
pkgname=perl-unicode-linebreak
-pkgver=2018.003
+pkgver=2019.001
_univer=8.0.0 # update this and unicode.org URLs if sombok is ever updated
pkgrel=0
pkgdesc="Perl implementation of the UAX#14 Unicode line-breaking algorithm"
@@ -39,6 +39,6 @@ package() {
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
-sha512sums="37fa931978e1f88667b13ef25eb3b2414a6b055f03fec5925b3605e06026f06af332179e07f35d58f61924f43f305a5bc5ef1d76a61e1d56568abf60c9bf8fc7 Unicode-LineBreak-2018.003.tar.gz
+sha512sums="2d285f928db2ed32aefa741629ce9f9bee82e69c247eaa2c9145fdb4e9bae4441bf822e108cbffc3955369539474c3299f0a8f69026a5f9686aa8458a1d87f27 Unicode-LineBreak-2019.001.tar.gz
cc5a4fa7d53c127f749d0c45582f55f391ffdcfa2f2c91c41cb0a4f71e566f1657d4653a6a251c6ae4f769420701df6e0cf184e55413c602cbc5191f9dc99201 GraphemeBreakTest.txt
d2ffb02fb4d402e6a90937743721692c008b78045e295bd77bcdfcabc99fb1fdbfb0b4679b410bce4487eba115a7ef2e6d6bb03b0a47a7220fa4308eafbac74e LineBreakTest.txt"
diff --git a/system/perl-uri/APKBUILD b/system/perl-uri/APKBUILD
index 5909ad364..93aea427d 100644
--- a/system/perl-uri/APKBUILD
+++ b/system/perl-uri/APKBUILD
@@ -1,5 +1,5 @@
# Contributor: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
-# Maintainer: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
+# Maintainer: Adélie Perl Team <adelie-perl@lists.adelielinux.org>
pkgname=perl-uri
pkgver=1.74
pkgrel=0
diff --git a/system/perl/APKBUILD b/system/perl/APKBUILD
index 5f4410851..be47ade30 100644
--- a/system/perl/APKBUILD
+++ b/system/perl/APKBUILD
@@ -1,6 +1,7 @@
# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
# Contributor: Valery Kartel <valery.kartel@gmail.com>
-# Maintainer: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
+# Contributor: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
+# Maintainer: Adélie Perl Team <adelie-perl@lists.adelielinux.org>
# Proxy-For: solar
pkgname=perl
pkgver=5.26.3
diff --git a/system/util-linux/APKBUILD b/system/util-linux/APKBUILD
index 350ffe057..138d6f402 100644
--- a/system/util-linux/APKBUILD
+++ b/system/util-linux/APKBUILD
@@ -9,7 +9,7 @@ case $pkgver in
*.*) _v=$pkgver;;
esac
-pkgrel=0
+pkgrel=1
pkgdesc="Official Linux system management utilities"
url="http://git.kernel.org/cgit/utils/util-linux/util-linux.git"
arch="all"
@@ -43,8 +43,8 @@ prepare() {
build() {
cd "$builddir"
- # login utils are provided by shadow (with PAM) or busybox (no PAM) --nenolod
- ./configure \
+ # login utils are provided by shadow
+ LIBS="-lutmps -lskarnet" ./configure \
--build=$CBUILD \
--host=$CHOST \
--with-sysroot=$CBUILDROOT \
@@ -54,7 +54,6 @@ build() {
--disable-tls \
--disable-kill \
--disable-login \
- --disable-last \
--disable-sulogin \
--disable-su \
--without-python
diff --git a/system/utmps/APKBUILD b/system/utmps/APKBUILD
index 2306b8be3..91bb18b19 100644
--- a/system/utmps/APKBUILD
+++ b/system/utmps/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Laurent Bercot <ska-adelie@skarnet.org>
# Maintainer: Laurent Bercot <ska-adelie@skarnet.org>
pkgname=utmps
-pkgver=0.0.1.3
+pkgver=0.0.2.0
pkgrel=2
pkgdesc="A secure utmp/wtmp implementation"
url="https://skarnet.org/software/$pkgname/"
@@ -46,6 +46,6 @@ doc() {
cp -a "$builddir/doc" "$subpkgdir/usr/share/doc/$pkgname"
}
-sha512sums="ec6135e56858f4bb81ca8c5015e605bc1ecc809ef10565207335a86ccee250683fde7c1df999649b6055ef2df900a70cd3d2f9f1066e066c6871a0cfe2785824 utmps-0.0.1.3.tar.gz
+sha512sums="5fffb86f68475f3eadf8da53e3ae40284040cceb644f453218a5fd9e1be081920b5c787283e2578a60922e2feb75c94a7430034a658f7399645fc3bcc9afa28f utmps-0.0.2.0.tar.gz
525d43e3eced30c564e5390fc715b6caa1ae2b6515a9e3bf01263ff3fb9379bd6908ed302d0d50b6568ac36ed44d272dcc44a683f9ae34d586d8ad17023ed6b1 utmpd.run
93e4fae527ada9381e0b0a7ad5de9079e8d88959abd74fa5c0710c30c6153832abb010b57ddf83055ca34c032e7e5c9c1eedceb2f122a11ab20837ab66dcf5e2 wtmpd.run"
diff --git a/system/vim/APKBUILD b/system/vim/APKBUILD
index 2f64f96d8..c4cdf7e45 100644
--- a/system/vim/APKBUILD
+++ b/system/vim/APKBUILD
@@ -4,7 +4,7 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
pkgname=vim
-pkgver=8.1.0606
+pkgver=8.1.0687
pkgrel=0
pkgdesc="advanced text editor"
url="http://www.vim.org"
@@ -80,5 +80,5 @@ vimdiff() {
mv "$pkgdir"/usr/bin/vimdiff "$subpkgdir"/usr/bin
}
-sha512sums="df02717611d7b2f54f3b60ff9f73259a6ff3228b841d7d2d429fa0eedd98ce0a140a6a3839b50bd67ce5724d86f816042d6cbb0930fd040d30216f98f2d7e6ec vim-8.1.0606.tar.gz
+sha512sums="cf7cc21fa27f365a9a65333b4c18bf08c5aa3e6c6896ecaec54b57ff3d87d99463cf4e39b138b62ae7f7a7337b126fa3165e30c5045b30648ad2c21dc1df618a vim-8.1.0687.tar.gz
3a6c9bc187a6f45fd78e91dcc44d4d661c1ae1f2655e3a66bb36245ad1dc41e8d0e6061ec3aee6d323f96058b4a5501a87e3327e539cfd026f68cf81d455d721 vimrc"