summaryrefslogtreecommitdiff
path: root/system
diff options
context:
space:
mode:
Diffstat (limited to 'system')
-rw-r--r--system/build-tools/APKBUILD4
-rw-r--r--system/fortify-headers/APKBUILD18
-rw-r--r--system/fortify-headers/extension-cpp-fix.patch175
-rw-r--r--system/musl/APKBUILD4
-rw-r--r--system/musl/ppc64-regs.patch45
-rw-r--r--system/s6/APKBUILD6
-rw-r--r--system/s6/s6-svscanboot9
7 files changed, 60 insertions, 201 deletions
diff --git a/system/build-tools/APKBUILD b/system/build-tools/APKBUILD
index 39495ec5b..e5ff48c72 100644
--- a/system/build-tools/APKBUILD
+++ b/system/build-tools/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=build-tools
pkgver=1.0
-pkgrel=7
+pkgrel=8
pkgdesc="Meta-package for user development utilities"
url="https://adelielinux.org/"
arch="noarch"
@@ -11,7 +11,7 @@ depends="bash gettext-tiny gettext-tiny-dev
binutils gcc g++
make
diffutils patch
- fortify-headers linux-headers
+ linux-headers
mawk sed
bzip2 gzip unzip xz
abuild"
diff --git a/system/fortify-headers/APKBUILD b/system/fortify-headers/APKBUILD
deleted file mode 100644
index 33ee4e317..000000000
--- a/system/fortify-headers/APKBUILD
+++ /dev/null
@@ -1,18 +0,0 @@
-# Contributor: Timo Teräs <timo.teras@iki.fi>
-# Maintainer: Adelie Platform Group <adelie-devel@lists.adelielinux.org>
-pkgname=fortify-headers
-pkgver=1.0
-pkgrel=0
-pkgdesc="libc-agnostic implementation of FORTIFY_SOURCE"
-url="https://git.2f30.org/fortify-headers/"
-arch="noarch"
-options="!check" # No test suite.
-license="0BSD"
-source="https://dl.2f30.org/releases/$pkgname-$pkgver.tar.gz"
-
-package() {
- cd "$builddir"
- make DESTDIR="$pkgdir" PREFIX=/usr install
-}
-
-sha512sums="085a725da9a6da0eea732ee77e3a3dc7d3c96bc3344172523db5f1e35391492910a050c15c560912115b2db916c2d6fa37e409e997c53399ee4fee912c5513e8 fortify-headers-1.0.tar.gz"
diff --git a/system/fortify-headers/extension-cpp-fix.patch b/system/fortify-headers/extension-cpp-fix.patch
deleted file mode 100644
index fc7bbb5f8..000000000
--- a/system/fortify-headers/extension-cpp-fix.patch
+++ /dev/null
@@ -1,175 +0,0 @@
-From a29bd89353a05454e2545d52124f9a1a61b4e3e3 Mon Sep 17 00:00:00 2001
-From: "A. Wilcox" <AWilcox@Wilcox-Tech.com>
-Date: Sat, 23 Jun 2018 17:57:48 -0500
-Subject: [PATCH] Don't use __extension__ in C++ code
-
-A few important notes:
-
-* __extension__ is a GNU C "alternate" keyword, not a C++ keyword.[1]
-
-* __extension__ is designed to work on "expressions"; it does work on
- #include_next in C mode, but it has no effect in C++ mode; the
- warning will still appear, if enabled, even with __extension__
- preceding #include_next. This is because #include_next is not
- considered an expression in C++, so the compiler attaches
- __extension__ to the first expression of the header.
-
-All of this leads us to a build failure while building at least all
-Mozilla software. Moz has an alternate -isystem dir searched before
-/usr/include that overrides some headers, including <features.h>. The
-first statement in each of these headers is a #pragma, and since
-__extension__ is looking for an expression, and #pragma is a "null"
-expression, we end up with the following error:
-
-dist/system_wrappers/features.h:1:9: error: '#pragma' is not allowed here
-
-Since __extension__ has no effect on #include_next in C++ mode anyway,
-and since it can cause breakage, this commit omits __extension__ in C++
-mode.
-
-[1]: https://gcc.gnu.org/onlinedocs/gcc-6.4.0/gcc/Alternate-Keywords.html
----
- include/poll.h | 2 ++
- include/stdio.h | 2 ++
- include/stdlib.h | 4 ++++
- include/string.h | 2 ++
- include/sys/select.h | 2 ++
- include/sys/socket.h | 2 ++
- include/unistd.h | 2 ++
- include/wchar.h | 8 ++++++++
- 8 files changed, 24 insertions(+)
-
-diff --git a/include/poll.h b/include/poll.h
-index 7b42866..24691f1 100644
---- a/include/poll.h
-+++ b/include/poll.h
-@@ -16,7 +16,9 @@
- #ifndef _FORTIFY_POLL_H
- #define _FORTIFY_POLL_H
-
-+#ifndef __cplusplus
- __extension__
-+#endif
- #include_next <poll.h>
-
- #if defined(_FORTIFY_SOURCE) && _FORTIFY_SOURCE > 0 && defined(__OPTIMIZE__) && __OPTIMIZE__ > 0
-diff --git a/include/stdio.h b/include/stdio.h
-index b67f9ce..a965184 100644
---- a/include/stdio.h
-+++ b/include/stdio.h
-@@ -16,7 +16,9 @@
- #ifndef _FORTIFY_STDIO_H
- #define _FORTIFY_STDIO_H
-
-+#ifndef __cplusplus
- __extension__
-+#endif
- #include_next <stdio.h>
-
- #if defined(_FORTIFY_SOURCE) && _FORTIFY_SOURCE > 0 && defined(__OPTIMIZE__) && __OPTIMIZE__ > 0
-diff --git a/include/stdlib.h b/include/stdlib.h
-index 7ff5746..ef70995 100644
---- a/include/stdlib.h
-+++ b/include/stdlib.h
-@@ -16,12 +16,16 @@
- #ifndef _FORTIFY_STDLIB_H
- #define _FORTIFY_STDLIB_H
-
-+#ifndef __cplusplus
- __extension__
-+#endif
- #include_next <stdlib.h>
-
- #if defined(_FORTIFY_SOURCE) && _FORTIFY_SOURCE > 0 && defined(__OPTIMIZE__) && __OPTIMIZE__ > 0
- #if defined(_XOPEN_SOURCE) || defined(_GNU_SOURCE) || defined(_BSD_SOURCE)
-+#ifndef __cplusplus
- __extension__
-+#endif
- #include_next <limits.h>
- #endif
-
-diff --git a/include/string.h b/include/string.h
-index ff237b0..43c7485 100644
---- a/include/string.h
-+++ b/include/string.h
-@@ -16,7 +16,9 @@
- #ifndef _FORTIFY_STRING_H
- #define _FORTIFY_STRING_H
-
-+#ifndef __cplusplus
- __extension__
-+#endif
- #include_next <string.h>
-
- #if defined(_FORTIFY_SOURCE) && _FORTIFY_SOURCE > 0 && defined(__OPTIMIZE__) && __OPTIMIZE__ > 0
-diff --git a/include/sys/select.h b/include/sys/select.h
-index e4e398f..bcee8be 100644
---- a/include/sys/select.h
-+++ b/include/sys/select.h
-@@ -16,7 +16,9 @@
- #ifndef _FORTIFY_SYS_SELECT_H
- #define _FORTIFY_SYS_SELECT_H
-
-+#ifndef __cplusplus
- __extension__
-+#endif
- #include_next <sys/select.h>
-
- #if defined(_FORTIFY_SOURCE) && _FORTIFY_SOURCE > 0 && defined(__OPTIMIZE__) && __OPTIMIZE__ > 0
-diff --git a/include/sys/socket.h b/include/sys/socket.h
-index 7d3f023..ad6ab2d 100644
---- a/include/sys/socket.h
-+++ b/include/sys/socket.h
-@@ -16,7 +16,9 @@
- #ifndef _FORTIFY_SYS_SOCKET_H
- #define _FORTIFY_SYS_SOCKET_H
-
-+#ifndef __cplusplus
- __extension__
-+#endif
- #include_next <sys/socket.h>
-
- #if defined(_FORTIFY_SOURCE) && _FORTIFY_SOURCE > 0 && defined(__OPTIMIZE__) && __OPTIMIZE__ > 0
-diff --git a/include/unistd.h b/include/unistd.h
-index d3ab246..71dda84 100644
---- a/include/unistd.h
-+++ b/include/unistd.h
-@@ -16,7 +16,9 @@
- #ifndef _FORTIFY_UNISTD_H
- #define _FORTIFY_UNISTD_H
-
-+#ifndef __cplusplus
- __extension__
-+#endif
- #include_next <unistd.h>
-
- #if defined(_FORTIFY_SOURCE) && _FORTIFY_SOURCE > 0 && defined(__OPTIMIZE__) && __OPTIMIZE__ > 0
-diff --git a/include/wchar.h b/include/wchar.h
-index 7394598..3cb6f92 100644
---- a/include/wchar.h
-+++ b/include/wchar.h
-@@ -16,13 +16,21 @@
- #ifndef _FORTIFY_WCHAR_H
- #define _FORTIFY_WCHAR_H
-
-+#ifndef __cplusplus
- __extension__
-+#endif
- #include_next <limits.h>
-+#ifndef __cplusplus
- __extension__
-+#endif
- #include_next <stdlib.h>
-+#ifndef __cplusplus
- __extension__
-+#endif
- #include_next <string.h>
-+#ifndef __cplusplus
- __extension__
-+#endif
- #include_next <wchar.h>
-
- #if defined(_FORTIFY_SOURCE) && _FORTIFY_SOURCE > 0 && defined(__OPTIMIZE__) && __OPTIMIZE__ > 0
---
-2.15.0
-
diff --git a/system/musl/APKBUILD b/system/musl/APKBUILD
index 1ab117c16..d35060fb4 100644
--- a/system/musl/APKBUILD
+++ b/system/musl/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=musl
pkgver=1.1.21
-pkgrel=1
+pkgrel=2
pkgdesc="System library (libc) implementation"
url="http://www.musl-libc.org/"
arch="all"
@@ -27,6 +27,7 @@ source="http://www.musl-libc.org/releases/musl-$pkgver.tar.gz
handle-aux-at_base.patch
fgetspent_r.patch
gettext-preserve-errno.patch
+ ppc64-regs.patch
ldconfig
getent.c
@@ -125,6 +126,7 @@ sha512sums="fa6c4cc012626c5e517e0e10926fc845e3aa5f863ffaceeb38ac5b9ce0af631a37f6
6a7ff16d95b5d1be77e0a0fbb245491817db192176496a57b22ab037637d97a185ea0b0d19da687da66c2a2f5578e4343d230f399d49fe377d8f008410974238 handle-aux-at_base.patch
ded41235148930f8cf781538f7d63ecb0c65ea4e8ce792565f3649ee2523592a76b2a166785f0b145fc79f5852fd1fb1729a7a09110b3b8f85cba3912e790807 fgetspent_r.patch
db180e437b8b7582e4d2baf06b592b88a9f6e5a8f18b7afa81d7a707240a774273778f8fec1c5cbea2a137e00cca49ff08fe762c871be20c70b50104b7e8e1e1 gettext-preserve-errno.patch
+8d90a4bbec151f696bee30ed7275d8eb88b5c5ae7027d1dac963a950b0717b1e5149d6718c441bc9ee103b57899a9835a93f8373448b5887b52a24937bfd0af9 ppc64-regs.patch
cce2f1eeb61e55674469c26871a573cce61d739c3defe9c8f56f2b774f6ba5435849ad542a6714120efddc98c297098e9c98a1a424ac593df2243d4aa479f9a9 ldconfig
378d70e65bcc65bb4e1415354cecfa54b0c1146dfb24474b69e418cdbf7ad730472cd09f6f103e1c99ba6c324c9560bccdf287f5889bbc3ef0bdf0e08da47413 getent.c
9d42d66fb1facce2b85dad919be5be819ee290bd26ca2db00982b2f8e055a0196290a008711cbe2b18ec9eee8d2270e3b3a4692c5a1b807013baa5c2b70a2bbf iconv.c"
diff --git a/system/musl/ppc64-regs.patch b/system/musl/ppc64-regs.patch
new file mode 100644
index 000000000..4deb979ba
--- /dev/null
+++ b/system/musl/ppc64-regs.patch
@@ -0,0 +1,45 @@
+From ea183d9b727ac7e3ccfdcb89242566857d7182c8 Mon Sep 17 00:00:00 2001
+From: "A. Wilcox" <AWilcox@Wilcox-Tech.com>
+Date: Tue, 12 Feb 2019 09:31:34 -0600
+Subject: [PATCH] powerpc64: use a type for mcontext_t regs field
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+GCC Go dereferences `regs` for `nip`. Without this change, compilation
+fails with the following message:
+
+../../../libgo/runtime/go-signal.c: In function ‘getSiginfo’:
+../../../libgo/runtime/go-signal.c:225:56: warning: dereferencing ‘void *’ pointer
+ ret.sigpc = ((ucontext_t*)(context))->uc_mcontext.regs->nip;
+ ^~
+../../../libgo/runtime/go-signal.c:225:56: error: request for member ‘nip’ in something not a structure or union
+---
+ arch/powerpc64/bits/signal.h | 4 +++-
+ 1 file changed, 3 insertions(+), 1 deletion(-)
+
+diff --git a/arch/powerpc64/bits/signal.h b/arch/powerpc64/bits/signal.h
+index 34693a68..6736c69a 100644
+--- a/arch/powerpc64/bits/signal.h
++++ b/arch/powerpc64/bits/signal.h
+@@ -8,6 +8,8 @@
+
+ #if defined(_GNU_SOURCE) || defined(_BSD_SOURCE)
+
++#include <bits/user.h>
++
+ typedef unsigned long greg_t, gregset_t[48];
+
+ typedef struct {
+@@ -29,7 +31,7 @@ typedef struct sigcontext {
+ int _pad0;
+ unsigned long handler;
+ unsigned long oldmask;
+- void *regs;
++ struct pt_regs *regs;
+ gregset_t gp_regs;
+ fpregset_t fp_regs;
+ vrregset_t *v_regs;
+--
+2.19.2
+
diff --git a/system/s6/APKBUILD b/system/s6/APKBUILD
index dd8c20f8b..5c7ec31a1 100644
--- a/system/s6/APKBUILD
+++ b/system/s6/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Laurent Bercot <ska-adelie@skarnet.org>
# Maintainer: Laurent Bercot <ska-adelie@skarnet.org>
pkgname=s6
-pkgver=2.7.2.1
+pkgver=2.7.2.2
pkgrel=0
pkgdesc="skarnet.org's small & secure supervision software suite"
url="https://skarnet.org/software/$pkgname/"
@@ -42,5 +42,5 @@ doc() {
cp -a "$builddir/doc" "$subpkgdir/usr/share/doc/$pkgname"
}
-sha512sums="dcf032b812ce955c2276af36aa93138debcfa9e429e79af7b8da4f1e98b21e7b658564024c713fef45ffee03704d78f7618ad4b890de0bd3defa51b4689d3790 s6-2.7.2.1.tar.gz
-bad19965aa8ea138cdf5688db9ae05fc7ce2111ac0945b5b0e78cda55ad290602f28ac8b52aae395ca5e857f32e9be4d6df882286b362ba7008a52b29472ff1e s6-svscanboot"
+sha512sums="ed7b9fbc73e9947e56ad641459c04ff210fb801c8cfdbb5f0a00bdecbe1f5969ae73a6b52b048cd6617c88308f3a7bfd0ed98a48e78b1b5ba90b96e95845d165 s6-2.7.2.2.tar.gz
+9c29bc9eee6d5ab502a5a86bb043ebd21e085022efc506a330ae5ab0eadf7038d0a3dc8e025d78d9610cf7ec0ca031887f755486c4cb4e571090ea3a9c1806ac s6-svscanboot"
diff --git a/system/s6/s6-svscanboot b/system/s6/s6-svscanboot
index 8fa8ec5d5..32eb5f290 100644
--- a/system/s6/s6-svscanboot
+++ b/system/s6/s6-svscanboot
@@ -12,14 +12,19 @@ umask 022
if { rm -rf /run/service /run/services }
if { mkdir -p -m 0755 /run/service/.s6-svscan /run/service/s6-svscan-log }
-if { ln -sf /bin/false /run/service/.s6-svscan/crash }
+if
+{
+ redirfd -w 1 /run/service/.s6-svscan/crash
+ heredoc 0 "#!/bin/execlineb -P\nfalse\n"
+ cat
+}
if
{
redirfd -w 1 /run/service/.s6-svscan/finish
heredoc 0 "#!/bin/execlineb -P\ns6-svc -X -- \"/run/service/s6-svscan-log\"\n"
cat
}
-if { chmod 0755 /run/service/.s6-svscan/finish }
+if { cd /run/service/.s6-svscan chmod 0755 crash finish }
# Directory for the catch-all logger to store its logs