summaryrefslogtreecommitdiff
path: root/system
diff options
context:
space:
mode:
Diffstat (limited to 'system')
-rw-r--r--system/cmake/APKBUILD4
-rw-r--r--system/libucontext/APKBUILD2
-rw-r--r--system/lz4/APKBUILD6
-rw-r--r--system/parted/APKBUILD4
-rw-r--r--system/parted/posix-shell.patch69
-rw-r--r--system/paxmark/APKBUILD23
-rw-r--r--system/paxmark/paxmark33
-rw-r--r--system/pcre2/APKBUILD2
-rw-r--r--system/sudo/APKBUILD6
9 files changed, 83 insertions, 66 deletions
diff --git a/system/cmake/APKBUILD b/system/cmake/APKBUILD
index 38bdbf3ad..e667dcd0e 100644
--- a/system/cmake/APKBUILD
+++ b/system/cmake/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Valery Kartel <valery.kartel@gmail.com>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=cmake
-pkgver=3.15.2
+pkgver=3.15.4
pkgrel=0
pkgdesc="Cross-platform build system"
url="https://cmake.org"
@@ -52,4 +52,4 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="154494fe4c8673c3b17a6f1823c55f06fbb35d7ea048b63a5c3e3157108f222693cf1606c879a3cf425edea686dfe19e27974b338e5d281ec118b1a51c632ccc cmake-3.15.2.tar.gz"
+sha512sums="4058b89d35d243146f4f521356d483a850cbade316b60cf896c90da5d6b6504bc35224c0702fa525d90fe97a5311c7a895466e5eb2edb4cd4306a3cc45182650 cmake-3.15.4.tar.gz"
diff --git a/system/libucontext/APKBUILD b/system/libucontext/APKBUILD
index 81990e112..534e6b137 100644
--- a/system/libucontext/APKBUILD
+++ b/system/libucontext/APKBUILD
@@ -11,7 +11,7 @@ subpackages="$pkgname-dev"
source="https://distfiles.adelielinux.org/source/libucontext/libucontext-$pkgver.tar.xz"
case "$CTARGET_ARCH" in
-armhf) LIBUCONTEXT_ARCH="arm" ;;
+arm*) LIBUCONTEXT_ARCH="arm" ;;
ppc64le) LIBUCONTEXT_ARCH="ppc64" ;;
pmmx) LIBUCONTEXT_ARCH="x86" ;;
*) LIBUCONTEXT_ARCH="$CTARGET_ARCH" ;;
diff --git a/system/lz4/APKBUILD b/system/lz4/APKBUILD
index 281c3248c..b17306752 100644
--- a/system/lz4/APKBUILD
+++ b/system/lz4/APKBUILD
@@ -1,13 +1,13 @@
# Contributor: Stuart Cardall <developer@it-offshore.co.uk>
# Maintainer: Dan Theisen <djt@hxx.in>
pkgname=lz4
-pkgver=1.9.1
+pkgver=1.9.2
pkgrel=0
pkgdesc="LZ4: Extremely Fast Compression algorithm"
url="https://github.com/lz4/lz4"
arch="all"
license="BSD-2-Clause GPL-2.0-only"
-checkdepends="diffutils"
+checkdepends="diffutils python3"
subpackages="$pkgname-dev $pkgname-doc $pkgname-libs"
source="$pkgname-$pkgver.tar.gz::https://github.com/$pkgname/$pkgname/archive/v$pkgver.tar.gz"
@@ -27,4 +27,4 @@ package() {
make PREFIX="/usr" DESTDIR="$pkgdir" install
}
-sha512sums="536cdeb6dd73b4769cf9501ad312b004ab01699758534b47ca2eddbc815fd374a3caba40cde36f73a7a70e134065836b733e2b0c023c31740b877ef9317ccf3e lz4-1.9.1.tar.gz"
+sha512sums="ae714c61ec8e33ed91359b63f2896cfa102d66b730dce112b74696ec5850e59d88bd5527173e01e354a70fbe8f036557a47c767ee0766bc5f9c257978116c3c1 lz4-1.9.2.tar.gz"
diff --git a/system/parted/APKBUILD b/system/parted/APKBUILD
index d75fa2fe5..da56a73f9 100644
--- a/system/parted/APKBUILD
+++ b/system/parted/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer:
pkgname=parted
pkgver=3.2
-pkgrel=9
+pkgrel=1
pkgdesc="Utility to create, destroy, resize, check and copy partitions"
url="https://www.gnu.org/software/parted/parted.html"
arch="all"
@@ -15,6 +15,7 @@ source="https://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.xz
bsd-endian.patch
disable-two-tests.patch
fix-includes.patch
+ posix-shell.patch
sysmacros.patch
tests-call-name-correctly.patch
tests-python3.patch
@@ -52,6 +53,7 @@ sha512sums="4e37dbdd6f5032c9ebfec43704f6882379597d038167b9c4d04053efa083c68a7051
d3c16548cac315dad100c992c0b8446d1f7978cb45e867c69e746b25781c06802d3b4aab7d9346e44e68f61bb07e41ff65ef75d0dc6613f6fa8472b2e67a76a7 bsd-endian.patch
b49eb0211c405a4ef69e1bb0079621c22fec4adf0309f0a58b5d881540913de01d05ccd3eb521f35c3cf6f4eb8aa0f4c5270ce3dea47270a5c3fe8fae635c6f0 disable-two-tests.patch
55ee63c218d1867c0f2c596e7c3eec5c42af160181456cc551fe3d432eabed0ac2dd3a3955ff0c375f76aeec8071e7f55a32834b87a0d39b8ef30361f671bfdd fix-includes.patch
+6710a92cfb0a455de5e0c58f50c3c081c564307463c448fdc62521b868cb08fc10b2c558b284ec2e4ebbea7e940bda4b9e8e7aa7db58aec1b856451df9c54650 posix-shell.patch
5d2e8f22b6cd5bdd3289996848279a945ca09acd2862e82283bb769c2e4d61a24a31e1793d81385e8f3f1f4d48417e2308c5ea39dac47e832666363dde044ba7 sysmacros.patch
8bd86d2b0401566e7757c43d849b7f913cc4ec1bf50d5641dc72d7e278ca38db2ac746cd8dcc756b245021ea1f9738875b6a831f05185b9217d3f1c287944748 tests-call-name-correctly.patch
7486f98d535380a9e6598b9ac6153564319d5effa25456dc393cf3540ea47ac5b462be79cbd7d8efbd1fc2d2ef240a00873a2e2b138d4b4b0bb1494893de1eac tests-python3.patch"
diff --git a/system/parted/posix-shell.patch b/system/parted/posix-shell.patch
new file mode 100644
index 000000000..3418e31c6
--- /dev/null
+++ b/system/parted/posix-shell.patch
@@ -0,0 +1,69 @@
+--- parted-3.2/tests/t0205-gpt-list-clobbers-pmbr.sh.old 2014-06-15 18:17:43.000000000 +0000
++++ parted-3.2/tests/t0205-gpt-list-clobbers-pmbr.sh 2019-10-04 23:36:26.560000000 +0000
+@@ -37,7 +37,7 @@
+ # Write non-NUL bytes all over the MBR, so we're likely to see any change.
+ # However, be careful to leave the type of the first partition, 0xEE,
+ # as well as the final two magic bytes.
+-printf '%0450d\xee%059d\x55\xaa' 0 0 | dd of=$dev count=1 conv=notrunc || fail=1
++printf '%0450d\356%059d\125\252' 0 0 | dd of=$dev count=1 conv=notrunc || fail=1
+
+ dd if=$dev of=before count=1 || fail=1
+
+--- parted-3.2/tests/t0206-gpt-print-with-corrupt-primary-clobbers-pmbr.sh.old 2014-06-15 18:17:43.000000000 +0000
++++ parted-3.2/tests/t0206-gpt-print-with-corrupt-primary-clobbers-pmbr.sh 2019-10-04 23:37:08.760000000 +0000
+@@ -33,7 +33,7 @@
+ # Write non-NUL bytes all over the MBR, so we're likely to see any change.
+ # However, be careful to leave the type of the first partition, 0xEE,
+ # as well as the final two magic bytes.
+-printf '%0450d\xee%059d\x55\xaa' 0 0 | dd of=$dev count=1 conv=notrunc || fail=1
++printf '%0450d\356%059d\125\252' 0 0 | dd of=$dev count=1 conv=notrunc || fail=1
+
+ dd if=$dev of=before count=1 || fail=1
+
+--- parted-3.2/tests/t-local.sh.old 2014-06-15 18:17:43.000000000 +0000
++++ parted-3.2/tests/t-local.sh 2019-10-04 23:48:32.670000000 +0000
+@@ -135,7 +135,7 @@
+ peek_()
+ {
+ case $# in 2) ;; *) echo "usage: peek_ FILE 0_BASED_OFFSET" >&2; exit 1;; esac
+- case $2 in *[^0-9]*) echo "peek_: invalid offset: $2" >&2; exit 1 ;; esac
++ case $2 in *[!0-9]*) echo "peek_: invalid offset: $2" >&2; exit 1 ;; esac
+ dd if="$1" bs=1 skip="$2" count=1
+ }
+
+@@ -143,7 +143,7 @@
+ {
+ case $# in 3) ;; *) echo "usage: poke_ FILE 0_BASED_OFFSET BYTE" >&2; exit 1;;
+ esac
+- case $2 in *[^0-9]*) echo "poke_: invalid offset: $2" >&2; exit 1 ;; esac
++ case $2 in *[!0-9]*) echo "poke_: invalid offset: $2" >&2; exit 1 ;; esac
+ case $3 in ?) ;; *) echo "poke_: invalid byte: '$3'" >&2; exit 1 ;; esac
+ printf %s "$3" | dd of="$1" bs=1 seek="$2" count=1 conv=notrunc
+ }
+@@ -152,7 +152,7 @@
+ gpt1_pte_name_offset_()
+ {
+ local ss=$1
+- case $ss in *[^0-9]*) echo "$0: invalid sector size: $ss">&2; return 1;; esac
++ case $ss in *[!0-9]*) echo "$0: invalid sector size: $ss">&2; return 1;; esac
+ expr $ss \* 2 + 56
+ return 0
+ }
+@@ -164,7 +164,7 @@
+ case $# in 2) ;; *) echo "$0: expected 2 args, got $#" >&2; return 1;; esac
+ local dev=$1
+ local ss=$2
+- case $ss in *[^0-9]*) echo "$0: invalid sector size: $ss">&2; return 1;; esac
++ case $ss in *[!0-9]*) echo "$0: invalid sector size: $ss">&2; return 1;; esac
+
+ # get the first byte of the name
+ local orig_pte_name_byte
+@@ -185,7 +185,7 @@
+ case $# in 3) ;; *) echo "$0: expected 2 args, got $#" >&2; return 1;; esac
+ local dev=$1
+ local ss=$2
+- case $ss in *[^0-9]*) echo "$0: invalid sector size: $ss">&2; return 1;; esac
++ case $ss in *[!0-9]*) echo "$0: invalid sector size: $ss">&2; return 1;; esac
+ local orig_byte=$3
+ poke_ $dev $(gpt1_pte_name_offset_ $ss) "$orig_byte" || return 1
+ }
diff --git a/system/paxmark/APKBUILD b/system/paxmark/APKBUILD
deleted file mode 100644
index 3c9c69400..000000000
--- a/system/paxmark/APKBUILD
+++ /dev/null
@@ -1,23 +0,0 @@
-# Contributor: Timo Teräs <timo.teras@iki.fi>
-# Maintainer: A. Wilcox <awilfox@adelielinux.org>
-pkgname=paxmark
-pkgver=0.11
-pkgrel=1
-pkgdesc="Manage PaX marking of executables"
-url="https://alpinelinux.org"
-arch="noarch"
-options="!check"
-license="GPL-2.0-only"
-depends="attr bash"
-makedepends=""
-install=""
-subpackages=""
-source="paxmark"
-
-package() {
- mkdir -p "$pkgdir"/usr/sbin
- install -m755 "$srcdir"/paxmark "$pkgdir"/usr/sbin
- ln -s paxmark "$pkgdir"/usr/sbin/paxmark.sh
-}
-
-sha512sums="ed904790bfa6c86e216e2c8c1ed8fb1f997b7d1a55f997459655e402d8eec6447095709e38472cf909ea4d03e623e3e0eeddc0da57378901fe9d18d8c14b68d8 paxmark"
diff --git a/system/paxmark/paxmark b/system/paxmark/paxmark
deleted file mode 100644
index 87a84f4f7..000000000
--- a/system/paxmark/paxmark
+++ /dev/null
@@ -1,33 +0,0 @@
-#!/bin/bash
-
-ret=0
-flags="${1//[!zPpEeMmRrSs]}"
-[ -n "${flags}" ] || exit 0
-shift
-
-# Create XATTR_PAX marking using attr
-xval=""
-[ "${flags//[!P]}" ] && xval="${xval}P"
-[ "${flags//[!p]}" -a -z "${flags//[!P]}" ] && xval="${xval}p"
-[ "${flags//[!E]}" ] && xval="${xval}E"
-[ "${flags//[!e]}" -a -z "${flags//[!E]}" ] && xval="${xval}e"
-[ -z "${flags//[!zEe]}" ] && xval="${xval}e"
-[ "${flags//[!M]}" ] && xval="${xval}M"
-[ "${flags//[!m]}" -a -z "${flags//[!M]}" ] && xval="${xval}m"
-[ "${flags//[!R]}" ] && xval="${xval}R"
-[ "${flags//[!r]}" -a -z "${flags//[!R]}" ] && xval="${xval}r"
-[ "${flags//[!S]}" ] && xval="${xval}S"
-[ "${flags//[!s]}" -a -z "${flags//[!S]}" ] && xval="${xval}s"
-
-for f in "$@"; do
- if [ -n "FAKEROOTKEY" ]; then
- # fakeroot does not set xattr's on disk.
- # explicitly do that, because the marked binary might
- # be executed next during install.
- LD_PRELOAD="" FAKEROOTKEY="" attr -q -s pax.flags -V "${xval}" "${f}" >/dev/null || ret=1
- fi
- attr -q -s pax.flags -V "${xval}" "${f}" >/dev/null || ret=1
-done
-
-exit $ret
-
diff --git a/system/pcre2/APKBUILD b/system/pcre2/APKBUILD
index ef1fa1492..7bca0e450 100644
--- a/system/pcre2/APKBUILD
+++ b/system/pcre2/APKBUILD
@@ -9,7 +9,7 @@ arch="all"
license="BSD-3-Clause"
depends=""
depends_dev="libedit-dev zlib-dev"
-makedepends="$depends_dev paxmark"
+makedepends="$depends_dev"
subpackages="$pkgname-dev $pkgname-doc $pkgname-tools
libpcre2-16:_libpcre libpcre2-32:_libpcre"
source="https://ftp.pcre.org/pub/pcre/$pkgname-$pkgver.tar.gz"
diff --git a/system/sudo/APKBUILD b/system/sudo/APKBUILD
index 6b8685d86..2cb62343a 100644
--- a/system/sudo/APKBUILD
+++ b/system/sudo/APKBUILD
@@ -9,7 +9,7 @@ if [ "${pkgver%_*}" != "$pkgver" ]; then
else
_realver=$pkgver
fi
-pkgrel=0
+pkgrel=1
pkgdesc="Give certain users the ability to run some commands as root"
url="https://www.sudo.ws/sudo/"
arch="all"
@@ -42,7 +42,9 @@ build() {
--with-env-editor \
--with-pam \
--without-skey \
- --with-passprompt="[sudo] Password for %p: "
+ --with-passprompt="[sudo] Password for %p: " \
+ --with-insults=disabled \
+ --with-all-insults
make
}