summaryrefslogtreecommitdiff
path: root/system
diff options
context:
space:
mode:
Diffstat (limited to 'system')
-rw-r--r--system/iproute2/APKBUILD1
-rw-r--r--system/iproute2/iproute2.post-install6
-rw-r--r--system/lvm2/APKBUILD4
-rw-r--r--system/zsh/APKBUILD5
-rw-r--r--system/zsh/skel4
5 files changed, 12 insertions, 8 deletions
diff --git a/system/iproute2/APKBUILD b/system/iproute2/APKBUILD
index 4b4b6060c..b4e32f6a8 100644
--- a/system/iproute2/APKBUILD
+++ b/system/iproute2/APKBUILD
@@ -11,7 +11,6 @@ options="!check"
license="GPL-2.0-only"
depends=""
makedepends="bison flex bash libelf-dev libmnl-dev libcap-dev bsd-compat-headers"
-install="$pkgname.post-install"
subpackages="$pkgname-doc $pkgname-bash-completion:bashcomp:noarch"
source="https://kernel.org/pub/linux/utils/net/iproute2/iproute2-$pkgver.tar.xz
devlink-sysinfo.patch"
diff --git a/system/iproute2/iproute2.post-install b/system/iproute2/iproute2.post-install
deleted file mode 100644
index 36d567ea2..000000000
--- a/system/iproute2/iproute2.post-install
+++ /dev/null
@@ -1,6 +0,0 @@
-#!/bin/sh
-
-if [ "$(readlink /bin/ip)" = "/bin/busybox" ]; then
- rm -f /bin/ip
-fi
-exit 0
diff --git a/system/lvm2/APKBUILD b/system/lvm2/APKBUILD
index 842dee2fa..fc491a70a 100644
--- a/system/lvm2/APKBUILD
+++ b/system/lvm2/APKBUILD
@@ -51,6 +51,10 @@ build () {
--with-thin=internal \
--enable-dmeventd \
--enable-cmdlib \
+ --with-default-dm-run-dir=/run \
+ --with-default-locking-dir=/run/lock/lvm \
+ --with-default-pid-dir=/run \
+ --with-default-run-dir=/run/lvm \
--with-thin-check=/sbin/thin_check \
--with-thin-dump=/sbin/thin_dump \
--with-thin-repair=/sbin/thin_repair \
diff --git a/system/zsh/APKBUILD b/system/zsh/APKBUILD
index 5c80e950b..695a26a1d 100644
--- a/system/zsh/APKBUILD
+++ b/system/zsh/APKBUILD
@@ -4,7 +4,7 @@
# Maintainer: Dan Theisen <djt@hxx.in>
pkgname=zsh
pkgver=5.7.1
-pkgrel=0
+pkgrel=1
pkgdesc="A very advanced and programmable command interpreter (shell)"
url="https://www.zsh.org/"
arch="all"
@@ -14,6 +14,7 @@ makedepends_host="ncurses-dev pcre-dev utmps-dev"
install="zsh.post-install zsh.post-upgrade zsh.pre-deinstall"
# Note the custom fetch() function
source="https://www.zsh.org/pub/$pkgname-$pkgver.tar.xz
+ skel
zprofile
zshrc
"
@@ -118,6 +119,7 @@ package() {
make DESTDIR="$pkgdir" install
install -Dm644 "$srcdir"/zprofile "$pkgdir"/etc/zsh/zprofile
install -Dm644 "$srcdir"/zshrc "$pkgdir"/etc/zsh/zshrc
+ install -Dm755 "$srcdir"/skel "$pkgdir"/etc/skel/.zshrc
}
doc() {
@@ -176,5 +178,6 @@ _submv() {
}
sha512sums="a6aa88e1955a80229a4784a128866e325f79a8b5f73c922ab480048411036f1835cbb31daa30ab38bd16ab2a50040eda8f4f1f64704b21b6acc3051b1dbf18d0 zsh-5.7.1.tar.xz
+7d46b958a3402214a1982a4fbb71b9916b385e295593202e2cc4893f278b4faec6950c02b9924551687e3f6e53c727d5b6f2a8d39bc0e7abe33bedc0110f96ac skel
e90723eb790581419498f3ab86fb5d6cab4aaede8c87eb79ead7047d259b643cfb47f4d1beb06d03e038cfda3a20ef9dd4c1b417270ab55c688e166fe30ef4f6 zprofile
1675e016f97333cad89b587f4292d81b6bc10e27b75482e3e0c3808539c95bd49b907b6579fb98d817f77f2f2384c0df5afa3e2b6f43b6ae9b466925cd9ccffc zshrc"
diff --git a/system/zsh/skel b/system/zsh/skel
new file mode 100644
index 000000000..e3ddddf99
--- /dev/null
+++ b/system/zsh/skel
@@ -0,0 +1,4 @@
+# Lines configured by zsh-newuser-install
+HISTFILE=~/.histfile
+setopt appendhistory extendedglob
+# End of lines configured by zsh-newuser-install