summaryrefslogtreecommitdiff
path: root/system
diff options
context:
space:
mode:
Diffstat (limited to 'system')
-rw-r--r--system/binutils/APKBUILD4
-rw-r--r--system/binutils/arm-pie.patch24
-rw-r--r--system/cmake/APKBUILD4
-rw-r--r--system/iproute2/APKBUILD6
-rw-r--r--system/libcap-ng/APKBUILD7
-rw-r--r--system/libucontext/APKBUILD2
-rw-r--r--system/lz4/APKBUILD6
-rw-r--r--system/mawk/APKBUILD7
-rw-r--r--system/nspr/APKBUILD4
-rw-r--r--system/nss/APKBUILD4
-rw-r--r--system/parted/APKBUILD4
-rw-r--r--system/parted/posix-shell.patch69
-rw-r--r--system/paxmark/APKBUILD23
-rw-r--r--system/paxmark/paxmark33
-rw-r--r--system/pcre2/APKBUILD2
-rw-r--r--system/ruby/APKBUILD13
-rw-r--r--system/strace/APKBUILD4
-rw-r--r--system/sudo/APKBUILD6
-rw-r--r--system/texinfo/APKBUILD4
-rw-r--r--system/tzdata/APKBUILD8
-rw-r--r--system/xfsprogs/APKBUILD6
-rw-r--r--system/zstd/APKBUILD4
22 files changed, 144 insertions, 100 deletions
diff --git a/system/binutils/APKBUILD b/system/binutils/APKBUILD
index 8304e5c7d..682f2e93c 100644
--- a/system/binutils/APKBUILD
+++ b/system/binutils/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Adelie Platform Group <adelie-devel@lists.adelielinux.org>
pkgname=binutils
pkgver=2.32
-pkgrel=3
+pkgrel=4
pkgdesc="Tools necessary to build programs"
url="https://www.gnu.org/software/binutils/"
depends=""
@@ -15,6 +15,7 @@ subpackages="$pkgname-dev $pkgname-doc $pkgname-lang $pkgname-libs"
# non-PIC is unsupported by musl/ppc
[ "${CARCH}" != "ppc" ] || options='!check'
source="https://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.xz
+ arm-pie.patch
binutils-ld-fix-static-linking.patch
disable-gnu-mbind.patch
disable-ifunc-tests.patch
@@ -140,6 +141,7 @@ libs() {
}
sha512sums="d326408f12a03d9a61a9de56584c2af12f81c2e50d2d7e835d51565df8314df01575724afa1e43bd0db45cfc9916b41519b67dfce03232aa4978704492a6994a binutils-2.32.tar.xz
+2f862c473b357effe63221a47c4a34893eff50e4ab3c7b500b19754f3c7bf81ee695c35e5ce16f6c6fcd75696d270d04f282ae4c7d32b42a61b667ff1eccce8f arm-pie.patch
ecee33b0e435aa704af1c334e560f201638ff79e199aa11ed78a72f7c9b46f85fbb227af5748e735fd681d1965fcc42ac81b0c8824e540430ce0c706c81e8b49 binutils-ld-fix-static-linking.patch
d378fdf1964f8f2bd0b1e62827ac5884bdf943aa435ec89c29fc84bb045d406b733fffaff8fdd8bd1cba8ddea7701c4cf6ccf3ed76a8a3df9c72b447737575a6 disable-gnu-mbind.patch
474ab24097bbb5b24433620549e5234fe65c547824c1342f693c718ffbc81e2d968259cce2d650b55200dd1ec89da207ea2db10c551cd9941285c4600b4297b2 disable-ifunc-tests.patch
diff --git a/system/binutils/arm-pie.patch b/system/binutils/arm-pie.patch
new file mode 100644
index 000000000..f42477a04
--- /dev/null
+++ b/system/binutils/arm-pie.patch
@@ -0,0 +1,24 @@
+Bug: https://sourceware.org/bugzilla/show_bug.cgi?id=25056
+Author: Rich Felker <dalias@libc.org>
+Upstream-Status: reported
+
+--- binutils-2.32/bfd/elf32-arm.c.orig 2019-10-02 07:47:36.153918869 -0400
++++ binutils-2.32/bfd/elf32-arm.c 2019-10-02 08:37:09.108263016 -0400
+@@ -11624,7 +11624,7 @@
+ {
+ /* If we don't know the module number, create a relocation
+ for it. */
+- if (bfd_link_pic (info))
++ if (bfd_link_dll (info))
+ {
+ Elf_Internal_Rela outrel;
+
+@@ -11728,7 +11728,7 @@
+ now, and emit any relocations. If both an IE GOT and a
+ GD GOT are necessary, we emit the GD first. */
+
+- if ((bfd_link_pic (info) || indx != 0)
++ if ((bfd_link_dll (info) || indx != 0)
+ && (h == NULL
+ || (ELF_ST_VISIBILITY (h->other) == STV_DEFAULT
+ && !resolved_to_zero)
diff --git a/system/cmake/APKBUILD b/system/cmake/APKBUILD
index 38bdbf3ad..e667dcd0e 100644
--- a/system/cmake/APKBUILD
+++ b/system/cmake/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Valery Kartel <valery.kartel@gmail.com>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=cmake
-pkgver=3.15.2
+pkgver=3.15.4
pkgrel=0
pkgdesc="Cross-platform build system"
url="https://cmake.org"
@@ -52,4 +52,4 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="154494fe4c8673c3b17a6f1823c55f06fbb35d7ea048b63a5c3e3157108f222693cf1606c879a3cf425edea686dfe19e27974b338e5d281ec118b1a51c632ccc cmake-3.15.2.tar.gz"
+sha512sums="4058b89d35d243146f4f521356d483a850cbade316b60cf896c90da5d6b6504bc35224c0702fa525d90fe97a5311c7a895466e5eb2edb4cd4306a3cc45182650 cmake-3.15.4.tar.gz"
diff --git a/system/iproute2/APKBUILD b/system/iproute2/APKBUILD
index 8c7c1a64b..287dfb603 100644
--- a/system/iproute2/APKBUILD
+++ b/system/iproute2/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Dan Theisen <djt@hxx.in>
pkgname=iproute2
-pkgver=5.2.0
-pkgrel=1
+pkgver=5.3.0
+pkgrel=0
pkgdesc="IP configuration, routing, and traffic control utilities"
url="https://wiki.linuxfoundation.org/networking/iproute2"
arch="all"
@@ -55,4 +55,4 @@ bashcomp() {
rmdir -p "$pkgdir"/usr/share 2>/dev/null || true
}
-sha512sums="82bbeae29d98129d822c95ff7523186569e32c66132b8d781d501d61f396b04d122e3d13057dd4236455264008e5bfac7cb63c325908fc1c46d416cbde6ac7e1 iproute2-5.2.0.tar.xz"
+sha512sums="c20ce477cb3ec24194ea56d3d9037795e26975ffde188b63ba974a0aa671dd169f356e9446bf43dc56523e01c0bafa442b91d83da9b2302daee18e237f2f3157 iproute2-5.3.0.tar.xz"
diff --git a/system/libcap-ng/APKBUILD b/system/libcap-ng/APKBUILD
index 5bf8dc29d..a31545601 100644
--- a/system/libcap-ng/APKBUILD
+++ b/system/libcap-ng/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer:
pkgname=libcap-ng
-pkgver=0.7.9
+pkgver=0.7.10
pkgrel=0
pkgdesc="POSIX capabilities library"
url="https://people.redhat.com/sgrubb/libcap-ng/index.html"
@@ -15,7 +15,6 @@ source="https://people.redhat.com/sgrubb/libcap-ng/libcap-ng-$pkgver.tar.gz
"
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -27,12 +26,10 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
@@ -44,5 +41,5 @@ utils() {
mv "$pkgdir"/usr/bin/* "$subpkgdir"/usr/bin/
}
-sha512sums="095edabaf76a943aab0645b843b14e20b1733ba1d47a8e34d82f6586ca9a1512ba2677d232b13dd3900b913837401bb58bf74481970e967ba19041959dc43259 libcap-ng-0.7.9.tar.gz
+sha512sums="1b93c7f5c20ae5cc705fe5244af3e299454e988388cda95f006e248d97c0713e77da2a81c67ecf15755f3958df373fc6d1ca14197d6357ab1f2d8c3a0fd12def libcap-ng-0.7.10.tar.gz
8de98ce0fae63812cf7fd17e788343798b0cab63ba029f046ac9b89b2305da17432bafdd3dfa36046fc2cc0a453e0c889f6744c632f4617e0e5fc08e2823e324 fix-includes.patch"
diff --git a/system/libucontext/APKBUILD b/system/libucontext/APKBUILD
index 81990e112..534e6b137 100644
--- a/system/libucontext/APKBUILD
+++ b/system/libucontext/APKBUILD
@@ -11,7 +11,7 @@ subpackages="$pkgname-dev"
source="https://distfiles.adelielinux.org/source/libucontext/libucontext-$pkgver.tar.xz"
case "$CTARGET_ARCH" in
-armhf) LIBUCONTEXT_ARCH="arm" ;;
+arm*) LIBUCONTEXT_ARCH="arm" ;;
ppc64le) LIBUCONTEXT_ARCH="ppc64" ;;
pmmx) LIBUCONTEXT_ARCH="x86" ;;
*) LIBUCONTEXT_ARCH="$CTARGET_ARCH" ;;
diff --git a/system/lz4/APKBUILD b/system/lz4/APKBUILD
index 281c3248c..b17306752 100644
--- a/system/lz4/APKBUILD
+++ b/system/lz4/APKBUILD
@@ -1,13 +1,13 @@
# Contributor: Stuart Cardall <developer@it-offshore.co.uk>
# Maintainer: Dan Theisen <djt@hxx.in>
pkgname=lz4
-pkgver=1.9.1
+pkgver=1.9.2
pkgrel=0
pkgdesc="LZ4: Extremely Fast Compression algorithm"
url="https://github.com/lz4/lz4"
arch="all"
license="BSD-2-Clause GPL-2.0-only"
-checkdepends="diffutils"
+checkdepends="diffutils python3"
subpackages="$pkgname-dev $pkgname-doc $pkgname-libs"
source="$pkgname-$pkgver.tar.gz::https://github.com/$pkgname/$pkgname/archive/v$pkgver.tar.gz"
@@ -27,4 +27,4 @@ package() {
make PREFIX="/usr" DESTDIR="$pkgdir" install
}
-sha512sums="536cdeb6dd73b4769cf9501ad312b004ab01699758534b47ca2eddbc815fd374a3caba40cde36f73a7a70e134065836b733e2b0c023c31740b877ef9317ccf3e lz4-1.9.1.tar.gz"
+sha512sums="ae714c61ec8e33ed91359b63f2896cfa102d66b730dce112b74696ec5850e59d88bd5527173e01e354a70fbe8f036557a47c767ee0766bc5f9c257978116c3c1 lz4-1.9.2.tar.gz"
diff --git a/system/mawk/APKBUILD b/system/mawk/APKBUILD
index 8f2cd7faf..9c84905f8 100644
--- a/system/mawk/APKBUILD
+++ b/system/mawk/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: A. Wilcox <awilfox@adelielinux.org>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=mawk
-pkgver=1.3.4.20171017
+pkgver=1.3.4.20190203
pkgrel=0
pkgdesc="Pattern scanning and text processing language"
url="https://invisible-island.net/mawk/mawk.html"
@@ -13,7 +13,6 @@ source="https://invisible-mirror.net/archives/$pkgname/$pkgname-$_dlver.tgz"
builddir="$srcdir/$pkgname-$_dlver"
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -25,14 +24,12 @@ build() {
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
ln -s mawk "$pkgdir"/usr/bin/awk
}
check() {
- cd "$builddir"
make check
}
-sha512sums="4ed6ca0ecca12e7409d3d364b72dc6a2b411c61bf53fe8aa0b0cac65a3bdb941921c0b81d94f34c8ac9f4922c8c7566d347b5e6b5c74518ae3a88904f9e20f27 mawk-1.3.4-20171017.tgz"
+sha512sums="64d5b1838d34d30e32966f46cb7457c865caccfe9fe1049d2645ba301b1ddb4efc18588115dbcf96234a2a0b791211a7f82264a3c81899459dc3029e65837646 mawk-1.3.4-20190203.tgz"
diff --git a/system/nspr/APKBUILD b/system/nspr/APKBUILD
index 9700b0491..667e2d189 100644
--- a/system/nspr/APKBUILD
+++ b/system/nspr/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=nspr
-pkgver=4.21
+pkgver=4.22
pkgrel=0
pkgdesc="Netscape Portable Runtime"
url="https://developer.mozilla.org/en-US/docs/Mozilla/Projects/NSPR"
@@ -60,6 +60,6 @@ package() {
"$pkgdir"/usr/include/nspr/md
}
-sha512sums="4f152c6ca32d9dd4cf3d92b4b54f249ac1fa39047811f7c0c7a67bdc73173cf7de0dce36dc278ad781189ea2fdc71fa70e044597676a8b1f5e6d664907e5ab7c nspr-4.21.tar.gz
+sha512sums="d34271f0692905162f71b02cf6f62a8ebf779159335e4ed286ee8d51faaad633a61c9392bada86d976bca2b5aa47c8760085de30dbd13c9cfa423582c31db37b nspr-4.22.tar.gz
ee654f609a90b9a95c1901ad1d56cdef7cce8bca9efc092198607944f142f8fec924b13219ca6663facd0f0d59b671b8b3de58ab3449c4c863d42e2937f02184 fix-getproto.patch
1f694fc151f6578080449e3aa999c520486bbe117b8237150966ec43092db4156e81412ac889045e0c0c3bf65d459af5bdc1cf19c9fa3dab120405a60732f15a stacksize.patch"
diff --git a/system/nss/APKBUILD b/system/nss/APKBUILD
index 20aea14c3..7f3cc141d 100644
--- a/system/nss/APKBUILD
+++ b/system/nss/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Łukasz Jendrysik <scadu@yandex.com>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=nss
-pkgver=3.45
+pkgver=3.46.1
_ver=$(printf '%s' "$pkgver" | tr . _)
pkgrel=0
pkgdesc="Mozilla Network Security Services"
@@ -147,7 +147,7 @@ tools() {
mv "$pkgdir"/usr/bin "$subpkgdir"/usr/
}
-sha512sums="33360a1bb4e0a0a974070c354ee82c515d5cfa2a12c9c96817a9fdb3e4ca1ad62eb95886b9b0d60e2f69efda964376d0671c1e3c920b2ea614aeecb719c6ff29 nss-3.45.tar.gz
+sha512sums="f4c24f0e31d11413cbbf791a24687c02cd934b9baf4a3e9ce27406638a1d497654fbeec79c22ab4ad29374dd0063c05104c9514580b1b8156ed8d18404e1681b nss-3.46.1.tar.gz
75dbd648a461940647ff373389cc73bc8ec609139cd46c91bcce866af02be6bcbb0524eb3dfb721fbd5b0bc68c20081ed6f7debf6b24317f2a7ba823e8d3c531 nss.pc.in
0f2efa8563b11da68669d281b4459289a56f5a3a906eb60382126f3adcfe47420cdcedc6ab57727a3afeeffa2bbb4c750b43bef8b5f343a75c968411dfa30e09 nss-util.pc.in
09c69d4cc39ec9deebc88696a80d0f15eb2d8c94d9daa234a2adfec941b63805eb4ce7f2e1943857b938bddcaee1beac246a0ec627b71563d9f846e6119a4a15 nss-softokn.pc.in
diff --git a/system/parted/APKBUILD b/system/parted/APKBUILD
index d75fa2fe5..da56a73f9 100644
--- a/system/parted/APKBUILD
+++ b/system/parted/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer:
pkgname=parted
pkgver=3.2
-pkgrel=9
+pkgrel=1
pkgdesc="Utility to create, destroy, resize, check and copy partitions"
url="https://www.gnu.org/software/parted/parted.html"
arch="all"
@@ -15,6 +15,7 @@ source="https://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.xz
bsd-endian.patch
disable-two-tests.patch
fix-includes.patch
+ posix-shell.patch
sysmacros.patch
tests-call-name-correctly.patch
tests-python3.patch
@@ -52,6 +53,7 @@ sha512sums="4e37dbdd6f5032c9ebfec43704f6882379597d038167b9c4d04053efa083c68a7051
d3c16548cac315dad100c992c0b8446d1f7978cb45e867c69e746b25781c06802d3b4aab7d9346e44e68f61bb07e41ff65ef75d0dc6613f6fa8472b2e67a76a7 bsd-endian.patch
b49eb0211c405a4ef69e1bb0079621c22fec4adf0309f0a58b5d881540913de01d05ccd3eb521f35c3cf6f4eb8aa0f4c5270ce3dea47270a5c3fe8fae635c6f0 disable-two-tests.patch
55ee63c218d1867c0f2c596e7c3eec5c42af160181456cc551fe3d432eabed0ac2dd3a3955ff0c375f76aeec8071e7f55a32834b87a0d39b8ef30361f671bfdd fix-includes.patch
+6710a92cfb0a455de5e0c58f50c3c081c564307463c448fdc62521b868cb08fc10b2c558b284ec2e4ebbea7e940bda4b9e8e7aa7db58aec1b856451df9c54650 posix-shell.patch
5d2e8f22b6cd5bdd3289996848279a945ca09acd2862e82283bb769c2e4d61a24a31e1793d81385e8f3f1f4d48417e2308c5ea39dac47e832666363dde044ba7 sysmacros.patch
8bd86d2b0401566e7757c43d849b7f913cc4ec1bf50d5641dc72d7e278ca38db2ac746cd8dcc756b245021ea1f9738875b6a831f05185b9217d3f1c287944748 tests-call-name-correctly.patch
7486f98d535380a9e6598b9ac6153564319d5effa25456dc393cf3540ea47ac5b462be79cbd7d8efbd1fc2d2ef240a00873a2e2b138d4b4b0bb1494893de1eac tests-python3.patch"
diff --git a/system/parted/posix-shell.patch b/system/parted/posix-shell.patch
new file mode 100644
index 000000000..3418e31c6
--- /dev/null
+++ b/system/parted/posix-shell.patch
@@ -0,0 +1,69 @@
+--- parted-3.2/tests/t0205-gpt-list-clobbers-pmbr.sh.old 2014-06-15 18:17:43.000000000 +0000
++++ parted-3.2/tests/t0205-gpt-list-clobbers-pmbr.sh 2019-10-04 23:36:26.560000000 +0000
+@@ -37,7 +37,7 @@
+ # Write non-NUL bytes all over the MBR, so we're likely to see any change.
+ # However, be careful to leave the type of the first partition, 0xEE,
+ # as well as the final two magic bytes.
+-printf '%0450d\xee%059d\x55\xaa' 0 0 | dd of=$dev count=1 conv=notrunc || fail=1
++printf '%0450d\356%059d\125\252' 0 0 | dd of=$dev count=1 conv=notrunc || fail=1
+
+ dd if=$dev of=before count=1 || fail=1
+
+--- parted-3.2/tests/t0206-gpt-print-with-corrupt-primary-clobbers-pmbr.sh.old 2014-06-15 18:17:43.000000000 +0000
++++ parted-3.2/tests/t0206-gpt-print-with-corrupt-primary-clobbers-pmbr.sh 2019-10-04 23:37:08.760000000 +0000
+@@ -33,7 +33,7 @@
+ # Write non-NUL bytes all over the MBR, so we're likely to see any change.
+ # However, be careful to leave the type of the first partition, 0xEE,
+ # as well as the final two magic bytes.
+-printf '%0450d\xee%059d\x55\xaa' 0 0 | dd of=$dev count=1 conv=notrunc || fail=1
++printf '%0450d\356%059d\125\252' 0 0 | dd of=$dev count=1 conv=notrunc || fail=1
+
+ dd if=$dev of=before count=1 || fail=1
+
+--- parted-3.2/tests/t-local.sh.old 2014-06-15 18:17:43.000000000 +0000
++++ parted-3.2/tests/t-local.sh 2019-10-04 23:48:32.670000000 +0000
+@@ -135,7 +135,7 @@
+ peek_()
+ {
+ case $# in 2) ;; *) echo "usage: peek_ FILE 0_BASED_OFFSET" >&2; exit 1;; esac
+- case $2 in *[^0-9]*) echo "peek_: invalid offset: $2" >&2; exit 1 ;; esac
++ case $2 in *[!0-9]*) echo "peek_: invalid offset: $2" >&2; exit 1 ;; esac
+ dd if="$1" bs=1 skip="$2" count=1
+ }
+
+@@ -143,7 +143,7 @@
+ {
+ case $# in 3) ;; *) echo "usage: poke_ FILE 0_BASED_OFFSET BYTE" >&2; exit 1;;
+ esac
+- case $2 in *[^0-9]*) echo "poke_: invalid offset: $2" >&2; exit 1 ;; esac
++ case $2 in *[!0-9]*) echo "poke_: invalid offset: $2" >&2; exit 1 ;; esac
+ case $3 in ?) ;; *) echo "poke_: invalid byte: '$3'" >&2; exit 1 ;; esac
+ printf %s "$3" | dd of="$1" bs=1 seek="$2" count=1 conv=notrunc
+ }
+@@ -152,7 +152,7 @@
+ gpt1_pte_name_offset_()
+ {
+ local ss=$1
+- case $ss in *[^0-9]*) echo "$0: invalid sector size: $ss">&2; return 1;; esac
++ case $ss in *[!0-9]*) echo "$0: invalid sector size: $ss">&2; return 1;; esac
+ expr $ss \* 2 + 56
+ return 0
+ }
+@@ -164,7 +164,7 @@
+ case $# in 2) ;; *) echo "$0: expected 2 args, got $#" >&2; return 1;; esac
+ local dev=$1
+ local ss=$2
+- case $ss in *[^0-9]*) echo "$0: invalid sector size: $ss">&2; return 1;; esac
++ case $ss in *[!0-9]*) echo "$0: invalid sector size: $ss">&2; return 1;; esac
+
+ # get the first byte of the name
+ local orig_pte_name_byte
+@@ -185,7 +185,7 @@
+ case $# in 3) ;; *) echo "$0: expected 2 args, got $#" >&2; return 1;; esac
+ local dev=$1
+ local ss=$2
+- case $ss in *[^0-9]*) echo "$0: invalid sector size: $ss">&2; return 1;; esac
++ case $ss in *[!0-9]*) echo "$0: invalid sector size: $ss">&2; return 1;; esac
+ local orig_byte=$3
+ poke_ $dev $(gpt1_pte_name_offset_ $ss) "$orig_byte" || return 1
+ }
diff --git a/system/paxmark/APKBUILD b/system/paxmark/APKBUILD
deleted file mode 100644
index 3c9c69400..000000000
--- a/system/paxmark/APKBUILD
+++ /dev/null
@@ -1,23 +0,0 @@
-# Contributor: Timo Teräs <timo.teras@iki.fi>
-# Maintainer: A. Wilcox <awilfox@adelielinux.org>
-pkgname=paxmark
-pkgver=0.11
-pkgrel=1
-pkgdesc="Manage PaX marking of executables"
-url="https://alpinelinux.org"
-arch="noarch"
-options="!check"
-license="GPL-2.0-only"
-depends="attr bash"
-makedepends=""
-install=""
-subpackages=""
-source="paxmark"
-
-package() {
- mkdir -p "$pkgdir"/usr/sbin
- install -m755 "$srcdir"/paxmark "$pkgdir"/usr/sbin
- ln -s paxmark "$pkgdir"/usr/sbin/paxmark.sh
-}
-
-sha512sums="ed904790bfa6c86e216e2c8c1ed8fb1f997b7d1a55f997459655e402d8eec6447095709e38472cf909ea4d03e623e3e0eeddc0da57378901fe9d18d8c14b68d8 paxmark"
diff --git a/system/paxmark/paxmark b/system/paxmark/paxmark
deleted file mode 100644
index 87a84f4f7..000000000
--- a/system/paxmark/paxmark
+++ /dev/null
@@ -1,33 +0,0 @@
-#!/bin/bash
-
-ret=0
-flags="${1//[!zPpEeMmRrSs]}"
-[ -n "${flags}" ] || exit 0
-shift
-
-# Create XATTR_PAX marking using attr
-xval=""
-[ "${flags//[!P]}" ] && xval="${xval}P"
-[ "${flags//[!p]}" -a -z "${flags//[!P]}" ] && xval="${xval}p"
-[ "${flags//[!E]}" ] && xval="${xval}E"
-[ "${flags//[!e]}" -a -z "${flags//[!E]}" ] && xval="${xval}e"
-[ -z "${flags//[!zEe]}" ] && xval="${xval}e"
-[ "${flags//[!M]}" ] && xval="${xval}M"
-[ "${flags//[!m]}" -a -z "${flags//[!M]}" ] && xval="${xval}m"
-[ "${flags//[!R]}" ] && xval="${xval}R"
-[ "${flags//[!r]}" -a -z "${flags//[!R]}" ] && xval="${xval}r"
-[ "${flags//[!S]}" ] && xval="${xval}S"
-[ "${flags//[!s]}" -a -z "${flags//[!S]}" ] && xval="${xval}s"
-
-for f in "$@"; do
- if [ -n "FAKEROOTKEY" ]; then
- # fakeroot does not set xattr's on disk.
- # explicitly do that, because the marked binary might
- # be executed next during install.
- LD_PRELOAD="" FAKEROOTKEY="" attr -q -s pax.flags -V "${xval}" "${f}" >/dev/null || ret=1
- fi
- attr -q -s pax.flags -V "${xval}" "${f}" >/dev/null || ret=1
-done
-
-exit $ret
-
diff --git a/system/pcre2/APKBUILD b/system/pcre2/APKBUILD
index ef1fa1492..7bca0e450 100644
--- a/system/pcre2/APKBUILD
+++ b/system/pcre2/APKBUILD
@@ -9,7 +9,7 @@ arch="all"
license="BSD-3-Clause"
depends=""
depends_dev="libedit-dev zlib-dev"
-makedepends="$depends_dev paxmark"
+makedepends="$depends_dev"
subpackages="$pkgname-dev $pkgname-doc $pkgname-tools
libpcre2-16:_libpcre libpcre2-32:_libpcre"
source="https://ftp.pcre.org/pub/pcre/$pkgname-$pkgver.tar.gz"
diff --git a/system/ruby/APKBUILD b/system/ruby/APKBUILD
index e608e4637..537c1010a 100644
--- a/system/ruby/APKBUILD
+++ b/system/ruby/APKBUILD
@@ -31,11 +31,18 @@
# - CVE-2019-8323
# - CVE-2019-8324
# - CVE-2019-8325
+# 2.5.7-r0:
+# - CVE-2012-6708
+# - CVE-2015-9251
+# - CVE-2019-15845
+# - CVE-2019-16201
+# - CVE-2019-16254
+# - CVE-2019-16255
#
pkgname=ruby
-pkgver=2.5.5
+pkgver=2.5.7
_abiver="${pkgver%.*}.0"
-pkgrel=2
+pkgrel=0
pkgdesc="An object-oriented language for quick and easy programming"
url="https://www.ruby-lang.org/"
arch="all"
@@ -307,7 +314,7 @@ _mvgem() {
done
}
-sha512sums="06b1d58536ebfacb7b56c1e6ed4b8ab816fadc4f48c845a452554cd262e7908199a30e5793f3cbaec2db56a8803aa5c6089abf7bf06c8fc47867e97870b7dfec ruby-2.5.5.tar.xz
+sha512sums="63b7c75fab44cd1bd22f22ddec00c740cf379ac7240da0dfafcec54347766695faef47428ce1c433fd77fa96992e976c984697067fa526236d383b12adc9ce75 ruby-2.5.7.tar.xz
20e7e5ee9936a93872fe1ad836dd1fde001fe4a0e7ed54c26727ad83da3ceb0e6247681d9dd4f98a69e1b0250703ed8fc682d44075780d5f47faa1d5f58d2bdb rubygems-avoid-platform-specific-gems.patch
814fe6359505b70d8ff680adf22f20a74b4dbd3fecc9a63a6c2456ee9824257815929917b6df5394ed069a6869511b8c6dce5b95b4acbbb7867c1f3a975a0150 test_insns-lower-recursion-depth.patch
e99b36940fa8fdd445d82738c70b8fc042cab042a4662cab156578aad2dac9673a96da22b6676aa36beac08070e92a7798c60d6f36eeb169216c4c51864ce2fe fix-get_main_stack.patch
diff --git a/system/strace/APKBUILD b/system/strace/APKBUILD
index 040754adc..1c6bcc854 100644
--- a/system/strace/APKBUILD
+++ b/system/strace/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=strace
-pkgver=5.2
+pkgver=5.3
pkgrel=0
pkgdesc="A useful diagnositic, instructional, and debugging tool"
url="https://strace.io/"
@@ -51,6 +51,6 @@ package() {
make -j1 DESTDIR="$pkgdir" install
}
-sha512sums="41bea20215fa80ad90a5d49c41944e02774e715efda5e563b3714e5800933a5fca4a2392634193cf49c0752321a39e0c185bdbc9cfb8ee053b09a6bd5723da35 strace-5.2.tar.xz
+sha512sums="02b80a8abedb14e40235709733953005210cd328daba59cb594745e7ed3851d155546ccccdb3e43835aa75eee89f023324e542e15154bbc3269e37fd23433e2a strace-5.3.tar.xz
64bcd5a335d8117bf6d6eb1e47b47ef5d3df5bdc6e4c52379e0e8b099fd06e5d4fa362b3b88fbacec350783f65de589f2fb562d9df04e2895c8a74c8198e6cea fix-ppc-pt-regs-collision.patch
6616161b6e015c5e56b7171995d28ab63a865156b7f9826b4be26beaac863f0ebc341014910ea53157a810c6afafc10ce80b2d31f4d649d28718a9be78795c6c nlattr-fix.patch"
diff --git a/system/sudo/APKBUILD b/system/sudo/APKBUILD
index 6b8685d86..2cb62343a 100644
--- a/system/sudo/APKBUILD
+++ b/system/sudo/APKBUILD
@@ -9,7 +9,7 @@ if [ "${pkgver%_*}" != "$pkgver" ]; then
else
_realver=$pkgver
fi
-pkgrel=0
+pkgrel=1
pkgdesc="Give certain users the ability to run some commands as root"
url="https://www.sudo.ws/sudo/"
arch="all"
@@ -42,7 +42,9 @@ build() {
--with-env-editor \
--with-pam \
--without-skey \
- --with-passprompt="[sudo] Password for %p: "
+ --with-passprompt="[sudo] Password for %p: " \
+ --with-insults=disabled \
+ --with-all-insults
make
}
diff --git a/system/texinfo/APKBUILD b/system/texinfo/APKBUILD
index 329bdfcdc..f11ebab45 100644
--- a/system/texinfo/APKBUILD
+++ b/system/texinfo/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=texinfo
-pkgver=6.6
+pkgver=6.7
pkgrel=0
pkgdesc="Utilities to manage on-line documentation"
url="https://www.gnu.org/software/texinfo/"
@@ -30,4 +30,4 @@ package() {
gzip "$pkgdir"/usr/share/info/*
}
-sha512sums="96e0764d0808152d3662e65c3287fb0f86ed918912cdc036380637dbadaacd6a489b516543c07b08105686575e8d495a945f73e23ff0909d5a0f12026e4131e0 texinfo-6.6.tar.xz"
+sha512sums="da55a0d0a760914386393c5e8e864540265d8550dc576f784781a6d72501918e8afce716ff343e5c2a0ce09cf921bfaf0a48ecb49f6182a7d10e920ae3ea17e7 texinfo-6.7.tar.xz"
diff --git a/system/tzdata/APKBUILD b/system/tzdata/APKBUILD
index dc641bde4..cdcbdbc26 100644
--- a/system/tzdata/APKBUILD
+++ b/system/tzdata/APKBUILD
@@ -2,8 +2,8 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=tzdata
-pkgver=2019b
-_tzcodever=2019b
+pkgver=2019c
+_tzcodever=2019c
_ptzver=0.5
pkgrel=0
pkgdesc="Time zone data"
@@ -54,7 +54,7 @@ package() {
"$pkgdir"/usr/bin/posixtz
}
-sha512sums="bcfb417fe3b7c39e702da0090291db0489744f733010ae183007fce5e441bfce885fb25ed11730cf7f363572e107d7ff0c4b38691bb99def2d8cf7017c05720f tzcode2019b.tar.gz
-c0104078d994e501d80a41bea31364b1390a75c2fbf42968a8343a090e2ac2eddbc58770ca470b192ea19dec89fcc634141a1de703ea2ffa0325176a64afe1fc tzdata2019b.tar.gz
+sha512sums="61ef36385f501c338c263081486de0d1fccd454b86f8777b0dbad4ea3f21bbde059d0a91c23e207b167ed013127d3db8b7528f0188814a8b44d1f946b19d9b8b tzcode2019c.tar.gz
+2921cbb2fd44a6b8f7f2ed42c13fbae28195aa5c2eeefa70396bc97cdbaad679c6cc3c143da82cca5b0279065c02389e9af536904288c12886bf345baa8c6565 tzdata2019c.tar.gz
68dbaab9f4aef166ac2f2d40b49366527b840bebe17a47599fe38345835e4adb8a767910745ece9c384b57af815a871243c3e261a29f41d71f8054df3061b3fd posixtz-0.5.tar.xz
f54ce213d74c5a8387e1a7c56299bc6eee65a035772288222128abc249a112067b8791b88b45c342b2d4d8d12e9e4f1f2f5c92c5de67f8b6413b1ebf1d7de467 0001-posixtz-fix-up-lseek.patch"
diff --git a/system/xfsprogs/APKBUILD b/system/xfsprogs/APKBUILD
index 52ae967b5..868e90131 100644
--- a/system/xfsprogs/APKBUILD
+++ b/system/xfsprogs/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Valery Kartel <valery.kartel@gmail.com>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=xfsprogs
-pkgver=5.2.0
-pkgrel=1
+pkgver=5.2.1
+pkgrel=0
pkgdesc="XFS filesystem utilities"
url="http://xfs.org/index.php/Main_Page"
arch="all"
@@ -48,6 +48,6 @@ base() {
mv "$subpkgdir"/sbin/xfs_scrub "$pkgdir"/sbin/
}
-sha512sums="ddc01a3aca3d84a2bb848a3954b1704056d0fc3fb302981bf67208e0435cf3887f44eefcdb40460b576fbe6cfb26a48ad6f032092829b3a2bb1ca4fae9fcc5f4 xfsprogs-5.2.0.tar.gz
+sha512sums="4bf598b811dddae8dfc7e7086a157a53667602c80a34b0d037f94d3d8e35ad7172ac0b89ba83118a3bfa85d1127982cdb08fb3e30f38b63e3f124d19267d6532 xfsprogs-5.2.1.tar.gz
c23d5dca744c4589ede517701fc8ea02f9b7a59568d907269048741806d2e6c9e56ed3493163d63dbf16193ff99471206548b25efcda18e3e5dff14eb38066d4 fix-mmap.patch
29c77c550fa8f7a0b3794649d278a2cb3a65c9368db19415866910160adb6d5a52f1be4f8713b58c5c87f149b6212c068ae27a4547a6c4e4fe7b1584e1261dae no-utmp-header.patch"
diff --git a/system/zstd/APKBUILD b/system/zstd/APKBUILD
index 72ae16746..89f6ed7a0 100644
--- a/system/zstd/APKBUILD
+++ b/system/zstd/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: A. Wilcox <awilfox@adelielinux.org>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=zstd
-pkgver=1.4.2
+pkgver=1.4.3
pkgrel=0
pkgdesc="Fast real-time compression algorithm"
url="https://facebook.github.io/zstd/"
@@ -25,4 +25,4 @@ package() {
make PREFIX="/usr" DESTDIR="$pkgdir" install
}
-sha512sums="b760f201ff8d018c422b030d3f59245b5f1cfd157ba8d6eb9fe9240e23d5739ca7b5a705b2d5e8ace703d041ab77bea66d735b283e51facfb18923794fabe213 zstd-1.4.2.tar.gz"
+sha512sums="cb36772a59f79922e65c0f869384dca4ef2948c1d1440abcddecc7e3838efee5b547dad97b9023cdcf17bf10a32412b8f3b20a5e16b79314e61074987edecfab zstd-1.4.3.tar.gz"