summaryrefslogtreecommitdiff
path: root/system
diff options
context:
space:
mode:
Diffstat (limited to 'system')
-rw-r--r--system/openssh/APKBUILD2
-rw-r--r--system/perl/APKBUILD4
2 files changed, 1 insertions, 5 deletions
diff --git a/system/openssh/APKBUILD b/system/openssh/APKBUILD
index 38d947585..10eee5514 100644
--- a/system/openssh/APKBUILD
+++ b/system/openssh/APKBUILD
@@ -136,7 +136,7 @@ server() {
pkgdesc="OpenSSH server"
depends="openssh-client openssh-keygen"
replaces="openssh-server-common"
- cd "$builddir"
+
install -d "$subpkgdir"/usr/sbin
install -d "$subpkgdir"/etc/ssh
mv "$pkgdir"/usr/sbin/sshd "$subpkgdir"/usr/sbin/
diff --git a/system/perl/APKBUILD b/system/perl/APKBUILD
index 0fc25d609..f65edd034 100644
--- a/system/perl/APKBUILD
+++ b/system/perl/APKBUILD
@@ -37,7 +37,6 @@ _archlib=/usr/lib/perl5/core_perl
prepare() {
chmod +w "$builddir"/*.c
default_prepare
- cd "$builddir"
sed -e 's/less -R/less/g' \
-e 's/libswanted="\(.*\) nsl\(.*\)"/libswanted="\1\2"/g' \
-i ./Configure ||
@@ -50,7 +49,6 @@ prepare() {
}
build() {
- cd "$builddir"
BUILD_ZLIB=0
BUILD_BZIP2=0
BZIP2_LIB=/usr/lib
@@ -89,12 +87,10 @@ build() {
}
check() {
- cd "$builddir"
make test
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
if [ -n "$(find $pkgdir/usr/local -type f)" ]; then
error "files found under /usr/local"