summaryrefslogtreecommitdiff
path: root/system
diff options
context:
space:
mode:
Diffstat (limited to 'system')
-rw-r--r--system/openssh/APKBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/system/openssh/APKBUILD b/system/openssh/APKBUILD
index c17e23c4b..3c877c3c8 100644
--- a/system/openssh/APKBUILD
+++ b/system/openssh/APKBUILD
@@ -4,7 +4,7 @@
pkgname=openssh
pkgver=9.9_p2
_myver=${pkgver%_*}${pkgver#*_}
-pkgrel=0
+pkgrel=1
pkgdesc="Remote login tool using encrypted SSH protocol"
url="https://www.openssh.com/portable.html"
arch="all"
@@ -137,8 +137,12 @@ server() {
replaces="openssh-server-common"
install -d "$subpkgdir"/usr/sbin
- install -d "$subpkgdir"/etc/ssh
mv "$pkgdir"/usr/sbin/sshd "$subpkgdir"/usr/sbin/
+
+ install -d "$subpkgdir"/usr/lib/ssh
+ mv "$pkgdir"/usr/lib/ssh/sshd-session "$subpkgdir"/usr/lib/ssh/
+
+ install -d "$subpkgdir"/etc/ssh
mv "$pkgdir"/etc/ssh/sshd_config "$subpkgdir"/etc/ssh/
}